Upgraded the GPU but the performance still the same

Discussion in 'Wii U - Emulation & CEMU' started by leandrosrds, Mar 2, 2017.

  1. leandrosrds
    OP

    leandrosrds Newbie

    Newcomer
    2
    0
    Mar 2, 2017
    Brazil
    Running Mario kart 8 in my PC(Core i7 3770k 3.7ghz) , 16gb RAM, SSD 256gb, and GPU geforce 680 gtx 2gb with some slowdowns to 14-18 fps while playing.

    Now that I upgraded the GPU to Geforce 1070 GTX 8GB, the performance stills the same !!

    I need hints to improve the performance please
     
  2. gman666

    gman666 Cubicle Expert

    Member
    183
    113
    Jun 4, 2011
    United States
    a cubicle
    Have you formed a cache for MK8 yet? Your specs are fine, however, I wouldn't doubt a problem with your settings
     
    Last edited by gman666, Mar 2, 2017
  3. Glyptofane

    Glyptofane GBAtemp Advanced Fan

    Member
    575
    293
    Feb 12, 2009
    United States
    Emulation relies more on CPU than GPU.
     
    Molhel likes this.
  4. Molhel

    Molhel GBAtemp Regular

    Member
    135
    43
    Jan 23, 2017
    United States
    Phantom Forest
    Yup! Plus the emulator is still in the baby steps, so optimization isn't Dolphin level.
     
    NoNAND likes this.
  5. leandrosrds
    OP

    leandrosrds Newbie

    Newcomer
    2
    0
    Mar 2, 2017
    Brazil
    Thanks for the tips guys,
     
  6. PPN

    PPN Newbie

    Newcomer
    5
    0
    Mar 10, 2017
    Italy
    Get a proper CPU cooler and overclock your CPU to around 4.5Ghz.