Upgraded eeePC's RAM, now it won;t start up :(

Discussion in 'Computer Games and General Discussion' started by War, Jun 12, 2009.

Jun 12, 2009
  1. War
    OP

    Member War Take it easy~

    Joined:
    Oct 26, 2007
    Messages:
    5,409
    Location:
    California
    Country:
    Japan
    As the thread title says, I bought a 2Gb Crucial RAM stick to upgrade the default 1Gb. I looked up a video on how to do the upgrade and everything. So I removed the battery, took out the 2 screws in the back faceplate, removed the faceplate, unhinged the two metal holder thingies and the old RAM popped right up as it's supposed to. Took it out, got the new one out of the package, lined it up perfectly, and placed it in. I put everything back, turned on the eeePC, and all of a sudden in 5 seconds or so it turns off. After that, every time I turn it on, it just shows a completely black screen. The lights come up so I know SOMETHING is happening, but the screen is just black and there's no noise coming from the machine at all. I opened it back up and tried to push the RAM a little bit more in (just in case I had placed it wrong), but that didn't solve anything. How can i fix this?

    PS: This is the video I followed
     
  2. raulpica

    Supervisor raulpica With your drill, thrust to the sky!

    Joined:
    Oct 23, 2007
    Messages:
    10,672
    Location:
    _____________ PowerLevel: 9001
    Country:
    Italy
    Tried to put the old RAM in and seeing if it works with that?
     
  3. War
    OP

    Member War Take it easy~

    Joined:
    Oct 26, 2007
    Messages:
    5,409
    Location:
    California
    Country:
    Japan
    Finally got it working! Thanks for all the help raulpica! (Not really, but at least you bothered to post [​IMG])
     
  4. Salamantis

    Member Salamantis GBAtemp Advanced Maniac

    Joined:
    Feb 20, 2007
    Messages:
    1,945
    Country:
    Canada
    I'm pretty sure you forgot to disable the BIOS Booster, right? Same happened to me on my 1000HE [​IMG]
     
  5. playallday

    Member playallday Group: GBAtemp Ghost

    Joined:
    May 23, 2008
    Messages:
    3,773
    Location:
    [@N@[)@
    Country:
    Canada
    I hope you grounded yourself...
     

Share This Page