Updating CFW from 5.00 M33-6

Discussion in 'PSP - Games & Content' started by Leo Cantus, Oct 11, 2009.

  1. Leo Cantus
    OP

    Leo Cantus So zeta slow!

    Member
    832
    0
    May 23, 2009
    England
    On my PSP 1000 I have 5.00 M33-6 cfw. I want to update to 5.50 so I can play some new games such as Final Fantasy VII which I have from the PSN Store. I was just wondering what its best to upgrade to, like the latest custom firmware. I have heard of gen a and b. Which is the latest one? And apparently these arent as good as the m33 cfw...
    So, what should I upgrade to? What is the latest, best cfw? Suggestions please
    Thanks [​IMG]
     
  2. nico445

    nico445 GBAtemp Advanced Fan

    Member
    579
    9
    Apr 27, 2008
    Netherlands
    my house.
    just upgrade to 5.50 GEN B first download Gen-a Install it then install the quik updater B and then the b2 updater
     
  3. Leo Cantus
    OP

    Leo Cantus So zeta slow!

    Member
    832
    0
    May 23, 2009
    England
    Oh, okay. I'm guessing that B-2 is the latest cfw, what is the difference between b-2 and b and a?
    thanks for the help
     
  4. themuddaload

    themuddaload Creepin' hardcore.

    Member
    1,099
    0
    May 4, 2008
    United States
    West of the equator Sex: sure
  5. riddle43

    riddle43 GBAtemp Fan

    Member
    376
    0
    Nov 21, 2008
    United States
    Mich USA
    go the way themuddaload said thats the way i did it took 2 min and i was playing all the new games when fixed right so good luck
     
  6. taken

    taken GBAtemp Advanced Fan

    Member
    520
    2
    Dec 23, 2008
    United Kingdom
    Do this one XGEN UPDATER and XGEN Pandora DCv8 converter.

    You can go from 5.00m33-6 straight to 5.50genb2 with no problems at all.
     
  7. themuddaload

    themuddaload Creepin' hardcore.

    Member
    1,099
    0
    May 4, 2008
    United States
    West of the equator Sex: sure
    not reading previous posts ftl...
     
  8. Shardnax

    Shardnax GBAtemp Regular

    Member
    179
    1
    Aug 23, 2008
    United States
    Why don't you just get an EBOOT and use popsloader...?
     
  9. sadak5

    sadak5 GBAtemp Fan

    Member
    421
    0
    Feb 27, 2007
    Mexico
    Mexico City
    That's only for PS games.

    You can either update or fix the ISOS to play using 5.00 M33
    Just use game decrypter v4 to fix the iso for m33.
     
  10. Raiser

    Raiser I am mad scientist.

    Member
    1,565
    40
    May 31, 2008
    Canada
    Yeah, if you want to play any PSX games, just get the EBOOTs. o.o

    People are making use of the Game Decrypter to make fixes for games. Almost all the "better known" recently released games have fixes for M33 now like SC, Motorstorm, etc.

    I'm personally staying at 5.00 M33 until newly released games somehow become impossible to create fixes for. (:

    Having a fun time with the Minis right now. ;D
     
  11. zektor

    zektor GBAtemp Maniac

    Member
    1,325
    22
    Nov 29, 2005
    United States

    Thanks for the advice! I've been neglecting my good ol' PSP(s) since I started hacking the Wii and was wondering if there had been a development in the firmware department. Upgraded both my slim units to the new Gen-b2, and I have to say it is absolutely fantastic. The new pandora stick it generates (well, new to me) is very very nice as well! Thanks again!