Updated SX 2.4 lost almost everything

Discussion in 'Switch - Backup Loaders & Modchips' started by RedHunter, Dec 13, 2018.

  1. RedHunter
    OP

    RedHunter GBAtemp Fan

    Member
    6
    Dec 12, 2014
    Italy
    After booting my Switch with the new 2.4 update I lost all the nsp files like updates, games and dlcs. It says it needs to download them. Why this happened? Luckily I have all my nsp on my pc but still its annoying having to remove them from the console (the icons) and installing them all over again.
     
    Last edited by RedHunter, Dec 13, 2018
  2. NeoSlyde

    NeoSlyde Let us start the game

    Member
    10
    Mar 6, 2015
    France
    Morocco
    Screens?
     
  3. AaronUzumaki

    AaronUzumaki A.K.A. Ecstasy Espeon

    Member
    6
    GBAtemp Patron
    AaronUzumaki is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Feb 8, 2009
    United States
    Akron, Ohio
    If you installed a new emuNAND via the new method, it formats the SD card. Is that the issue perhaps?
     
  4. RedHunter
    OP

    RedHunter GBAtemp Fan

    Member
    6
    Dec 12, 2014
    Italy
    No I haven't done anything I just put the update there in the sd and power on the console :/
     
  5. voddy

    voddy No Title Available

    Member
    6
    Jul 14, 2013
    United States
    If you used exfat and didnt do emunand it might have corrupted your sd files. That might be the exfat bug while using homebrew. (Had that too)
     
  6. AaronUzumaki

    AaronUzumaki A.K.A. Ecstasy Espeon

    Member
    6
    GBAtemp Patron
    AaronUzumaki is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Feb 8, 2009
    United States
    Akron, Ohio
    Hm. Welp, I've expended my limited knowledge. Hope you figure it out, best of luck!
     
  7. mcmanic

    mcmanic Member

    Newcomer
    5
    Mar 1, 2007
    It’s certainly nothing to do with sxos as works fine here, probably just user error or because it’s a beta software
     
  8. FEF1

    FEF1 Sleep deprived sarcastic comments all the time!

    Member
    5
    Aug 22, 2018
    United States
    Someplace
    Wait, are you saying it isn’t a issues with software provided by TX (SXOS), but it is instead a error with software that TX provided (SXOS). Just because it is Beta doesn’t mean that it is not made by TX.
     
  9. ViperCorona

    ViperCorona Newbie

    Newcomer
    3
    Jun 7, 2018
    United States
    Pomona
    I noticed the same thing it moved my nsps from the emunand to the regular custom firmware....the saves and everything is still there
     
  10. fringle

    fringle GBAtemp Regular

    Member
    4
    Apr 16, 2009
    Canada
    Sounds like you booted ofw with the sd card inserted before loading cfw. This will clear the nintendo folder of all non legitimate titles and requires they be reinstalled.
    This is the reason TX introduced the emutendo folder for use with emunand.
     
    Last edited by fringle, Dec 13, 2018
    RedHunter likes this.
  11. Ra1d

    Ra1d GBAtemp Maniac

    Member
    8
    Jul 31, 2010
    Canada
    But do you have emuNAND ? if you do, try creating a folder called "Emutendo" on the root of your microSD and copy the contents of "Nintendo" folder into "Emutendo". If you already have "Emutendo," or don't have emuNAND at all, no idea.
     
    Blinkerz likes this.
  12. NateXIII

    NateXIII Member

    Newcomer
    3
    Aug 3, 2017
    Chile
    That happens because the "Emutendo folder", check your sd card, delete the "Emutendo" folder and then change the name of the "Nintendo" folder to "Emutendo".
     
    RedHunter likes this.
  13. RedHunter
    OP

    RedHunter GBAtemp Fan

    Member
    6
    Dec 12, 2014
    Italy
    Yes I already have emunand, just updated to 6.2.
    Can someone confirm this? What is this emutendo folder I just noticed it wasn't there before, it's also pretty big more that 10gb. Btw I almost reinstalled everything wasn't that painful thanks to multi nsp installation but if it happens again I want to be sure this emutendo procedure fixes all the files back?

    Now that I have reinstalled almost anything I have to still remove that emutendo folder?
     
  14. ninjistix

    ninjistix GBAtemp Regular

    Member
    5
    Aug 8, 2016
    United States
    sigh another case of people not reading the update instructions, when the previous version of their EmuNand was released they said that in order to migrate to the new Emunand you have to COPY AND RENAME YOUR NINTENDO TO EMUTENDO


    This is directly from the 2.3 Beta Release Notes
    Source: TX Forums
     
    RedHunter likes this.
  15. RedHunter
    OP

    RedHunter GBAtemp Fan

    Member
    6
    Dec 12, 2014
    Italy
    Ah I think I saw that but didn't give much importance but it turn out to be important my bad. Btw I just did that folder switch but didn't notice any difficence, for example that super big patch of Wolfenstein 2 is still missing.
     
  16. fringle

    fringle GBAtemp Regular

    Member
    4
    Apr 16, 2009
    Canada
    If you are not using emunand you do not need the emutendo folder and can remove it. If you are using emunand, the emutendo folder is the emunands copy of the nintendo folder so it does not get overwritten when booting ofw with the same sd card inserted. If you are using both OFW and CFW with emunand keep both the nintendo and emutendo folders as they both serve their purpose.

    From what I can understand by the comments is that you are not using emunand but the emutendo folder got created? Is this correct as that does not sound possible. As far as I'm aware the folder has to be created manually.
     
    RedHunter likes this.
  17. RedHunter
    OP

    RedHunter GBAtemp Fan

    Member
    6
    Dec 12, 2014
    Italy
    Oh now I understand you have been very clear. I'm using both ofw (since I'm not banned) and emunand but I really don't remember to have created that emutendo folder... Btw so did I messed up my ofw or something else now that I have deleted the Nintendo folder? Haven't tried yet I'm updating paladins and Warframe :(
     
  18. NateXIII

    NateXIII Member

    Newcomer
    3
    Aug 3, 2017
    Chile
    You don't remember because you didn't create it. SXOS 2.3 and above will create the Emutendo folder automatically if you are using emunand. That's why when you booted into the emunand your games where gone, because the emunand is reading the emutendo folder and your games are installed in the Nintendo folder that you should have named to "Emutando". Since you deleted the Nintendo folder you'll have to install the games again. Saves are stored on the NAND or in your case the Emunand so you won't have a problem with that. I don't think you messed up anything, next time though don't update immediately and read up on how this things work so something like this doesn't happen to you again.
     
    RedHunter likes this.
  19. StarGazerTom

    StarGazerTom GBAtemp Advanced Maniac

    Member
    10
    Feb 2, 2015
    Just rename your Nintendo folder to Emutendo. Everything will be back.
     
  20. fringle

    fringle GBAtemp Regular

    Member
    4
    Apr 16, 2009
    Canada
    Didn't really mess ofw up so to speak. Just that by removing the nintendo folder, any legit bought games or installed nsp files would have to be redownloaded or installed. It's really a non issue. The system will automatically recreate it the next time you boot to ofw and you can reinstall any legit eshop titles if your not banned.
     
    RedHunter likes this.
Quick Reply
Draft saved Draft deleted
Loading...