Update DSi Firmware - Yes or No?

Discussion in 'NDS - Flashcarts and Accessories' started by Shano56, Dec 28, 2010.

  1. Shano56
    OP

    Shano56 noobie

    Member
    877
    99
    Apr 29, 2010
    United States
    I'll try to make this quick, I haven't found a straight answer so I'll ask.

    My brother has a DSi with 1.4U firmware. I'm looking into getting a flashcart in the future to install homebrew for him, but for now, should I update the firmware to 1.4.1 with the intention for using a flashcart in the future? Basically, I'm wondering if the update is helpful at all and won't interfere with any intentions to hack in the future.
     
  2. Pyrmon

    Pyrmon Burnin' Monkey Love

    Member
    1,086
    14
    Sep 25, 2010
    Canada
    Montreal
    All the good flashcarts are updated to work with 1.4.1
    Go ahead, there's no problem. Also, which flashcart are you gonna get?
     
  3. anaxs

    anaxs got milk, got candy

    Member
    2,208
    1
    Mar 23, 2009
    Canada
    your moms jeans pocket
    it depeneds what flashcard you get. if the m3 or any other card that can be updated without a ds, then you can update, but if its a card like an ak2i, makes sure u have a ds lite/phat or anything below dsi v1.3 so that you can update the card for it to work on the dsi 1.4, if you dont, do not update it until ou have your card. the upsate doesnt really change anything, it just blocks falsh cards, but you also wont be able to access the dsi shop
     
  4. Shano56
    OP

    Shano56 noobie

    Member
    877
    99
    Apr 29, 2010
    United States
    Thanks for the quick answer!

    Not sure about which flashcart, still debating and looking into discussions and opinions on the best [​IMG]
     
  5. Vigilante

    Vigilante TempLurker

    Member
    1,555
    46
    Jan 1, 2010
    CyberSpace IQ:OVER 9000
    Just dont update man,if your going to use a flashcart.
    The update is useless and it will render some flashcarts useless unless you instaled the fix in your flashcart first
     
  6. Pyrmon

    Pyrmon Burnin' Monkey Love

    Member
    1,086
    14
    Sep 25, 2010
    Canada
    Montreal
    I would suggest an Acekard 2i(but you will need another ds to update it) because it has quite a few features and it's still cheap. Or an R4i Gold if you want a bit cheaper and with slightly less features. Otherwise there's the DSTWO which is pretty much the best one out there.
     
  7. EvangelionEX

    EvangelionEX GBAtemp Regular

    Member
    260
    0
    Dec 17, 2010
    Senegal
    I don't see why not. Tons of flashcarts out there can support 1.4.1U except for some exception of Acekard 2i which needs to be flashed in a DS system which is lower than firmware 1.3. DSi's default version is already 1.4U and makes no difference if you upgrade it because you also can't flash it no matter what.

    As for flashcart recommendation.

    R4i Gold is very cheap, but the features isn't that much and attractive, good for playing games. Acekard 2i have more features compared to R4i Gold and have good compatibility so you don't really have to worry much about game compatibility problems. Same as DSTWO(which is probably the best card out there currently), nifty functions and good game compatibility though it might cost a little bit higher. Don't buy M3 though. Their updates are not often and I heard it's one of the worse card out there.
     
  8. haddad

    haddad GBAtemp Advanced Maniac

    Member
    1,519
    16
    Aug 12, 2010
    Canada
    check my sig >_
     
  9. Presto99

    Presto99 You slammin, bro?

    Member
    913
    60
    Feb 24, 2010
    United States
    Skyworld
    You should be getting an AK2i, R4i Gold, or SCdstwo. All those work on 1.4.1, but you might want to wait until after you get the cart to update to 1.4.1.
     
  10. Evo.lve

    Evo.lve All that you could be.

    Member
    1,786
    21
    Oct 11, 2010
    Away from you.
     
  11. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,129
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Any cart that's updateable to bypass 1.4.1 (besides M3i0 and DStwo) will end to be run in a DS other than the original if the original was updated to 1.4.1 before the card was, because the DS won't run the card for it to update itself.

    M3i0 has a flashing cable and the DS2 has a built-in CPU to bypass that.