Update CFW

Discussion in '3DS - Flashcards & Custom Firmwares' started by weetbix, Apr 19, 2015.

  1. weetbix
    OP

    weetbix Member

    Newcomer
    13
    3
    Apr 19, 2015
    Hi, I was wondering is it possible to update Palantine's CFW to a higher version say like 9.5? I have a
    theory and I think it could work. Firstly you would have to have CFW on your big sd card, 2nd you have bigbluemenu.cia installed, 3rd go into your CFW and run bigbluemenu and manually update FW by downloading the 9.5 firmware through 3DSNU. Would this work? Also another thought is could I format the big sdcard and put emunand on it, put PBT-CFW on it, install bigbluemenu.cia, go into emunand, go into bigbluemenu and update firmware?

    Thanks.
     
    Margen67 likes this.
  2. Loaffy

    Loaffy GBAtemp Regular

    Member
    136
    45
    Mar 27, 2015
    Canada
    When you update the emuNAND, whether through Nintendo's official servers or via another method, Palantine cfw will fail to work any more. The exploit(s) it uses to boot will be patched. Many other things will be patched/changed/incompatible.

    I don't think there is any way to avoid this, though I guess I've never seen anyone flatout say that you can't install a partial update. That would probably brick emuNAND though, or else the files that you want to update would also be the files that break things.

    Anyways I'm 99.9% sure this is impossible, but new cfws can be written and currently are - though whether or not they will include features you want, or be released to the public, is up in the air.
     
  3. weetbix
    OP

    weetbix Member

    Newcomer
    13
    3
    Apr 19, 2015
    Thanks mate for the prompt reply and good comprehensive detail. Is there other CFW where the firmware is higher than 4.5? I only know of palantine CFW. I tried the 2nd theory. I was able to see bigbluemenu in GW emunand menu title screen but I couldn't open, so I wasn't able to manually update the FW.
    I don't have a GW card, I have a 3dslink card and I can't access emunand it goes blank when I hold down L. I've tried using the GW launcher but it doesn't detect my 3dslink red card. Since I can't update the 3dslink FW. I'm hope there is a method like running .cia games on a big sdcard through bigbluemenu on a higher CFW (4.5+). If anyone knows of a method? Would be awesome if you could share. Thanks.
     
    Margen67 likes this.
  4. Loaffy

    Loaffy GBAtemp Regular

    Member
    136
    45
    Mar 27, 2015
    Canada
    I wish B-)

    Technically GW is a cfw, but of course it requires a DRM GW card.

    There is also rxTools cfw (rxMode) but it is strictly an emuNAND solution for old3DS meaning you can only play legit* games or eShop purchases. rxTools does offer some file injecting/extraction options as well as a few others, though.


    I don't know much about this card, only vaguely remember hearing about it, but I know that gateway does not have 9.6 support yet. I'm not sure what version your emuNAND is on, but if you updated it to 9.6 that might be why it doesn't work. Or maybe 3DSlink just has some other issues, I'm not sure.

    Outside of buying a gateway card (which doesn't support 9.6 emuNAND and might possibly not support it ever), not really. You can buy a sky3DS card but it strictly plays ROMS and requires a bit of a process for playing online without getting banned.

    *There is one way I know of to run a handful of games as .cias on a firmware higher than 4.5. There are legit .cias (basically ripped versions of preinstalled games that came in bundles) which will run without any signature patches/hacks (but will require signature patches/cfw to be installed in the first place). Therefore you can install these .cias to an emuNAND/cfw(redNAND) and then update that emuNAND (using rxTools/rxMode) and the games will still boot even though rxTools offers no signature patching/"backup" features/etc. I'll send you a PM of where you can find a list of these games. You can look at these threads for more info if interested in this;
    https://gbatemp.net/threads/tutorial-installing-clean-cias-with-4-5-cfw.385285/
    https://gbatemp.net/threads/i-found-a-eshop-bug-on-this-a-good-one.385185/

    So basically other than buying a gw, buying a sky3DS and sticking to .3ds ROMS, or using cfw/rxTools to play about a dozen legit .cia games (many of which can already be played on 4.5 cfw), your only other option is to wait for a new cfw to be released to the public and hope it has the features you want.
     
    Margen67 likes this.
  5. Rudy69

    Rudy69 Member

    Newcomer
    36
    13
    Oct 31, 2006
    Canada
    I made the mistake of "upgrading" my emunand to 9.5 twice (I thought I messed up the first time), until I read online that you can't upgrade. It's a shame but can't complain
     
    Margen67 likes this.
  6. weetbix
    OP

    weetbix Member

    Newcomer
    13
    3
    Apr 19, 2015
    Just finished work, damn I hate retail. Thankfully I'm not at the checkouts haha, sucks to be them saying the same spiel again. Work in the produce department, I'm a peon saying in my head "work, work". Anyway Thanks for the reply people. I'll give the tutorials a shot. I also came across this website and I think this could possibly work for what I'm trying to do. http://www.maxconsole.com/maxcon_fo...-Dual-boot-Emunand-CFW-(NinjaHax)-one-SD-card. I'm not sure if I'll be able to run bigbluemenu when I switch from the CFW to emunand?
    I think for some retarded reason they removed the GUI from the 3dslink launcher.bat, so when I hold down L to access it, the screen goes white and freezes. The 3ds link I think is a clone from the r4i 3ds card as the same thing happens when I use the r4i launcher. Another thing is I have tried putting the GW launcher on the big sd card but every time I update it via internet the screen goes black when I try to access the updated Emunand. I can't update it manually through a rom because the GW Emunand doesn't respond when I put in my 3dslink red card :(. Well I learned a good lesson GW FTW and clones are shit. I really hope this dual nand thing works. Really wanting to play super smash.
     
    Margen67 likes this.
  7. aenoch

    aenoch GBAtemp Advanced Fan

    Member
    740
    44
    Feb 23, 2015
    United States
    Ludington, Michigan
    ust set up rx tools change the emunand region to europe and install the legit smash cia
     
    Margen67 likes this.
  8. DarkFlare69

    DarkFlare69 GBAtemp Psycho!

    Member
    4,681
    2,509
    Dec 8, 2014
    United States
    Ohio
    Set up rxTools and change the emuNAND region to Europe and install the legit Sm4sh CIA.
     
    Margen67 likes this.
  9. MrJason005

    MrJason005 √2

    Member
    2,092
    1,156
    Nov 26, 2014
    Greece
    Κάπου
    think of it like this:
    you know how we are currently waiting for a 9.6 emunand from gateway right now, yes?
    well, think of it like we're waiting (permanently) for a 9.5 emunand for palantine cfw, unless someone got to work and managed a 9.5 rednand, then your idea won't work

    if you want smash and such, i'd say use PBT, install a legit smash CIA, use 3DSNUS and get a 9.0 update for your 3DS, install that update for your sysnand via PBT, and play smash or pokemon etc etc
    if you had a NAND backup and a solder job, you could also simply update from the settings menu to 9.6 and boot up the legit CIA, and when you want to go back just flash the NAND backup to the motherboard NAND chip, no harm done
     
    Margen67 likes this.