ULTIMATE System Menu 4.0 Guide

Discussion in 'Wii - Hacking' started by assassda, Apr 1, 2009.

Thread Status:
Not open for further replies.
  1. assassda
    OP

    assassda GBAtemp Regular

    Member
    283
    0
    Jul 31, 2004
    United States
    <!--sizeo:5--><span style="font-size:18pt;line-height:100%"><!--/sizeo--><!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->This is the ULTIMATE Tutorial for everything you need for System Menu 4.1<!--fontc--></span><!--/fontc--><!--sizec--></span><!--/sizec-->
    <!--coloro:red--><span style="color:red"><!--/coloro--><!--sizeo:4--><span style="font-size:14pt;line-height:100%"><!--/sizeo-->for EUR and USA Wiis only not JAP or KOREAN

    <b>There are two methods described in this guide. Online and completely Offline installations. The Online installation is the safer method. They should both work on ANY Wii besides LU64+. You only need to use one guide, they both do the same thing. Please read the entire thread including FAQ before asking a question.</b><!--sizec--></span><!--/sizec--><!--colorc--></span><!--/colorc-->


    <!--sizeo:4--><span style="font-size:14pt;line-height:100%"><!--/sizeo--><b>Online Downgrade/Upgrade</b><!--sizec--></span><!--/sizec-->

    Prerequisites:
    --SD card
    --Wifi Connection (Ethernet doesnt work)
    --Unplug any Gamecube Memory Cards, Gamecube Controllers, USB Devices
    <!--sizeo:3--><span style="font-size:12pt;line-height:100%"><!--/sizeo--><b>--Read the FAQ and be prepared with a general knowledge of Wii Homebrew</b><!--sizec--></span><!--/sizec-->

    <a href="http://www.mediafire.com/?omntyolyjm5" target="_blank">http://www.mediafire.com/?omntyolyjm5</a> (08-31-09)

    1) Format your SD card to FAT16. Copy the contents inside the sd folder to the root of your SD card

    <b>If you have bootmii with a nand backup, the homebrew channel, and cios installed already you may skip to step 8</b>

    2) Insert the SD card in the Wii and go to Data Management>Channels>SD Card press YES on the dialog box that asks to load boot.dol

    3) Install the Homebrew Channel and install BootMii as boot2 if possible or as an IOS if boot2 is not available.

    4) Launch Bootmii (if you installed to boot2 just reset the system if you installed to IOS go to the HBC and press the Home button)

    5) Open the config menu (gears) and choose backup NAND (green arrow) wait for it to finish and restart the Wii

    6) Run Trucha Bug Restorer and choose "IOS36" and pick "Downgrade IOS15" and "Download IOS from NUS" then restart

    7) Run Trucha Bug Restorer again and choose "IOS15" then "IOS36 menu" set "IOS to slot 36" and "yes" "yes" "yes" to the 3 options then press "Install patched IOS36" and "Download IOS from NUS"

    8) Install cIOS36 rev10 to IOS249 using Network install mode

    9) Downgrade system IOS files using IOS Downgrader

    10) Downgrade to 3.2 using cIOS Downgrader even if you are already on 3.2 run this

    11) Run 4.1 Firmware-Updater.

    12) Using Dop-IOS install IOS60 v6174 with Sig Hash Check.

    13) Install preloader. On the install screen press 1

    14) Set your preloader settings. In preloader hacks enable "Skip disc update check"


    ---------------------------------------------------------------------


    <!--sizeo:4--><span style="font-size:14pt;line-height:100%"><!--/sizeo--><b>Offline Downgrade/Upgrade</b><!--sizec--></span><!--/sizec-->

    Prerequisites:
    --SD card
    --Unplug any Gamecube Memory Cards, Gamecube Controllers, USB Devices
    <!--sizeo:3--><span style="font-size:12pt;line-height:100%"><!--/sizeo--><b>--Read the FAQ and be prepared with a general knowledge of Wii Homebrew</b><!--sizec--></span><!--/sizec-->

    <a href="http://www.mediafire.com/?m2d4dq0njlb" target="_blank">http://www.mediafire.com/?m2d4dq0njlb</a> (08-31-2009)

    <!--sizeo:2--><span style="font-size:10pt;line-height:100%"><!--/sizeo--><b><!--coloro:red--><span style="color:red"><!--/coloro-->This package contains instructions on how to acquire the necessary files from Nintendo to do an offline update
    This package will work on ANY Wii! Virgin or Nintendo Official Updated without cios!!<!--colorc--></span><!--/colorc-->
    </b><!--sizec--></span><!--/sizec-->
    1) Extract the files somewhere on your hard drive such as C:\wii\ and run prepare.bat and choose your desired version

    2) Check that the WAD files are correct with MooSFV. If any files are not correct run clean.bat and start over

    3) Format your SD card to FAT16. Copy the contents inside the sd folder to the root of your SD card

    <b>If you have bootmii with a nand backup, the homebrew channel, and cios installed already you may skip to step 10</b>

    4) Insert the SD card in the Wii and go to Data Management>Channels>SD Card press YES on the dialog box that asks to load boot.dol

    5) Install the Homebrew Channel and install BootMii as boot2 if possible or as an IOS if boot2 is not available.

    6) Launch Bootmii (if you installed to boot2 just reset the system if you installed to IOS go to the HBC and press the Home button)

    7) Open the config menu (gears) and choose backup NAND (green arrow) wait for it to finish and restart the Wii

    8) Run Trucha Bug Restorer and choose "IOS36" and pick "Downgrade IOS15" and "Load IOS from sd card" then restart

    9) Run Trucha Bug Restorer again and choose "IOS15" then "IOS36 menu" set "IOS to slot 36" and "yes" "yes" "yes" to the 3 options then press "Install patched IOS36" and "Load IOS from sd card"

    10) Run cIOS36_rev10-Installer and choose WAD Installation

    11) Run WAD-Manager_v1.4 again. Choose IOS249 and install WADs 01-18. If WAD Manager freezes during installation just try again from the WAD it froze on.

    12) While still in WAD Manager install SystemMenuv###.wad

    13) It is highly recommended that you install preloader to prevent bricks. On the install screen press 1

    14) Hold reset while powering on to access preloader and set preloader settings. In preloader hacks enable "Skip disc update check"


    ---------------------------------------------------------------------


    <!--sizeo:4--><span style="font-size:14pt;line-height:100%"><!--/sizeo--><!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto--><!--coloro:green--><span style="color:green"><!--/coloro-->You can now use Backup Loaders and run Virtual Console and WiiWare from the SD Channel!<!--colorc--></span><!--/colorc--><!--fontc--></span><!--/fontc--><!--sizec--></span><!--/sizec-->

    I recommend Backup Launcher NeoGamma for Wii Backups

    <a href="http://www.gbatemp.net/index.php?showtopic=158884" target="_blank">http://www.gbatemp.net/index.php?showtopic=158884</a>

    If you want Gamecube backups install the custom MIOS and use Gamecube Backup Launcher 0.2

    <a href="http://gbatemp.net/index.php?showtopic=142535" target="_blank">http://gbatemp.net/index.php?showtopic=142535</a>

    You can also now install a USB Loader. I reccomend USB Loader GX

    <a href="http://gbatemp.net/index.php?showtopic=149922" target="_blank">http://gbatemp.net/index.php?showtopic=149922</a>


    <!--sizeo:3--><span style="font-size:12pt;line-height:100%"><!--/sizeo--><b>If you want to load games from the disc channel you must install CIOSCORP
    The following section applies to both Online and Offline installations.
    <!--sizec--></span><!--/sizec--></b>

    <!--coloro:red--><span style="color:red"><!--/coloro--><!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->NOTE: NO ASKING FOR LINKS TO CIOS WADS
    This section has some risks and is OPTIONAL
    if you follow instructions you will be fine.<!--fontc--></span><!--/fontc--><!--colorc--></span><!--/colorc-->

    1) Put WAD Manager 1.3 on your sd card

    <a href="http://www.teknoconsolas.tv/wanin/WAD-Manager_v1.3.zip" target="_blank">http://www.teknoconsolas.tv/wanin/WAD-Manager_v1.3.zip</a>

    2) Install the CIOSCORP WADs

    can be found in Softmii or MiiWii packages

    3) Install CIOS60BF.wad

    google "CIOS60HK.zip" or get "cios60.wad" from the offline guide

    4) Your system menu will now say "System Files Corrupt" but dont worry! just hold reset and launch the Homebrew Channel and install Preloader 0.29 AGAIN

    5) Enable update blocker in preloader. Hold RESET and power on. Change preloader options and hacks


    <!--sizeo:5--><span style="font-size:18pt;line-height:100%"><!--/sizeo--><!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->Frequently Asked Questions<!--fontc--></span><!--/fontc--><!--sizec--></span><!--/sizec-->

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->How do I fix Homebrew Channel going to a black screen?<!--fontc--></span><!--/fontc-->

    reinstall it with bannerbomb

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->What if I cant install Bootmii? What if the NAND backup fails?<!--fontc--></span><!--/fontc-->

    Chances are you will be fine, its just another security measure which I have never needed to use.

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->Is my console BRICKED!?<!--fontc--></span><!--/fontc-->

    If you have Bootmii boot2 or preloader then you are fine. Turn your Wii OFF to the RED light and then hold RESET and turn it on then load the HBC
    If you have cIOS installed run cIOS Downgrader
    If you dont have cIOS installed use the Offline Downgrade method

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->Will this work with Softmii? MiiWii? old version of cIOS? etc<!--fontc--></span><!--/fontc-->

    Theres no need to uninstall anything first. You can install CIOSCORP on 4.0 using this guide

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->Will this work with Starfall? Preloader 0.28?<!--fontc--></span><!--/fontc-->

    No. You MUST use Preloader 0.29. Starfall hacks wont work on 4.0. Use the latest preloader hacks.ini

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->Do original discs work with/without CIOSCORP?<!--fontc--></span><!--/fontc-->

    Yes. CIOSCORP and CIOS60 only affect Backup Discs

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->How do I fix the error when installing preloader "current IOS(36) has the fakesign bug fixed"?<!--fontc--></span><!--/fontc-->

    Install "IOS36-64-v1042.wad" which can be found on a disc or using the Offline Pack

    <!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->How do I fix (X)?<!--fontc--></span><!--/fontc-->

    Chances are you messed up directions somewhere. Start from Step 1!



    <!--sizeo:4--><span style="font-size:14pt;line-height:100%"><!--/sizeo--><!--fonto:Arial Black--><span style="font-family:Arial Black"><!--/fonto-->Credits: Team Twiizers, Waninkoko, tona, WB3000, Crediar, WiiGator, WiiBlaster, wiiNinja, ubercow<!--fontc--></span><!--/fontc--><!--sizec--></span><!--/sizec-->
     
  2. JJBro1

    JJBro1 GBAtemp Advanced Fan

    Member
    849
    0
    Jan 20, 2008
    United States
    THANK YOU!!!!!
     
  3. fst312

    fst312 GBAtemp Advanced Fan

    Member
    511
    3
    Nov 4, 2008
    United States
    New York
    this guide does it give me full access when using the homebrew channel i been wanting to update for a long time but was afraid of getting bricked or not being able to do everything i already can do with my 3.2U wii. i already downloaded the cios rev 9.also not sure but i read rev 9 gives 6x speed for games now is this true.please answer i already have preloader ready to get installed also going to download the rest of the things i need now.

    thanks in advance
     
  4. JJBro1

    JJBro1 GBAtemp Advanced Fan

    Member
    849
    0
    Jan 20, 2008
    United States
    what happens if we update through nintendo? I've heard alot of people are getting bricked with wanin's updater and that it doesn't come with all the ios's.
     
  5. kikoolol

    kikoolol Advanced Member

    Newcomer
    64
    4
    Mar 15, 2008
    United States
    Are you sure you can install CIOS60BF.wad when you have the preloader 0.29 already installed? it won't fuck things up as preloader is using IOS60? [​IMG]
     
  6. JJBro1

    JJBro1 GBAtemp Advanced Fan

    Member
    849
    0
    Jan 20, 2008
    United States
    ya i also heard that you can get bricked if you install ios60 after you installed preloader 0.29.
     
  7. assassda
    OP

    assassda GBAtemp Regular

    Member
    283
    0
    Jul 31, 2004
    United States
    I dont think its an issue since preloader copies over the systemmenu.dol but if someone can confirm this i would appreciate it
    Other than that the only thing you would need to do is install CIOS60 and then install preloader again I can confirm this working
     
  8. kikoolol

    kikoolol Advanced Member

    Newcomer
    64
    4
    Mar 15, 2008
    United States
    I'm waiting for an answer on this too (can't test it myself as i have no way to recover from a brick/2nd wii) but it's safer to install CIOS60BF BEFORE preloader (just after 4.0update). And you need cioscorpV2 not cioscorp.
     
  9. Megan

    Megan Member

    Newcomer
    42
    1
    Mar 14, 2009
    Thanks, I might do this later, but why do all the guides tell us not to install IOS61 and the Shop Channel?
     
  10. nintendolinky

    nintendolinky GBAtemp Advanced Fan

    Member
    537
    19
    Jul 31, 2007
    Wanikoko's 4.0 upgrader does it for you, thats why
     
  11. thecyanaura

    thecyanaura Advanced Member

    Newcomer
    51
    0
    Dec 16, 2008
    United States
    Ninja'd! So it seems like I just did double the work, that's all. Thanks again.
     
  12. assassda
    OP

    assassda GBAtemp Regular

    Member
    283
    0
    Jul 31, 2004
    United States
    Its not necessary to install IOS61 or Shop Channel they are installed by the updater
     
  13. nintendolinky

    nintendolinky GBAtemp Advanced Fan

    Member
    537
    19
    Jul 31, 2007
    Just had the corrup error message, thought shit another bricked wii, but just loaded up HBC and installed preloader again, worked like a charm. Now will be installing cioscorp in a moment.
     
  14. kedest

    kedest GBAtemp Psycho!

    Member
    3,287
    110
    Feb 6, 2007
    Netherlands
    Still thinking about updating to 4.0. The SD functions look nice.
    As I understand it, Waninkoko's updates leaves trucha intact in IOS files. Does that mean I can also still run trucha signed discs from disc channel? I have of few of them (such as a patched Manhunt 2 with no censoring). I have a hardmodded Wii.
     
  15. assassda
    OP

    assassda GBAtemp Regular

    Member
    283
    0
    Jul 31, 2004
    United States
    If you have a hard mod and the cIOS files installed then yes trucha discs should work and if not you can always use GeckoOS or Backup Launcher to run trucha discs
     
  16. CopyCaet

    CopyCaet Member

    Newcomer
    35
    0
    Jan 7, 2009
    Netherlands
    Whenever I try this, my system menu gets corrupted. Any idea's?
     
  17. moviecouple

    moviecouple GBAtemp Regular

    Member
    173
    0
    Dec 13, 2006
    United States
    So MANY different guides out there... not sure what to believe anymore.

    I was told to do it the following way from this thread.

    http://gbatemp.net/index.php?showtopic=143281
    http://www.yafaze.com/wii/menu4.0hack.html

    Assuming you already have cIOS36 v7 or V8 installed.


    1. Put the contents of the 4.0hacktools.rar file on the sd card.

    2. Put contents of Waninkoko's 4.0 updater on the sd card

    3. Open Homebrew Channel and run IOS60 installer, when it boots it will ask the following:

    "do you want to download and install IOS61?" SAY NO PRESS B (because it's done later anyway)
    "do you want to download and install IOS60?" SAY YES PRESS A
    "do you want to patch IOS60?" SAY YES PRESS A

    After it's installed IOS60 it'll ask:

    "do you want to download and install the newest shop channel?" SAY NO PRESS B. (because it's done later anyway)

    Restart Wii.

    4. Now use Waninkoko's 4.0 updater and follow prompts.

    5. Install cIOS36 v9

    6. Install preloader 0.29.

    So which is the correct way???
     
  18. crosseye

    crosseye Newbie

    Newcomer
    7
    0
    Apr 1, 2009
    United States
    Could you please explain if I need to remove Softmii 2.1.1 in order to do this or let me know the steps I would take having Softmii 2.1.1 and 3.2U?

    I'd really like to upgrade to 4.0 to load wads from SD, but not lose the ability to load backups from disc channel.

    Thanks a lot.
     
  19. Megan

    Megan Member

    Newcomer
    42
    1
    Mar 14, 2009
    Also, is it safe to use the CIOSCORP installer that comes with SoftMii rather than installing them all seperately?
     
  20. assassda
    OP

    assassda GBAtemp Regular

    Member
    283
    0
    Jul 31, 2004
    United States
    yes i personally use the cioscorp installer
     
Thread Status:
Not open for further replies.