Trucha Bug Help

Discussion in 'Wii - Hacking' started by petethepug, May 26, 2016.

  1. petethepug
    OP

    petethepug PUG

    Member
    1,405
    368
    May 2, 2016
    United States
    COMPUTER
    Okay so a few weeks ago I had installed Multi Mod Manager and patched and installed IOS 59. I'm assuming I had installed it since IOS 59 is being taken. I heard the IOS needed IOS 59 is needed to install it, and I heard other apps such as Trucha Bug Installer, DOP Mii, etc could install it.

    Mymenuify, Priiloader, and Save Game Manager GX is working fine which confuses me even more...
     
  2. demon33

    demon33 GBAtemp Regular

    Member
    141
    9
    Jan 21, 2009
    Canada
  3. petethepug
    OP

    petethepug PUG

    Member
    1,405
    368
    May 2, 2016
    United States
    COMPUTER
  4. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,245
    817
    Mar 2, 2015
    United States
    IOS59 is only for the Japanese game Dragon Quest X. Nothing else uses it and it's not even on the Nintendo update server.
     
  5. petethepug
    OP

    petethepug PUG

    Member
    1,405
    368
    May 2, 2016
    United States
    COMPUTER
    So, installing Trucha Bug would not brick my Wii even though IOS 59 is being used?
    Edit: Actually scratch that. Ios 36 is being used"
     
    Last edited by petethepug, May 26, 2016
  6. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,245
    817
    Mar 2, 2015
    United States
    There is no reason to re-patch the Trucha bug unless you want to run unsigned/fakesigned VC/Wiiware from the system menu.

    IOS59 doesn't enter into anything. It's unnecessary unless you're playing the one game that uses it and doesn't need to be patched as Dragon Quest X already installs itself to a USB drive and runs without the discs.
     
    Last edited by GreyWolf, May 27, 2016
  7. petethepug
    OP

    petethepug PUG

    Member
    1,405
    368
    May 2, 2016
    United States
    COMPUTER
    So let's say I want to run a USB Loader, would I have to patch it so it can read USB Devices used for external storage/running games off of device, movies, etc...
     
  8. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    4,245
    817
    Mar 2, 2015
    United States
    No. You need no patches to any system IOSes. You only need custom IOSes installed >200 for Wii games. IOS58 can read USB drives just fine for homebrew.
     
  9. petethepug
    OP

    petethepug PUG

    Member
    1,405
    368
    May 2, 2016
    United States
    COMPUTER
    Alright that's good. By chance would I need to install Trucha Bug then for the following;

    - USB Loader GX
    - WiiMC

    Also Trucha Bug needs a certain IOS to run off of, but I can't seem to find out which one in player made guides, and YT Videos. They suggest running it off of IOS 39 would be best, but other people are installing it with IOS 15, and/or DOP Mii.
     
  10. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,705
    9,003
    Oct 27, 2002
    France
    Engine room, learning
    You don't need to install the trucha bug at all in any of your existing IOS. You don't need to install the IOS236 either (unless you expect to run very old homebrew released before 2010)
    It's not needed anymore. all homebrew work without relying on the bug anymore.
    The only homebrew which requires the trucha bug are already using it from the cIOS 249/250.

    WiiMC doesn't need trucha, it needs IOS58.
    USBLoaderGX doesn't need trucha, it already has trucha included in 249.

    IOS39 doesn't exists, you probably meant IOS36
    you don't need IOS15 or IOS36/236 anymore. All homebrew are relying on the official, unpatched, IOS58.
    Don't try to follow tutorial or guides or user's recommendation posted on forums before 2010 either, they will all provide you outdated information.

    So, to resume :
    install cIOS 249 and 250
    That's all !
    your wii can do all you need.
     
    piratesephiroth and petethepug like this.
  11. petethepug
    OP

    petethepug PUG

    Member
    1,405
    368
    May 2, 2016
    United States
    COMPUTER
    Alright sweet!
    Glad I asked, thanks for the help!