trouble with detecting HDD/loading games with WiiFlow

Discussion in 'Wii - Backup Loaders' started by FakeCrimes, Apr 21, 2014.

  1. FakeCrimes
    OP

    FakeCrimes Newbie

    Newcomer
    3
    0
    Apr 21, 2014
    Recently I've tried to set up WiiFlow but nothing I've tried seems to work. I first installed IOS236, then followed https://sites.google.com/site/wiiflowiki4/installing-wiiflow to install d2x-v10-beta52 for IOS249 and d2x-v10-beta53alt for IOS250. I am using WiiFlow running through the homebrew channel on an SD card and the games formatted to .wbfs in a /wbfs/ folder on the root of a hard drive formatted to be FAT32. By default, WiiFlow uses IOS249 and cannot detect the hard drive, no matter whether it is in port 0 or 1, with the file explorer displaying sd:/ working fine but usb1:/ as empty. This is the same for IOS250. If I disable forcing cIOS in the main WiiFlow settings, WiiFlow uses IOS58 and detects all games on the hard drive and can read the contents of the drive in file explorer, but attempting to play them always just takes me to the Wii menu. I also tried Configurable USB Loader & USB Loader GX with this setup, but neither could detect the hard drive at all.

    I then tried using ModMii to install all the IOS it recommends, as can be seen in the syscheck log below. I again tried using WiiFlow & Configurable USB Loader that it gave me, running both off the SD card through the homebrew channel, with the same results as before - neither can detect the hard drive at all except for WiiFlow with forcing cIOS off using IOS58, but is then unable to load the games.

    Here is a current syscheck log:
    SysCheck v2.2.0 HD Edition by Double_A and R2-D2199, JoostinOnline, Nano
    ...runs on IOS58 (rev 6176).

    Region: PAL (original region: AUS)
    System Menu 4.3E (v514)

    Drive date: 09.07.2006
    Homebrew Channel 1.1.0 running on IOS58

    Hollywood v0x11
    Console ID: 37576051
    Console Type: Wii
    Shop Channel Country: Australia (65)
    Boot2 v4
    Found 104 titles.
    Found 47 IOS on this console. 12 of them are stub.

    IOS4 (rev 65280): Stub
    IOS9 (rev 1034): No Patches
    IOS10 (rev 768): Stub
    IOS11 (rev 256): Stub
    IOS12 (rev 526): No Patches
    IOS13 (rev 1032): No Patches
    IOS14 (rev 1032): No Patches
    IOS15 (rev 1032): No Patches
    IOS16 (rev 512): Stub
    IOS17 (rev 1032): No Patches
    IOS20 (rev 256): Stub
    IOS21 (rev 1039): No Patches
    IOS22 (rev 1294): No Patches
    IOS28 (rev 1807): No Patches
    IOS30 (rev 2816): Stub
    IOS31 (rev 3608): No Patches
    IOS33 (rev 3608): No Patches
    IOS34 (rev 3608): No Patches
    IOS35 (rev 3608): No Patches
    IOS36 (rev 3608): No Patches
    IOS37 (rev 5663): No Patches
    IOS38 (rev 4124): No Patches
    IOS40 (rev 3072): Stub
    IOS41 (rev 3607): No Patches
    IOS43 (rev 3607): No Patches
    IOS45 (rev 3607): No Patches
    IOS46 (rev 3607): No Patches
    IOS48 (rev 4124): No Patches
    IOS50 (rev 5120): Stub
    IOS51 (rev 4864): Stub
    IOS52 (rev 5888): Stub
    IOS53 (rev 5663): No Patches
    IOS55 (rev 5663): No Patches
    IOS56 (rev 5662): No Patches
    IOS57 (rev 5919): No Patches
    IOS58 (rev 6176): USB 2.0
    IOS60 (rev 6400): Stub
    IOS61 (rev 5662): No Patches
    IOS70 (rev 6912): Stub
    IOS80 (rev 6944): No Patches
    IOS202[60] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
    IOS222[38] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
    IOS236[36] (rev 65535, Info: rev 3351): Trucha Bug, ES Identify, NAND Access
    IOS249[56] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS250[57] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
    IOS254 (rev 65281): BootMii
    BC v6
    MIOS v10
    Report generated on 04/21/2014.
     
  2. SickPuppy

    SickPuppy New Member

    Member
    1,792
    452
    Jul 29, 2009
    United States

    Have you tried to use d2x cIOS v8, and install base of 56 to 249, and base of 57 installed to 250? Not sure why you would install two different beta versions at the same time.

    Once you get that working, then go ahead and try the beta versions of d2x.
     
  3. FakeCrimes
    OP

    FakeCrimes Newbie

    Newcomer
    3
    0
    Apr 21, 2014
    Yes, as I said, after the beta versions did not work I used the ModMii installer to install d2x-v8 base 56 to 249 and base 47 to 250, as well as some hermes ones to 202, 222 and 223. You can see this in the syscheck log. I had the same results as with the beta d2x for all of them - WiiFlow could not detect the hard drive when using any of them.
     
  4. brausm08

    brausm08 GBAtemp Advanced Fan

    Member
    721
    17
    Nov 15, 2009
    United States
    USA - Midwest
    what kind of HDD you using....sounds like it isn't cIOS compatible (especially since it works on IOS58)
    to test, try a different HDD or USB thumbdrive.

    SickPuppy: two different beta d2x is a common (?preferred) setup...r53alt has worse emuNAND compatibility, but is PnP compatible...so it's common to see 249 r52 for loaders and r53 in other slots for certain games.
     
  5. FakeCrimes
    OP

    FakeCrimes Newbie

    Newcomer
    3
    0
    Apr 21, 2014
    The two hard-drives I have tried are the Seagate SRD00F1 Expansion Portable Drive 1TB (which I think is the same as the STBX1000200 one listed on the compatibility list) & a WD Elements SE Portable 500GB USB 3.0 2,5" (WDBPCK5000ABK-01). Neither seems to have been tested much unfortunately but both have been listed as working with CFG USB loader, specifically with NTFS for the WD one. I've tried this without success and tried all formats (FAT32, NTFS, WBFS) on both hard-drives.

    I hadn't considered it could be a cIOS compatibility issue with the hard drive as I'd thought if it was compatible with IOS58 it should also be with cIOS even though it seemingly isn't. I'll try a USB thumbstick to see if it works any differently for me.