Thinking About Trying Preloader. Advice Needed Please

Discussion in 'Wii - Hacking' started by ecw, May 7, 2009.

  1. ecw
    OP

    Member ecw GBAtemp Regular

    Joined:
    Jan 7, 2009
    Messages:
    175
    Country:
    United States
    Ok, I have read and searched here and other forums for some time now about Preloader. I have seen good stories AND bad. Seems like it's great IF you can get installed. I didn't think the April Fools joke was very funny and made me think twice about using it. Using something as dangerous as Preloader, I would hope things like that wouldn't happen.

    Anyway, I have a Wii with 4.0U. I had 3.4 using Noobwarrior's guide here on this site. All ran well. I then updated (through Nintendo) to 4.0 and installed the patched IOS60 Wad for the SD Features. All is working well. Backups, Wiiware, USB Loader etc. I am running cIOS36 Rev9 and some other cIOS's from Noob's pack.

    I know 0.29 is the latest Preloader. What would I have to do under my current set up to have it installed? I seen alot of posts about a "Your System Files are Corrupt" message, then you have to re-install Preloader again to make it work. Does that happen every time you install it for the first time? I am mainly looking for protection against Banner Bricks (I think that's what they're called) from a "bad wad". I don't play out of region games so I am not worried about update checks either. TIA
     


  2. lavamasta

    Member lavamasta GBAtemp Regular

    Joined:
    Feb 21, 2009
    Messages:
    197
    Country:
    United States
    just get preloader, its worth it! u'll see [​IMG]
     
  3. dlxowhd

    Member dlxowhd GBAtemp Fan

    Joined:
    Dec 7, 2008
    Messages:
    382
    Country:
    United States
    i'm sticking with starfall and 3.2.
     
  4. ecw
    OP

    Member ecw GBAtemp Regular

    Joined:
    Jan 7, 2009
    Messages:
    175
    Country:
    United States
    Does Starfall work on 4.0? Is it better than Preloader? Can it recover you from a bad Wad install?
     
  5. afif95

    Member afif95 I own a bungalow on Mars, and booked 4 corner lots

    Joined:
    Nov 24, 2008
    Messages:
    1,805
    Location:
    Malaysia!
    Country:
    Malaysia
    That wasn't being helpful. Plus, Starfall's outdated and Preloader's all around better. If you wanna complain about more boot time, you're pretty much a timid idiot for being unable to wait some extra seconds.

    To OP, get Preloader. But since you updated through Nintendo........

    1)Use Firmware Downgrader 1.11 (Ask these guys where to get it) downgrade to 3.2
    2)Run IOS Downgrader
    3)Use Firmware Downgrader again to go back to 4.0

    Why? Your IOSes are trucha-patched, thus, not allowing Preloader to install.

    EDIT: And no, there's no Starfall for 4.0. StartPatch is, but I don't think there's a reason to do it when you have PReloader.
     
  6. dlxowhd

    Member dlxowhd GBAtemp Fan

    Joined:
    Dec 7, 2008
    Messages:
    382
    Country:
    United States
    heard too many hassle/horror stories about preloader.
    and 1 thing that made me stay away from preloader is there is no way to uninstall it?
    even if you remove the hack, it will stay in nand or something..

    i'm not saying starfall is better.. it's just so much simpler to use and no hassle at all.. and does the job.
     
  7. afif95

    Member afif95 I own a bungalow on Mars, and booked 4 corner lots

    Joined:
    Nov 24, 2008
    Messages:
    1,805
    Location:
    Malaysia!
    Country:
    Malaysia
    It's not too much of a hassle. It's as simple as this:

    1)Get Hacks.ini
    2)Put it in the root of the SD Card
    3)Run the .dol of preloader, thus, installing it
    4)After reboot, set it
    5)You're done

    It's a simple 5-step procedure, even a 14 year old can do it, so why can't you?

    And there's a way to uninstall Preloader. Reinstall the system menu. That, or use NANDClean, an application to remove things from the NAND.
     
  8. icefireicefire

    Member icefireicefire GBATemp Fails.

    Joined:
    Dec 19, 2008
    Messages:
    961
    Country:
    United States
    Nope, uninstall is JUST to re-run the 4.0 installer. thats it. Brick chance: never bricked anyone from itself, only from stupididty. If you get a system files are corrupted, just reinstall preloader.

    Not installing it = no help from community, as you SHOULD HAVE.
     
  9. dlxowhd

    Member dlxowhd GBAtemp Fan

    Joined:
    Dec 7, 2008
    Messages:
    382
    Country:
    United States
    yes, that's 4 more steps than 'run .dol of starfall'.
    and no need to run stuff like nandclean or re-run the 4.0 installer to uninstall it.
    again, i'm not saying starfall is better.
    it fits my needs and much simpler and risk free than preloader.
     
  10. PNo4

    Member PNo4 GBAtemp Regular

    Joined:
    Apr 10, 2009
    Messages:
    259
    Country:
    Sweden
    1. In one way its not possible to uninstall, but actually it is, but not in the way you think.

    2. correct.


    Preloader, MOVES part of the systemmenu to a new location on nand, and takes it original place, that why Preloader boots first. (as I understand)

    The only way to "get rid" of Preloader is to install the entire systemmenu again or upgrade it, that will place it back on original location where Preloader was.
     
  11. dlxowhd

    Member dlxowhd GBAtemp Fan

    Joined:
    Dec 7, 2008
    Messages:
    382
    Country:
    United States
    exactly..
    i'd like to keep my system as 'clean' as possible.
    just barely enough to be safe and run usb loader and backup launcher and stuff.
     
  12. hanguker

    Newcomer hanguker Member

    Joined:
    Feb 2, 2009
    Messages:
    48
    Country:
    United States
    I've been thinking about installing preloader, too.

    Do you think I'll have any problems, considering I am using a Korean Wii?

    My rig: d2sun chip, HBC, Usbloader 1.5 (Ultimate v7.4+forwarder), USB HDD

    Everything works great. I just want to have a safety net.

    Is it worth the risk to install Preloader in my situation?
     
  13. icefireicefire

    Member icefireicefire GBATemp Fails.

    Joined:
    Dec 19, 2008
    Messages:
    961
    Country:
    United States
    PRELOADER IS NOT A RISK. JUST INSTALL IT.
     
  14. ecw
    OP

    Member ecw GBAtemp Regular

    Joined:
    Jan 7, 2009
    Messages:
    175
    Country:
    United States
    Thanks for this response. I wasn't trying to start a war. lol. I understand the advantages of Preloader. But downgrading, then upgrading leaves plenty of room for error. I wish I hadn't used the Ninty update. Before I make a decision, one last question. Would I have to downgrade to use Startpatch and most important, can Startpatch recover me from a bad wad install? Thanks again.
     
  15. icefireicefire

    Member icefireicefire GBATemp Fails.

    Joined:
    Dec 19, 2008
    Messages:
    961
    Country:
    United States
  16. ecw
    OP

    Member ecw GBAtemp Regular

    Joined:
    Jan 7, 2009
    Messages:
    175
    Country:
    United States
    That's what I thought. I guess that's why Preloader is better. Thanks again!
     
  17. cheech794

    Member cheech794 GBAtemp Regular

    Joined:
    Nov 15, 2008
    Messages:
    126
    Country:
    United States
    I just tried to install preloader .29 through HBC and i got this message "Failed to get boot, IOS(36) has fake sign bug fixed"

    I am on 4.0 and i have a NTSC-U Wii

    anyone know what to do?
     
  18. gamemasterkobs

    Newcomer gamemasterkobs Member

    Joined:
    Jul 9, 2008
    Messages:
    19
    Location:
    angeles city
    Country:
    Philippines
    Umm when you install preloader, can you go to wii menu??? and how does it prevent bricks???
     
  19. TheWiiNinja

    Member TheWiiNinja GBAtemp Regular

    Joined:
    Mar 14, 2009
    Messages:
    112
    Location:
    Texas
    Country:
    United States
    Yes, you can go to the system menu, it's an option on the screen. It can prevent bricks like ones caused by bad WADs and themes because it loads before the system menu and lets you go to the Homebrew Channel to correct your mistakes.
     
  20. TheWiiNinja

    Member TheWiiNinja GBAtemp Regular

    Joined:
    Mar 14, 2009
    Messages:
    112
    Location:
    Texas
    Country:
    United States
    You're IOSes are trucha-patched, so you need to downgrade first. Just follow the steps afif95 posted on the first page.
     

Share This Page