Tutorial Switch Unbricking Guide - ProdInfo Fix (PikaFix)

zorusgb

Member
Newcomer
Joined
Dec 10, 2021
Messages
17
Trophies
0
Age
47
XP
42
Country
Bulgaria
That is true, however since the switch fails to read the emmc board I have little hope the mmcblkNX will either. Hence the exploe.te dongle which won't.

In your opinion, how important is to have the original boot partitions for restoring full functionality?
 

Adran_Marit

Walküre's Hacker
OP
Member
Joined
Oct 3, 2015
Messages
3,174
Trophies
1
Location
42*South
XP
3,297
Country
Australia
That is true, however since the switch fails to read the emmc board I have little hope the mmcblkNX will either. Hence the exploe.te dongle which won't.

In your opinion, how important is to have the original boot partitions for restoring full functionality?
ehhhhhh maybe like 50/50 at best.

Biggest thing is prodinfo imo... though I don't know enough about boot0/1 and what they contain to say fully
 

zorusgb

Member
Newcomer
Joined
Dec 10, 2021
Messages
17
Trophies
0
Age
47
XP
42
Country
Bulgaria
So finally the explitee low voltage emmc adapter arrived and its not good news right away. I'm testing the process on a second hand original emmc board and while the soldering went surprisingly smooth the chip is not recognized by the OS. I know the spare board is good as I also ordered an mmcblkNX adapter and that one reads it just fine. Tested all connections for continuity and all check out. Anyone knows how those boards behave normally? The light on mine blinks few times and goes off; not sure if this is a symptom of a problem with it or this is how it behaves when it doesn't detect anything. I also tried connecting a regular SD card to it, but still nothing.
 

Ragna666

Member
Newcomer
Joined
Apr 2, 2020
Messages
13
Trophies
0
Location
Hungary
XP
130
Country
Hungary
ehhhhhh maybe like 50/50 at best.

Biggest thing is prodinfo imo... though I don't know enough about boot0/1 and what they contain to say fully


Hi.

i have a switch with no nand backup and i don't have the original emmc, just a replacement one.

with your tutorial now i have access to system and safe partition with the original console prod.keys, but i can't access the user partition without using my other switch prod.keys.

the switch is not booting right now and somehow the hekate not recognizing the touch panel.



do you know any method to save it?

UPDATE:
i used the second method.
i needed to use a user partition dump too, i decrypted with the working switch keys and re encrypted with the faulty switch keys.
idk why but it's not worked without this.

but i have a new problem, some games not starting, i tried to update sigpatches and other things too but it not works.
can u help me out with that?

here's some games that not start:
pokémon legends: arceus
castlevania advance collection
carrion
diablo 2 resurrected
...etc

bloodstained 1-2 and shantae and the pirates curse is working.
 
Last edited by Ragna666,
General chit-chat
Help Users
    alidergamer1234 @ alidergamer1234: hi