1. ThaKarra

    OP ThaKarra Member
    Newcomer

    Joined:
    Aug 17, 2018
    Messages:
    48
    Country:
    Australia
    Today I turned my Switch on and played it for the first time in a while. I docked it to the TV and played perfectly fine all morning.

    I put the Switch to sleep because I wanted to take a break. I came back about an hour later and now it's just completely spazzing out and will not dock to the TV.

    The dock just flashes a green light and nothing at all appears on the TV. I have recorded a small clip so you can see exactly what happens.

    https://streamable.com/wm6el

    I've owned my Switch for about 2 years and in that time I've probably only used the dock like 3 times in total. I mainly just use it handheld.

    On another note, when I take my charger cable out of the dock and plug it directly into the Switch, the screen goes on and off repetitively and doesn't really charge.

    It's all so random, I have no idea what's happening. Any ideas?

    P.S. I've tried jiggling the cables around. Doesn't do anything.
     
  2. ds34

    ds34 GBAtemp Fan
    Member

    Joined:
    Jan 14, 2020
    Messages:
    309
    Country:
    Germany
    Sounds like your M92T36 chip is broken. I have no idea about the flashing screen. Could be something related to P13USB because it only happens when you plug in the charger.
    Does it only happen with the original charger or also with e.g. your phone charger?
     
  3. ThaKarra

    OP ThaKarra Member
    Newcomer

    Joined:
    Aug 17, 2018
    Messages:
    48
    Country:
    Australia
    I'm not sure yet, I haven't had another cable to test. Visiting my sister tonight, I'll borrow her charger and see if it works. I'll report the results back.
     
  4. ds34

    ds34 GBAtemp Fan
    Member

    Joined:
    Jan 14, 2020
    Messages:
    309
    Country:
    Germany
    Just try a random USB C cable with any USB port available e.g. your PC.
     
  5. ThaKarra

    OP ThaKarra Member
    Newcomer

    Joined:
    Aug 17, 2018
    Messages:
    48
    Country:
    Australia
    I tried my sisters cable and hers worked fine, so it was definitely a charging cable issue.

    Contacted Nintendo and sent it to them, if they assess the cable and can verify its broken, they are going to send me out a new one for free.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - flashing, suddenly, Switch