Switch only charges in dock

Discussion in 'Switch - Console, Accessories & Hardware' started by Hacktendo, Jun 13, 2019.

  1. Hacktendo
    OP

    Hacktendo Member

    Newcomer
    1
    May 27, 2019
    Canada
    Hi, sorry if this is in the wrong place, but my switch only charges in the dock. I know it's my switch because my dock is fine with a friend's switch.
    Sometimes image shoots to the TV, but then it goes off to no signal screen sometimes glitches. One time it only shot out a 480p image and I got a nice colourful glitchy lines screen.
    The green light on the dock is on and the Switch screen is off.
    I'm thinking it may be a USB-C port issue? Works fine on 2 original chargers.
    I googled and I can't send it in due to cfw and scratches on the right joycon rail (I first used a paperclip) and Nintendo require the SD.
    Anyone else had similar problems like this?
    Thanks!
     
  2. Fernand

    Fernand Newbie

    Newcomer
    1
    Jun 13, 2019
    United States
    sounds like a charging port issue brother , try to change the cable and see what happens also check your port for lint or moisture depending on your situation , if you read in cellphone forums people complain about phones not charging and problems with these usb c ports not liking moisture and lint inside, samsung phones are notorious for this problem,the switch is no a phone but the ports are the same might help in cleaning it carefully ,there are tut on google on how to do this and hopefully this is it and nothing else , good luck
     
  3. Hacktendo
    OP

    Hacktendo Member

    Newcomer
    1
    May 27, 2019
    Canada
    The ports are clean like a whistleand as I stated in my post it charges just fine. The green light indicator on the dock is on like normal when the switches in the dark like I said in my post. Please reread.
    And I'm thinking it might be a USB c Port issue and does the cell phone place that will cost me $80 to get it replaced.
     
  4. Hacktendo
    OP

    Hacktendo Member

    Newcomer
    1
    May 27, 2019
    Canada
    So it seems like I must be the only one here out of the 171 views that is experiencing this issue???
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    19
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Mar 17, 2010
    Norway
    Alola
    I've seen other Switches with the same issue, sadly it's not an easy fix. The USB-C port is difficult to replace. But if you send it in to someone that repairs these things they might be able to fix it, such as TronicsFix: https://tronicsfix.com/collections/get-started
    He does a lot of repairs (usually priced at $99 + shipping) and has a YouTube channel if you want to check out his work. $99 is also the price for a USB-C port replacement.
     
    Last edited by The Real Jdbye, Jun 14, 2019
Quick Reply
Draft saved Draft deleted
Loading...