Supercard SD

Discussion in 'Supercard' started by BlueStar, Aug 13, 2010.

Aug 13, 2010

Supercard SD by BlueStar at 11:57 AM (845 Views / 0 Likes) 2 replies

  1. BlueStar
    OP

    Member BlueStar GBAtemp Psycho!

    Joined:
    Jan 10, 2006
    Messages:
    4,094
    Location:
    UK
    Country:
    United Kingdom
    So, my first flashcart was the Supercard SD with flashme on my DS phat. As soon as the R4 came out I got a lite and passed on my phat+supercard to a couple who are friends of mine. Was round the other night and they asked if I could add some new games. Notice the patching software was updated as recently as the end of march, though the card firmware is from 2008. What's the compatibility like nowadays? I know I should just convince them to fork out for an AceKard and a micro SD but they're tight as fuck, one of them's from Yorkshire.
     
  2. DanTheManMS

    Member DanTheManMS aka Ricochet Otter

    Joined:
    Jun 2, 2007
    Messages:
    4,325
    Location:
    Georgia
    Country:
    United States
    Most likely, they actually have the latest firmware. Version 1.85 was released March 18, 2008. Have them hold L+R upon startup and press A a few times to find out the current version.

    GBA compatibility hasn't changed since firmware version 1.63, which was probably from 2005 or 2006. DS compatibility I honestly don't know too much about, as I haven't played any recent games in ages.
     
  3. Overlord Nadrian

    Banned Overlord Nadrian Banned

    Joined:
    Jul 28, 2008
    Messages:
    6,671
    Location:
    Riviera
    Country:
    Belgium
    The DS compatibility is pretty good, although most of the latest released games need some sort of patch to run, and some won't even run at all.

    I'm sure you'll get a better answer by browsing through the English SuperCard slot-2 forums though.
     

Share This Page