Super R4i

Discussion in 'R4 DS' started by piratejohn11, Jun 4, 2010.

Jun 4, 2010

Super R4i by piratejohn11 at 4:06 AM (818 Views / 0 Likes) 3 replies

  1. piratejohn11
    OP

    Newcomer piratejohn11 Newbie

    Joined:
    Jun 4, 2010
    Messages:
    2
    Country:
    United States
    Hey, I recently got a Super R4i and I'm dying to find out how to make it work with my DSi whenever I put it inside the DSi nothing shows up and I already downloaded the kernel update and it still isnt working I've been looking for a solution for about 4 hours now.. and decided I should sign up and ask you guys so please I'm begging you to help me out.
    Thanks everyone who tried to help.
     
  2. exangel

    Member exangel executioner angel

    Joined:
    Apr 20, 2010
    Messages:
    1,574
    Location:
    Tucson, AZ
    Country:
    United States
    Are you talking about http://super4i.com/r4i-download-e.html specifically, or is the official website on your packaging/cartridge label different?

    Is your DSi brand new or fully updated (1.4 Firmware in the System settings)?

    Though it claims to be compatible with all types of DS/DSi, the product's initial release was before the major flashcart-blocking DSi Firmware 1.4 was introduced. The site claims in poor English that this product (made) after Aug 30 of last year is compatible with 1.4 Firmware. This implies that if yours was made before that it's never going to work as they don't have a flash update for the firmware of the cartridge.

    Sometimes the Kernel / Operating Software is called firmware, but the Kernel alone will never change the cartridge firmware; a flash update for flashcarts is typically a small homebrew that is run in the Kernel GUI from the MicroSD that modifies the cartridge's firmware.

    The most recent Kernel release is from the end of last October, which makes it pretty safe to say they've given up and bailed on supporting the product's future.

    Like it seems for you, I too started out on this site looking for solutions to problems I was having with an "R4i" variation of R4-clone. After a lot of research, and before I actually became a GBAtemp member, I decided the solution was to get an Acekard 2i. Since then, the Supercard DSTwo has been released as well. They seem to be the two most recommended flashcarts for use with DSi 1.4 and beyond because they can be internally updated. Acekard 2i has a very wide knowledgebase and Supercard DSTwo has a pretty active official development team.
     
  3. piratejohn11
    OP

    Newcomer piratejohn11 Newbie

    Joined:
    Jun 4, 2010
    Messages:
    2
    Country:
    United States
    I got that kernel thing from that website and I just updated my DSi and it still doesnt show, I don't know when it was made because I got it from someone.

    Is there like any other kernel or anything I could use to make this work?
     
  4. exangel

    Member exangel executioner angel

    Joined:
    Apr 20, 2010
    Messages:
    1,574
    Location:
    Tucson, AZ
    Country:
    United States
    If it is the older version, it's not possible to modify that flashcart to work with the current DSi firmware. It's also not possible to downgrade the DSi firmware to the previous version with which the card did work.

    *BUT* before you give up, you should make sure that it's not a contact issue, meaning that you should start by testing it in 1.3 or below DSi or NDS/NDSL system.

    If you do not have any way of borrowing an older DS system to test it (or don't want to wait until you can get one), you can try to elevate the contacts by inserting a piece of paper or card under the PCB between the gold contacts and the front half of the casing. There is a guide with photographs to do this on the Acekard, keep in mind that doing this on your flashcart will probably not be exactly the same due to a different manufacturer, but the principle is the same. If you're really lucky, this will fix the problem, but it won't stop the kernel from being a piece of crap from last October..
     

Share This Page