Suddenly having problems with Disc Channel?

Discussion in 'Wii - Hacking' started by torbit, Nov 18, 2008.

Nov 18, 2008
  1. torbit
    OP

    Newcomer torbit Newbie

    Joined:
    Nov 17, 2008
    Messages:
    8
    Country:
    United States
    No clue what's going on, but starting today whenever I launch anything through the Disc Channel (no modchip, just originals), it says I have to do a Wii System Update in order to play the game. I hit update, it says "Update Failed", and the Wii resets. Same thing happens when I try to launch the game again. It first started happening on Super Smash Bros. Brawl (which I installed the update for when I first got the game) but i've tried it with a few older games like No More Heroes that I know wouldn't need any update and it's the same deal.

    My Wii's DVD drive has been pretty noisy lately, I don't know if it's some sort of hardware problem (it's now making a strange noise when the disc spins up), but the strange thing is that games will launch and play through the Backup Loader / GeckoOS just fine. Has anyone run into this issue before? If so, is it hardware (drive failing) or something I did wrong with installing homebrew? Currently I have the Backup Loader 0.3 installed as a channel and the Homebrew Channel and that's it as far as hacked channels. They all work just fine.

    Out of curiosity I did the system update to 3.3 just to see if that would fix anything (I already have a custom IOS installed so I don't think I should run into any problems) and it didn't fix anything. Same problem with being stuck in a failed system update loop when using the Disc Channel. I've tried power cycling the Wii, unplugging it and leaving it there for about 5 minutes.

    tl;dr version: Disc channel has stopped being able to launch original games, prompts for a system update then fails. Games boot fine in GeckOS/Backup Loader. Could it be drive failing?
     
  2. remixer

    Newcomer remixer Advanced Member

    Joined:
    Oct 10, 2008
    Messages:
    64
    Country:
    United States
    It can't be the drive failing if it plays backup's o.k. this has to be something else.. what i dunno .. maybe someone else here can help.. but the drive should be o.k
     
  3. torbit
    OP

    Newcomer torbit Newbie

    Joined:
    Nov 17, 2008
    Messages:
    8
    Country:
    United States
    It's strange, I just tested out a Gamecube game and it worked fine, no problems.

    The reason I think it may be hardware related is that as the Wii game is spinning up there's a weird sound coming from the drive right before the Wii pops up the update screen. And sometimes I'll just flat out get a "Disc Can Not Be Read" error. I'll keep testing different games in the Disc Channel and the backup launcher and see what I can find.

    Edit: The sound seems to come from the DVD drive as the disc is spinning up or spinning down. Once when the Wii is starting up the system menu and reading the disc, and another time when it stops and prompts me for the update.
     
  4. torbit
    OP

    Newcomer torbit Newbie

    Joined:
    Nov 17, 2008
    Messages:
    8
    Country:
    United States

Share This Page