Strange Problem here

Discussion in 'Wii - Hardware, Devices and Utilities' started by Red Joker, Jun 4, 2014.

  1. Red Joker
    OP

    Red Joker GBATEMPer

    Newcomer
    50
    4
    Jun 2, 2012
    Indonesia
    GBATEMP
    Hi guys, I have a 4-5 years old Wii here. My Wii is pre-modded when I bought it. I use USB Loader GX to play games now.
    Yesterday, I installed cIOS 249 and 250 d2x with IOS base 58 (since Metroid Prime Trilogy won't fully work as intended), without uninstalling the previous version. After that, I accidentally scan and fixed my HDD in my laptop.

    It seems after that, my Wii refused to initialize any USB devices. Tried formatting a USB drive to FAT, but it won't initialize, either. Changing the port to 0, 1 and both in settings also didn't work.

    Last night, I played a game when suddenly it had a disc read error. I shut down my Wii and to my surprise, earlier this morning I discovered my Wii can't even read disc anymore. I really wanted to post a sysCheck, but for some reason, even before installing the cIOS, it says the Wii can't initialize FAT drive or something when scanning all IOS. Scanning IOS one by one works, though.

    What still works and reads normally are SD Cards. However, I'm really afraid that it will eventually break down as well.

    This problem is really strange. Everything breaks down one by one. Did I brick my Wii? Any thoughts?

    Thanks in advance.

    EDIT : Forgot to mention that my Wii is 4.1U. My house may be a bit dirty, so will cleaning the USB port fix this? And any special tools must I use? I don't mind my disc driver break down, but if the USB port breaks down as well, my Wii is near useless.
     
  2. Red Joker
    OP

    Red Joker GBATEMPer

    Newcomer
    50
    4
    Jun 2, 2012
    Indonesia
    GBATEMP
    nvm, looks like something messed up USB Loader GX's configuration in my SD Card. I replaced the USB Loader GX files into the original one. And my HDD problem fixed. My DVD Driver though, on the other hand may be broken for real.
     
  3. Red Joker
    OP

    Red Joker GBATEMPer

    Newcomer
    50
    4
    Jun 2, 2012
    Indonesia
    GBATEMP
    Looks like the newest version of USB Loader GX (Rev 1227) IS the one causing the problem. Any solutions?
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,626
    8,204
    Oct 27, 2002
    France
    Engine room, learning
    which is the latest working version?

    the new version has is now editing the meta.xml to reflect your settings.
    If you set "IOS249" for the loader's IOS in the settings, the meta.xml will have "--ios=249"
    if you select IOS58, it will edit the meta.xml to use --ios=58

    If the loader doesn't boot at all, try to edit your meta.xml manually and set these (default) values:
    --ios=249
    --usbport=0
    --mountusb=1
    then once in the loader, go to the settings and edit the Loader's IOS and usbport to the same values.

    Reinstall d2x cIOS with 249 base56 and 250 base 57, if you want a base58 install it in another slot (for example in slot 251 which is common practice in tutorials)