Sonic Rivals? Shutting off during start?

Discussion in 'PSP - Games & Content' started by Devin, Apr 4, 2010.

Apr 4, 2010
  1. Devin
    OP

    Member Devin "Local Hardware Wizard"

    Joined:
    Aug 17, 2009
    Messages:
    5,701
    Location:
    The Nexus
    Country:
    United States
    Hey, Tempers.

    I downloaded Sonic Rivals, to play later. Once the download finished, I tested out the iso, on my PSP running GEN-D3. I get it to boot, and then I get to a Auto Save screen. Once I press X, it goes to a black screen. Then the PSP turns itself off, with a click.

    Any help?
     
  2. TwinRetro

    Global Moderator TwinRetro Don't start nothin', Won't be nothin'

    Joined:
    Aug 29, 2008
    Messages:
    6,181
    Location:
    Las Vegas, NV
    Country:
    United States
    sounds like a bad ISO. try a different source.
     
  3. prowler

    Member prowler Sony

    Joined:
    Jul 14, 2009
    Messages:
    9,473
    Location:
    Ragol
    Country:
    United Kingdom
    Change your driver.
     
  4. Devin
    OP

    Member Devin "Local Hardware Wizard"

    Joined:
    Aug 17, 2009
    Messages:
    5,701
    Location:
    The Nexus
    Country:
    United States
    Tried them all.
     
  5. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    If a new ISO doesn't work - Disable your plugins or get a better memory stick. Failing that use 5.00M33-6
     

Share This Page