Gaming Sonic 2 & 3 virtual console spin dash glitch.

omegablacky

Member
OP
Newcomer
Joined
Aug 3, 2016
Messages
5
Trophies
0
XP
62
Country
United States
I'm having an issue with Sonic 2 & 3 on the virtual console.This issue is kinda hard to explain but most of the time,whenever I try to spin dash Sonic will rev it up then proceed to jump in place,at first I thought there was something wrong with my controller but when I used another one the same thing happened,this problem doesn't happen on other versions of the games either. I also noticed when kneeling,Sonic will try to go back to his regular standing animation even though I'm holding down,(This also happens in the VC version of Sonic 1),again this problem only seems to be exclusive to the Wii VC versions of these games. I even tried uninstalling and reinstalling them and I still encounter the issue,the problem only seems to disappear whenever I lock-on Sonic & Knuckles,while there doesn't seem to be a solution to this problem,I am curious to know if anyone else encountered this issue?
 

Attachments

  • sonic 2 title.png
    sonic 2 title.png
    7.3 KB · Views: 444

AyanamiRei0

GBATemp's Resident Evangelion fanboy.
Member
Joined
Jan 4, 2016
Messages
1,506
Trophies
1
Age
32
Location
Brexit
XP
1,707
Country
United Kingdom
Just remember the Wii VC versions are just roms of that game like Sonic 2, for example, it's a MegaDrive/Genesis rom that's inside an emulator if I'm wrong please correct me
 

omegablacky

Member
OP
Newcomer
Joined
Aug 3, 2016
Messages
5
Trophies
0
XP
62
Country
United States
It's probably your controller, but not a defect.
The Wii Remote's D-Pad is very sensitive. It's very easy to make it register Down-Right by pressing the right side of Down, for example.
I don't think its controller,when I use my classic controller analog the same thing happens.
 

smileyhead

I like cute stuff.
Member
Joined
Aug 31, 2015
Messages
4,808
Trophies
3
Age
23
Location
Budakeszi, Hungary
Website
sites.google.com
XP
10,657
Country
Hungary
I don't think its controller,when I use my classic controller analog the same thing happens.
Well, what did you expect from a joystick? Use the D-Pad for 2D games for crying out loud.
 

omegablacky

Member
OP
Newcomer
Joined
Aug 3, 2016
Messages
5
Trophies
0
XP
62
Country
United States
The emulation isn't at fault here it's the controller
When I the very same controller on my gen plus emulator this issue doesn't occur,the same applies for when I use it for other games as well.
Well, what did you expect from a joystick? Use the D-Pad for 2D games for crying out loud.
I do use the d-pad,I just was curious to see if it was only a problem with the Wii controller on its own,when I connected my classic controller I wanted to see if the same thing happened and it did.for both the analog and d-pad.
 

omegablacky

Member
OP
Newcomer
Joined
Aug 3, 2016
Messages
5
Trophies
0
XP
62
Country
United States
The emulation isn't at fault here it's the controller
How is it the controllers fault when it only happens for VC versions Sonic 2 & 3? I've used this very same controller on other games and this problem occur,not to mention,even when I use another controller the same thing happens. I'm more curious to know if its just me who has encounter this,do you own the VC versions of Sonic 2 & 3,I can now confirm that this issue only happens in Wii mode
should have used gensplus GX :P

What do you think my alternative is :wink:
 

AyanamiRei0

GBATemp's Resident Evangelion fanboy.
Member
Joined
Jan 4, 2016
Messages
1,506
Trophies
1
Age
32
Location
Brexit
XP
1,707
Country
United Kingdom
When I the very same controller on my gen plus emulator this issue doesn't occur,the same applies for when I use it for other games as well.

I do use the d-pad,I just was curious to see if it was only a problem with the Wii controller on its own,when I connected my classic controller I wanted to see if the same thing happened and it did.for both the analog and d-pad.

Yes I've played Sonic 2 and 3 completely without issues multiple times on the Wii VC
 
D

Deleted User

Guest
Have you tried turning it off and on again? ( ͡° ͜ʖ ͡°)

Try using another wiimote, or relinking the one you already have connected, and try changing the batteries
 

omegablacky

Member
OP
Newcomer
Joined
Aug 3, 2016
Messages
5
Trophies
0
XP
62
Country
United States
It turns out the Wii mode vc versions controls are sensitive than other versions,it doesn't make much sense to why though.
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    Gamemaster2022 @ Gamemaster2022: Great titles. I'm about to play some Pokémon Emerald. I need to lvl up +1