Some advice needed!!

Discussion in 'Acekard' started by Wii Warrior, Oct 7, 2009.

Oct 7, 2009

Some advice needed!! by Wii Warrior at 9:38 AM (860 Views / 0 Likes) 6 replies

  1. Wii Warrior
    OP

    Newcomer Wii Warrior Advanced Member

    Joined:
    Sep 21, 2008
    Messages:
    71
    Country:
    United Kingdom
    My son is wanting a dsi for Christmas.
    I have soft modded his Wii so I am planning on using the acekard2i with his dsi.

    I have already ordered him a acekard2i from Deal Extreme but I am now unsure that it is going to work with his dsi when I get it as I am pretty sure it is going to come with the 1.4 firmware.

    I have since noticed that NDS card shop are advertising their acekard2i as preloaded with firmware that will work with the dsi's with 1.4 firmware.

    What I am wanting to know is can I download this firmware that will make the ak2i work with the dsi from anywhere? or am I going to have to buy another ak2i card from nds card shop?

    I am a noob on the ds side so any help is appreciated
     
  2. BowlOfSpiders

    Member BowlOfSpiders hi

    Joined:
    Feb 10, 2009
    Messages:
    649
    Location:
    United States
    Country:
    United States
    Yes. You can update the ones from dealextreme. Just go to my stickied tutorial. And look for the "How to update your acekard2i to work on dsi 1.4 firmware". Just make sure your sons DSi isn't at firmware 1.4 or it wont work. If it's new, I doubt it is.
     
  3. rockstar99

    Member rockstar99 Hi

    Joined:
    Dec 3, 2008
    Messages:
    7,375
    Location:
    Toronto
    Country:
    Canada
    but by cchristmas the dsi might come with 1.4 but the aks from dx also have the 1.4 fix applied but who knows when 1.5 pops up
     
  4. Wii Warrior
    OP

    Newcomer Wii Warrior Advanced Member

    Joined:
    Sep 21, 2008
    Messages:
    71
    Country:
    United Kingdom
    Thanks for the advice.

    So if I can get a dsi sooner rather than later it is still likely to have the 1.3 firmware.
     
  5. rockstar99

    Member rockstar99 Hi

    Joined:
    Dec 3, 2008
    Messages:
    7,375
    Location:
    Toronto
    Country:
    Canada
    yes get it now i got a white one a few days back it had 1.3 you should buy one by the en dof this month
     
  6. dragonbladerxx1

    Member dragonbladerxx1 GBAtemp Regular

    Joined:
    Sep 12, 2008
    Messages:
    270
    Country:
    United States
    when u get the acekard, and its in a different firmware, ask us if u dont know how to update it... =)
     
  7. Wii Warrior
    OP

    Newcomer Wii Warrior Advanced Member

    Joined:
    Sep 21, 2008
    Messages:
    71
    Country:
    United Kingdom
    Thanks for the offer



    The acekard hasn't arrived yet but when it does from what I have read I think I will be installing the akaio software.
     

Share This Page