Solved: DSTT not loading games, then cannot load menu

Discussion in 'DSTT' started by peterg19, Feb 4, 2009.

  1. peterg19

    Newcomer peterg19 Member

    Jun 17, 2008
    United States
    Recently I upgraded the firmware to my sons DSTT to 1.17 in an attempt to get a game working. The menu would load but the games would get stuck on "Loading...". After trying to revert back to 1.15 the menu would not even load anymore on any revision. Running dsttflashchecker tells me it is a legit DSTT and the flash memory is intact. I searched this board but could not find a solution. It is probably there, I just could not find it in the midst of all the fake-killer complaints.

    I tried the usual remedies and checks. Reformated the card with the panasonic SD formatter, use a working backup, see if another card works in the DS, swap out the memory chip, etc.

    The thing that made everything work again was to go into the settings on the DS and turn off the feature that auto-loads the slot-1 cart. After that all was well on any version.

    Hope this helps someone. Perhaps someone could even explain why this helped.

Share This Page