Hacking So I have 4.0.8 - any reason to update past 4.1.0?

Athe

Member
OP
Newcomer
Joined
Aug 22, 2015
Messages
16
Trophies
0
Age
41
XP
76
Country
Hello,

I bought a Wii U online at random and somehow managed to get one with 4.0.8 firmware. So I was wondering... for softmodding and game backup purposes, is there any compelling reason to stick with 4.1.0 or should I update to 5.0.0, or the latest version for online play?

Thanks
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
2
XP
18,256
Country
United States
If you plan on using Loadiine, some newer games won't work unless you are on 5.0.0 or higher. However, if IOSU comes out someday, it is possible it will come out for lower system versions first. Finally, Loadiine only works on the following versions:
  • WiiU v4.0.0
  • WiiU v4.1.0
  • WiiU v5.0.0
  • WiiU v5.1.0
  • WiiU v5.3.2
  • WiiU v5.4.0
  • WiiU v5.5.0
  • WiiU v5.5.1
 
Last edited by Lacius,

Athe

Member
OP
Newcomer
Joined
Aug 22, 2015
Messages
16
Trophies
0
Age
41
XP
76
Country
Thanks for responding, Lacius. Is there any significant difference between versions 5.0.0 and above? So far the only thing I've found is that 5.5.1 allows online play.
 

Lacius

Well-Known Member
Member
Joined
May 11, 2008
Messages
18,100
Trophies
2
XP
18,256
Country
United States
Thanks for responding, Lacius. Is there any significant difference between versions 5.0.0 and above? So far the only thing I've found is that 5.5.1 allows online play.
I guess it's possible that IOSU could be released for 5.0 (or 4.0) first but not 5.5.1, but we really don't know what it's likely to be released for, and it's certainly possible we'll never get IOSU. Other than that, I see no reason not to update to 5.5.1. Updating to 5.5.1 is also easier because you can just do it over the internet instead of finding the right disc with the 5.0.0 update.

Edit: My personal rule of thumb is to stay on the lowest software version possible. I'm on 5.3.2 with no reason to update. I would recommend you stay on 4.0. If there's a problem with game compatibility that's important to you, take the risk of missing out on future/better hacks and update.

Edit x2: I forgot to mention that you can use spoofing to play online on a lower system version.
 
Last edited by Lacius,
D

Deleted User

Guest
The most supported firmwares (in terms of homebrew) are 5.3.2 - 5.5.1.
However, the 5.1.2 firmware has a publicly documented (but unreleased) IOSU kernel exploit, and is the last firmware that allows exploiting the bug without needing to re-enable it. This IOSU exploit can actually be run on all firmwares with a userland entrypoint (at the time of writing, 2.0.0 to all higher firmwares), on the newer formwares (5.2.0+) it requires needing to re-enable the bug through some command trickery.

The theoretical rule is that staying on lower firmwares = more bugs to exploit, but you do what you want to do.
If you want higher compatibility in the future, stay where you are.
If you want higher compatibility now, get yourself a copy of Splatoon/Mario Party 10/other games, which will update you to 5.3.2.
 

Athe

Member
OP
Newcomer
Joined
Aug 22, 2015
Messages
16
Trophies
0
Age
41
XP
76
Country
Well I would like stuff like Loadliine to work, and according to Lacius it won't work on 5.1.2. So as much as I'd like to stick with older firmware, it looks like I'll have to pick between the app or 5.1.2. And anyway it sounds like what you're saying is that it the IOSU exploit will still work once released, but just take an additional step or two?
 
  • Like
Reactions: Deleted User

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    M4x1mumReZ @ M4x1mumReZ: @BentlyMods, Priiloader and BootMii as boot2 and you're all set