SNSHAX and 10.3

Discussion in '3DS - Homebrew Development and Emulators' started by UltraHurricane, Dec 28, 2015.

  1. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    is it safe to update my N3DS to 10.3? i've watched the presentation and it seems to imply that SNSHAX will support 10.3 but there has been a lot of talk that it won't, right now it's on 10.2
     
  2. Octoling

    Octoling Banned

    Banned
    304
    61
    Dec 28, 2015
    United States
    Same place as [INSERT NAME HERE]
    You can update because all 10.3 did was add support for the badge center
     
  3. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,326
    1,728
    May 30, 2015
    United States
    It is currently not possible on any firmware above 10.1, 10.2 patched it.
     
  4. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    well that's a bummer, does memchunkhax 2 look promising though?
     
  5. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,326
    1,728
    May 30, 2015
    United States
    Yep :)
     
  6. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    so it's totally cool to update now then? just as long as i don't update any further in the future
     
  7. dark_samus3

    dark_samus3 GBAtemp Addict

    Member
    2,326
    1,728
    May 30, 2015
    United States
    Yes sir/ma'am :)
     
    UltraHurricane likes this.
  8. enarky

    enarky owls?

    Member
    GBAtemp Patron
    enarky is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,056
    249
    Jul 31, 2003
    Afghanistan
    Do you need to update for a feature you can absolutely not live without? Then update, but stop that fucking annoying whining when something gets released and you can't run it.

    If not: DON'T FUCKING UPDATE!
     
  9. DKB

    DKB N I G H T M A R E

    Member
    GBAtemp Patron
    DKB is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,300
    1,256
    May 29, 2015
    United States
    New York City, Manhattan
    Calm down..

    ..but they are right. Don't update.
     
  10. mariosonicds

    mariosonicds GBAtemp Regular

    Member
    140
    144
    Oct 9, 2009
    United States
    Well i had that on my 9.9 n3ds from japan....
     
  11. enarky

    enarky owls?

    Member
    GBAtemp Patron
    enarky is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,056
    249
    Jul 31, 2003
    Afghanistan
    Maybe I was a bit harsh, but coming here sometimes is a bit like Groundhog Day.
     
  12. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    it doesn't really matter anymore since i was already on 10.2 for awhile and 10.1< is needed for SNSHax

    memchunkhax 2 and arm9loaderhax is going to support 10.3 anyway and from what i heard seems more promising

    — Posts automatically merged - Please don't double post! —

    that's still pretty uncalled for dude

    i don't think you even knew what we were talking about specifically
     
  13. enarky

    enarky owls?

    Member
    GBAtemp Patron
    enarky is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,056
    249
    Jul 31, 2003
    Afghanistan
    I think I know pretty well that you have no clue what you're talking about, otherwise you wouldn't have to ask whether to update or not. :)
     
    Last edited by enarky, Dec 28, 2015
  14. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    if you're trying to prove a point, don't.

    you're going off-topic anyway
     
  15. Pandaxclone2

    Pandaxclone2 Pokemon Sprite Artist Hobbyist

    Member
    1,016
    396
    Aug 17, 2015
    Australia
    noun; a particular place or position.
    Stuff it, I wouldn't update.

    Given the current information we've just recieved, this can potentially open the door to greater things like kernel theoretically. At that point you don't even need to update because you can just patch eShop to work. If anything I'd say updating could be risky. Why try to fix something that isn't broken?
     
    Last edited by Pandaxclone2, Dec 28, 2015
  16. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    i think you needed to be on 9.9 or below for a still working eshop spoofer, there hasn't been one on 10.x in quiet awhile
     
  17. Pandaxclone2

    Pandaxclone2 Pokemon Sprite Artist Hobbyist

    Member
    1,016
    396
    Aug 17, 2015
    Australia
    noun; a particular place or position.
    Again, it wouldn't matter because we've basically been given a backdoor that doesn't require updating and lets us do whatever. It's probably a bit early to say at this time but it's highly likely.
     
  18. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    I'm just asking since there doesn't seem to be a point sticking around on 10.2 if there's other kernel hacks in the works that'll support 10.3, which all of the userland exploits have just been recently updated to support
     
  19. Pandaxclone2

    Pandaxclone2 Pokemon Sprite Artist Hobbyist

    Member
    1,016
    396
    Aug 17, 2015
    Australia
    noun; a particular place or position.
    I'm not quite sure what is going on about that. From what I hear only ARM11 will be exploitable, which in turn would allow downgrading and finally access to the full kernel if you downgrade to 9.2. I may be missing something but it'd be beneficial to stay anyway as whatever kernel hax shows up for 10.3, it follows that it should work for older firmware versions too.

    Not only that, at this time there is conflicting information on the subject. Some are saying it'll only work up to 10.1, while others claim it'll work on 10.2 and even 10.3. It may work on O3DS only or it may work on N3DS only, or maybe both. At this time there's too much contradictions so until the dust settles, it's best to just sit tight and not update atm.
     
    Last edited by Pandaxclone2, Dec 28, 2015
  20. UltraHurricane
    OP

    UltraHurricane GBAtemp Regular

    Member
    194
    114
    Feb 18, 2013
    United States
    https://gbatemp.net/threads/wip-memchunkhax-2.407006/

    unlike snshax it'll support both n3ds and o3ds up to 10.3

    there's also ARM9LOADERhax though there's not much info atm and probably one more from smea's hacking presentation i'm missing