Smash 4 problems

Discussion in '3DS - Homebrew Development and Emulators' started by urlogic, Jan 5, 2016.

  1. urlogic
    OP

    urlogic Member

    Newcomer
    12
    2
    Jan 5, 2016
    United States
    So I'm using rxtools 9.2 CFW and obviously I don't have access to the eshop.

    I need to update my smash 4 to 1.13, but every .cia I've found just makes the game give the black screen error telling me to turn the system off.

    But if I delete the update data everything works fine... what could be causing this exactly? I've tried installing a smash 4 .cia and trying the update with that and still no dice.

    I can install updates for any other game and it works fine... only smash 4 doesn't work.
     
    Last edited by urlogic, Jan 6, 2016
  2. urlogic
    OP

    urlogic Member

    Newcomer
    12
    2
    Jan 5, 2016
    United States
    bump
     
  3. rufuszombot

    rufuszombot Assassin

    Member
    408
    175
    Apr 13, 2010
    United States
    The Moon
    Are you using EmuNAND? Try updating it to the latest FW.
     
  4. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,546
    Dec 22, 2009
    Canada
  5. urlogic
    OP

    urlogic Member

    Newcomer
    12
    2
    Jan 5, 2016
    United States
  6. rufuszombot

    rufuszombot Assassin

    Member
    408
    175
    Apr 13, 2010
    United States
    The Moon
    You can update your O3DS EmuNAND through the EmuNAND system settings no problem. You won't lose anything.
     
  7. urlogic
    OP

    urlogic Member

    Newcomer
    12
    2
    Jan 5, 2016
    United States
    Do GBA VC games require a FW higher than 9.2 as well? That's another thing that black screen error'd on me actually...
     
  8. rufuszombot

    rufuszombot Assassin

    Member
    408
    175
    Apr 13, 2010
    United States
    The Moon
    Do you have them installed on SysNAND and EmuNAND? They require patches, and have to be installed on both, since technically they're only ever running on SysNAND.
     
  9. urlogic
    OP

    urlogic Member

    Newcomer
    12
    2
    Jan 5, 2016
    United States
    I only had them installed on EmuNAND...which I'm in the process of updating now. My SysNAND remains at 9.2.
     
  10. rufuszombot

    rufuszombot Assassin

    Member
    408
    175
    Apr 13, 2010
    United States
    The Moon
    I'm not saying you need to update your SysNAND, but you still need to install the GBA games to the sysNAND for them to work on emuNAND. hold L when booting into RXTools and use Pasta mode to boot sysNAND and run FBI through HBL to install them.
     
  11. SilverGhost420

    SilverGhost420 GBAtemp Regular

    Member
    114
    9
    Aug 31, 2015
    Canada
    I did it with not error iPad it still works fine for me
     

    Attached Files: