Sky3ds+ system update

Discussion in '3DS - Flashcards & Custom Firmwares' started by Ygolonac, Feb 22, 2016.

  1. Ygolonac
    OP

    Ygolonac Member

    Newcomer
    25
    0
    Dec 31, 2015
    Canada
    I'm trying to play the american version of fire emblem fates conquest and birthright on my sky 3ds but It tells me I have to update my system to play them.

    If there a way around this? does sky 3ds+ support the latest firmware?
     
  2. HariGp

    HariGp GBAtemp Regular

    Member
    266
    51
    Jan 14, 2016
    India
    sky3ds+ supports FW 10.5
     
  3. Ygolonac
    OP

    Ygolonac Member

    Newcomer
    25
    0
    Dec 31, 2015
    Canada
    It it common to just update? I like to keep my firmware as low as possible in case something happens.
     
  4. HariGp

    HariGp GBAtemp Regular

    Member
    266
    51
    Jan 14, 2016
    India
    It isn't. But if you're on FW <= 10.3, then you can just downgrade and install CFW :) If you're going to stick to your sky3ds+, then it will work for FW 10.5
     
  5. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,956
    Jun 9, 2007
    Antarctica
    Sky3DS doesn't provide any sort of bypassing or spoofing, so if you have zero interest in CFW then you'll probably need to update to play it. You could try using something like HANS to bypass the update prompt if you have homebrew installed, I suppose, but I wouldn't get your hopes up (not sure if people with Sky3DS have tried it or not, so I'll let them chime in). If you're on 10.3 or below, you might want to instead consider downgrading to 9.2 and getting CFW, so you can still have the latest games & firmware via emuNAND with no worries about losing homebrew or anything. Your Sky3DS would be less important at that point, but you could still keep it as an easy tool for homebrew entry or if you absolutely must have .3ds versions of your games.
     
  6. nero99

    nero99 GBAtemp Addict

    Member
    2,021
    936
    Sep 18, 2014
    United States
    Unless your firmware is 9.3-10.3, you're better off updating. 9.3-10.3 allows downgrading to 9.0-9.2 with a special version of sysupdater homebrew.

    — Posts automatically merged - Please don't double post! —

    Damn. You beat me to it by a few seconds.
     
  7. Ygolonac
    OP

    Ygolonac Member

    Newcomer
    25
    0
    Dec 31, 2015
    Canada
    I'm on 9.8 25 U. is it alot of work to all the custom firmware stuff? is there any risk?
     
  8. James310

    James310 GBAtemp Advanced Fan

    Member
    879
    319
    Oct 4, 2015
    United States
    Somewhere in California
    Main Risk is downgrading without a hardmod...
     
  9. daxtsu

    daxtsu GBAtemp Guru

    Member
    5,546
    3,956
    Jun 9, 2007
    Antarctica
    There's always a risk when downgrading, since the system isn't designed to do it. At the worst you could end up with a bricked console. At best you'll end up on 9.2 with no issues. But some people will end up on a frankenfirmware (meaning that the console will contain bits of 9.2, and others of 9.9 or whatever firmware you were on), needing to be fixed before continuing onward to "true" 9.2. The downgrade isn't 100% stable, so it's sort of luck of the draw in terms of ending up on 9.2 safely. If you do end up on frankenfirmware you can almost always fix it, though.
     
  10. Ygolonac
    OP

    Ygolonac Member

    Newcomer
    25
    0
    Dec 31, 2015
    Canada
    I decided just to update. Thanks guys, I was just curious as I saw a "template file" for the games and wasn't sure if that was supposed to make it wok on low firmware.