Hacking Simple and quick question about flashing the R4i

Distrance

矢澤にこ
OP
Member
Joined
Nov 23, 2008
Messages
1,147
Trophies
0
XP
762
Country
Finland
In instructions, it says you need Nintendo DSi with firmware 1.4.1 or below, or a DS Lite. On some websites it says you need firmware that is BELOW 1.4. If I have a Nintendo DSi with 1.4.0 can I use it to upgrade my R4i Gold so it will run on my own DSi that has 1.4.1E ?

I need reply fast and I've searched and searched ... but because each source says different ( 1.4.0 or below and others say below 1.4.0 ... ) I'm just simply confused.
 

ShadowSoldier

Well-Known Member
Member
Joined
Oct 8, 2009
Messages
9,382
Trophies
0
XP
3,833
Country
Canada
Best to use below 1.4. I could be wrong, but if it's the same updating process as the Acekard, below 1.4 is better.

If you use a DSL [which is the best], it will work no matter what. And it won't damage your DSL at all.
 

anton134

Well-Known Member
Newcomer
Joined
Nov 21, 2009
Messages
58
Trophies
0
Location
Somehwhere...
XP
64
Country
you can use dsi 1.4.0 to update your r4i.
the website probably meant you can use 1.4.0 OR less...
anyway i updated my ak2i with the same dsi 1.4 i was going to update after.
use a DSL if your not convinced
 

Distrance

矢澤にこ
OP
Member
Joined
Nov 23, 2008
Messages
1,147
Trophies
0
XP
762
Country
Finland
Well the official instructions say something about using NDSi which has firmware of 1.4.0 or below, but all guides and websites I look from usually say below 1.4.0 so it was confusing me. I had to know as I don't have another DSi at my home so I'll have to go to my friends place to do this.

Thanks for the reply.
 

Distrance

矢澤にこ
OP
Member
Joined
Nov 23, 2008
Messages
1,147
Trophies
0
XP
762
Country
Finland
Ah.. I still need to confirm it once more. You see, I tried the R4i Gold on my friends DSi earlier on just to see if it works on 1.4.0, but it didn't. I got the same error to refer the manual. Now.. How exactly would the update work on the DSi if the R4 can't be launcher and it just gives me black screen and '' Refer to the manual '' error ?
 

Distrance

矢澤にこ
OP
Member
Joined
Nov 23, 2008
Messages
1,147
Trophies
0
XP
762
Country
Finland
No it doesn't *facepalm*

Or how would you explain me playing and using R4i Gold on my DSi when it had 3.7 firmware or something like that ?
 

Dter ic

~
Member
Joined
Feb 19, 2009
Messages
1,756
Trophies
0
Age
26
Website
gbatemp.net
XP
283
Country
Rydian said:
It has to be firmware 1.4 or below.
fixed
smile.gif
 

Rydian

Resident Furvert™
Member
Joined
Feb 4, 2010
Messages
27,880
Trophies
0
Age
35
Location
Cave Entrance, Watching Cyan Write Letters
Website
rydian.net
XP
8,920
Country
United States
Dter ic said:
Rydian said:
It has to be firmware 1.4 or below.fixed
smile.gif
QUOTE(Distrance @ Nov 27 2010, 05:51 PM)
You see, I tried the R4i Gold on my friends DSi earlier on just to see if it works on 1.4.0, but it didn't.

Both 1.4 and 1.4.1 blocked flash carts. If it doesn't run on 1.4 then the cart probably hasn't been updated to bypass the 1.4 block (so it can't run to be flashed to bypass 1.4.1 either), you'd need 1.3 or below on a DSi (or any DS/Lite).
 

Distrance

矢澤にこ
OP
Member
Joined
Nov 23, 2008
Messages
1,147
Trophies
0
XP
762
Country
Finland
Ahh that makes sense. Then the only solution is to use my bro's Lite when he isn't home.

Thanks for the reply.
 

Distrance

矢澤にこ
OP
Member
Joined
Nov 23, 2008
Messages
1,147
Trophies
0
XP
762
Country
Finland
Havent managed to do this yet but now it got me wondering .. I got the update file with nds extension and I got it on the sd card... Do I need any other files on the sd card ? You know, like the normal files with the system folder etc. If I do, where do I put this update file to then .. to the games folder ?
 

Dter ic

~
Member
Joined
Feb 19, 2009
Messages
1,756
Trophies
0
Age
26
Website
gbatemp.net
XP
283
Country
i assume the r4i gold is this one \

dopwnoad the latest kernal, backup all your files, then format with sd formatter then put the kernal in the root of sd( eg E:/) then place either R4iDS_GOLD_update_141_DSi.nds if running the update from the dsi with 1.3 or below or R4iDS_GOLD_update_141_DSL.nds if running form a ds lite
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    M4x1mumReZ @ M4x1mumReZ: @FAST6191, Rats, rats, we are the rats.