showmiiwads 1.4

Discussion in 'Wii - Hacking' started by djc151084, Jun 25, 2011.

Jun 25, 2011

showmiiwads 1.4 by djc151084 at 10:55 AM (2,920 Views / 0 Likes) 10 replies

  1. djc151084
    OP

    Newcomer djc151084 Member

    Joined:
    Mar 21, 2011
    Messages:
    24
    Country:
    United Kingdom
    im trying to use this program to install wads to my emulated nand on my 10GB FAT32 Primary and active partition on my external harddrive, all looks like it goes ok and the wads show up in showmiiwads with no errors but when i plug the harddrive in to the wii and open triiforce it only shows the wads that were already installed to my nand through the wii at time of the backup ? any help please im pulling my hair out [​IMG] is there any alternatives to showmiiwads, WadManager 1.5 also is not much help as at the start i choose emu nand then when i choose source next i get an error and it wont go any further.

    Here is a previous post of mine, and this is what i ultimatly want to achive what was reccomended by Wever - http://gbatemp.net/t298377-cfg-usb-loader-show-vc-games

    thanks
    djc
     
  2. scooby74029

    Member scooby74029 "fake coder"

    Joined:
    May 7, 2010
    Messages:
    1,174
    Location:
    oklahoma, USA
    Country:
    United States
    this is because triiforce uses the banner from a game save for its gamelist so if you havent played the game at least once then it wont show up

    a way around this add a couple of games to wii and then use bluedump alpha 3 to get the savedata folder and add it to your emu nand
     
  3. djc151084
    OP

    Newcomer djc151084 Member

    Joined:
    Mar 21, 2011
    Messages:
    24
    Country:
    United Kingdom
    ok so i must have playd every wad i added at least 1ce ? how would bluedump work if i havnt playd the game then there will be no savedata for it ?

    thanks
    djc
     
  4. djc151084
    OP

    Newcomer djc151084 Member

    Joined:
    Mar 21, 2011
    Messages:
    24
    Country:
    United Kingdom
    does this mean i have to installl these wads on my real nand before i can play them on my emu nand ?

    thanks
    djc
     
  5. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,123
    Location:
    Belgium
    Country:
    Belgium
    Are you sure about this? I have installed and ran multiple Wiiware through triiforce (and its modifications) and it works just fine most of the time*.

    I think that the problem is that initially, djc151084 had a number of games on his nand (say: 3). Then he dumped it, extracted it and used showmiiwads to add a couple extra games to it (say: 2 extra, for a total of 5).
    The problem is that when he runs triiforce, only the initial 3 are found. My guess is that it just lists the wiiware in the real nand instead of the emulated nand, and that the latter isn't found somehow.

    @djc151084: are you sure the emulated nand is in the correct space? It should be on the root of your FAT32 formatted drive, and consist of the following folders:

    import
    meta
    shared1
    shared2
    temp
    title
    ticket
    sys


    I haven't mentioned it in the other thread, but it's important to know that triiforce requires a cIOS with proper emulation capacities in slot 249. You can go with the outdated Waninkoko's rev17, or with the more recent d2x cIOS (see the stickies of the hacking forum).

    Unfortunately...the forwarder iso's created by wad2iso (the program I mentioned in that other threads) only work with rev17. By itself, this isn't so bad...but it may require some organisational discipline (if rev17 is in slot 249, you'll have to install the best up to date cIOS in 246, 247, 248 and/or 250...and try to avoid setting your games to use 249 to run games).




    @scooby: Say...the fellow is trying to access his wiiware through CFG. Isn't this the perfect time to plug Joyloader_CFG? You modded the loader to do exactly that: allow to load channels as well as games. [​IMG]




    @djc151084: I'll have to warn you, though: joyloader is a modification of CFG, and still in beta stages. While it technically works to load games and channels, there are still a lot of bugs at this point.





    *the bit.trip series are an exception: for some reason, they cannot create that initial savegame.
     
  6. djc151084
    OP

    Newcomer djc151084 Member

    Joined:
    Mar 21, 2011
    Messages:
    24
    Country:
    United Kingdom
    Ok i finally got somewhere , i loaded cIOS249-v17b.wad and finally the games show in triiforce and mighty channels and load all fine, but when i go back into cfg usb loader and try loading 1 of the shortcuts there i get a error saying i need at least 249 rev18 to load games and this happens for all games wii or emu nand games,

    so then i went and installed cIOS249[58]-d2x-v6.wad now the games still show and load in triiforce, but mighty channels will not open my emu nand, not a problem as i dont want to use that program anyway,

    So i open cfg usb loader and all my wii games load up just fine like before but nnow the shortcuts to the wad files i installed on my emu nand do not load just freeze my wii with a black screen, do you know my problem,

    all help is much appriciated and i couldnt have got this far without you.

    thanks guys
    djc
     
  7. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,123
    Location:
    Belgium
    Country:
    Belgium
    Ok i finally got somewhere , i loaded cIOS249-v17b.wad and finally the games show in triiforce and mighty channels and load all fine, but when i go back into cfg usb loader and try loading 1 of the shortcuts there i get a error saying i need at least 249 rev18 to load games and this happens for all games wii or emu nand games,

    Ow...you were pretty close there, mate. Getting to run the games on triiforce is actually the hardest part.

    Here's the unfortunate thing: pretty much all guides want you to install some cIOS in slot 249 (this includes modmii). But like I said: it must have rev17 in that slot or it won't work for the forwarder iso's*.

    The mention of CFG is actually correct. I forgot to mention this: it's the forwarder iso itself that will use 249 (which is the reason rev17 should be there). However, you must indeed configure CFG to use another cIOS to run that forwarder iso. It's been a while since I used those things, but I'm pretty sure I used either Hermes's 222 or 223 to run it.

    The d2x should work fine as well...but obviously, you cannot overwrite rev17. You mentioned you installed "cIOS249[58]-d2x-v6.wad". With the current naming scheme of modmii, this means that installing this wad overwrites rev17, which caused those other errors mentioned in your post.
    modmii has a way to change those slot numbers, so pick another one. [​IMG] (oh, and a hint: use base IOS56 instead of 58. It works much better for other games [​IMG] ).

    ...and don't forget to reinstall rev17 before testing again. [​IMG]







    *not entirely true. when you create the forwarder iso's, you can choose the ios slot as well. If you can install rev17 in another slot (say...240) and create the forwarder iso to use that same slot (240), then it will work as well. but getting rev17 in that 240 slot isn't easy, as the installer won't give you that option. You'll have to dump it into a wad (with bluedump**), then edit it to change the slot number (with showmiiwads** - you can ignore the bricking warning if you remember to enter a number above 200) and finally install the wad on your wii with a wad manager. But all in all, this solution isn't exactly easy to follow. [​IMG]


    **note that I'm not sure these are the programs. if someone can confirm/deny this, it'd be great
     
  8. djc151084
    OP

    Newcomer djc151084 Member

    Joined:
    Mar 21, 2011
    Messages:
    24
    Country:
    United Kingdom
    ok i got some progress wad2iso dont offer me to use 240 slot so i used 247 and editid the slot on 249rev17 to 247rev17 (i previosly did not have 247 installed) also i installd cIOS249[56]-d2x-v6.wad in slot 249 as you suggested,

    now the games do load from cfg usb with the iso shortcuts but when i exit 1 of the "wad" games the wii hangs and i have 2 pull the power,

    thanks for your help m8

    djc
     
  9. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,123
    Location:
    Belgium
    Country:
    Belgium
    Good to hear it starts. I'm afraid I can't help much in why it fails when quitting the game. It could be the loader (I used wiiflow, mostly), it could be the d2x (I did it before that came along) or even something in wad2iso.

    All I can say is that a wii has a same shut down mechanism as a PC: hold the power button for 5 seconds and it will turn off, no matter what.
     
  10. djc151084
    OP

    Newcomer djc151084 Member

    Joined:
    Mar 21, 2011
    Messages:
    24
    Country:
    United Kingdom
    ok thanks for all your help Wever [​IMG] maybe there is a way i could help you in the future, i am very advanced in gps (sat-nav) upgrading/modifacation expecially tomtom, if you ever need help pm me [​IMG]

    djc
     
  11. zizer

    Member zizer GBAtemp Addict

    Joined:
    Aug 23, 2010
    Messages:
    2,035
    Country:
    it is known issue of triiforce
     

Share This Page