Should I?

Discussion in 'PSP - Games & Content' started by Morphn8r, Dec 13, 2008.

Dec 13, 2008

Should I? by Morphn8r at 11:48 PM (1,103 Views / 0 Likes) 8 replies

  1. Morphn8r
    OP

    Newcomer Morphn8r Newbie

    Joined:
    Nov 14, 2008
    Messages:
    7
    Location:
    Anchorage, AK
    Country:
    United States
    I have a GOW Blood Red PSP with 3.71 M33-4 on it(took me a while to do it myself [​IMG] )and I wanna Play Kateikyoushi Hitman Reborn on it but I can only do that if it has 4.01 M33-2 on it so should I Upgrade and put 4.01 M33-2 on it?
    Share your thoughts please all thoughts are accepted(that have to do with this topic)!!!
     
  2. myuusmeow

    Member myuusmeow GBAtemp Advanced Maniac

    Joined:
    Jun 24, 2007
    Messages:
    1,643
    Country:
    United States
    Why wouldn't you? I have no problems with 5.00 M33. You should just update everytime a new CFW comes out.
     
  3. Morphn8r
    OP

    Newcomer Morphn8r Newbie

    Joined:
    Nov 14, 2008
    Messages:
    7
    Location:
    Anchorage, AK
    Country:
    United States
    Thanks I will do that then! [​IMG]
     
  4. ShinRyouma

    Member ShinRyouma GBAtemp Advanced Fan

    Joined:
    Dec 6, 2008
    Messages:
    956
    Location:
    Surabaya
    Country:
    Indonesia
    In my opinion, if you really really want to play Kateikyoushi Hitman Reborn you should upgrade your CFW, beside you can play other new games as well.
    My current CFW is 4.01 M33, although there's 5.00 M33-4 I'm satisfied with my current CFW. Unless my CFW can't play new games that I really want, I won't upgrade it. Why? Cause new CFW doesn't mean better than the old ones, sometimes there're problems and new upgrade will be release to fix them. That's my opinion, the choice is yours [​IMG]
     
  5. Morphn8r
    OP

    Newcomer Morphn8r Newbie

    Joined:
    Nov 14, 2008
    Messages:
    7
    Location:
    Anchorage, AK
    Country:
    United States
    Yeah thats why I have Doubts...can I play games that work on all the other firmwares that came before 4.01?
     
  6. ShinRyouma

    Member ShinRyouma GBAtemp Advanced Fan

    Joined:
    Dec 6, 2008
    Messages:
    956
    Location:
    Surabaya
    Country:
    Indonesia
    Yes, so far I can play old games. If not, you let me know [​IMG]
     
  7. kai445

    Member kai445 GBAtemp Fan

    Joined:
    Oct 16, 2006
    Messages:
    325
    Country:
    United States
    I use 5.00 M33-4 and love it.
     
  8. Diablo1123

    Member Diablo1123 Newcomer

    Joined:
    Mar 9, 2008
    Messages:
    1,432
    Location:
    Underground
    Country:
    United States
    If there are any problems, you'd probably be able to downgrade if you still have a Pandora battery.
     
  9. reimu

    Newcomer reimu Advanced Member

    Joined:
    Dec 28, 2007
    Messages:
    68
    Location:
    Somewhere Over the Rainbow
    Country:
    Canada
    Yup, never had any problems with my 5.00 M33, just make sure you also install the 1.5 kernel so you can play homebrew games and such. [​IMG]
     

Share This Page