SDHC weird problem

Discussion in 'Wii - Hacking' started by EndlessDiversity, Dec 28, 2009.

  1. EndlessDiversity
    OP

    EndlessDiversity Member

    Newcomer
    38
    0
    Oct 22, 2008
    New Zealand
    New Zealand
    I never had this problem before, i've been using 4G SDHC Kingston for my wii since 4.0E.
    it work fine until just now when i follow this guide to update to 4.2, http://gbatemp.net/index.php?showtopic=171901

    My 4GB can be read by HBC (latest version 1.0.6), but the problem start when i tried to use wadmanager, wadmanager keep returning error -1 which mean hardware error.
    i tried my other 2GB SD card and it work fine, so i thought the problem was my 4GB card, but it work fine on PC tho, i tried to reformat it with different mode and still no luck.

    my wii seem doesn't recognize SDHC but HBC does, its so weird, could it be because i install IOS60 with trucha patch?

    could someone please tell me how to re-enable SDHC card? atm i am on 4.1E (downgrade from 4.2 to 4.1 using http://gbatemp.net/index.php?showtopic=171901)

    help would be really appreciate.
     
  2. wadzinsky

    wadzinsky Advanced Member

    Newcomer
    98
    0
    Dec 16, 2009
    United States
    Uranus
    SDHC cards are not recommended for use in the Wii for HBC, or NAND backups. Non SDHC cards are more widely accepted for Wii and homebrew. Just because it works in your PC doesn't mean it will work in your Wii. SDHC is slightly different in composition than standard SD. Certain programs may not contain the code to use SDHC properly (and that will make it seem like it isn't recognized)

    Also, unless you are running different region games on your Wii, there is no reason to downgrade from 4.2 to 4.1