SD card screwed

Discussion in '3DS - Flashcards & Custom Firmwares' started by Pacheko17, Jan 19, 2017.

  1. Pacheko17
    OP

    Pacheko17 かっこい男の子

    Member
    1,211
    1,145
    Jan 31, 2015
    Brazil
    Southern Confederation
    I'm making a new post because this is a rather different problem from my last post.
    Basically I bought a new 32gb sd card, formatted it to fat32, cluster at 32kbs, primary, bla bla bla
    I've checked on h2testw and it's ok.

    After I moved everything, I popped it in my 3DS and it just gave me a black screen.
    So I formatted it with Minitool as suggested by a temper, and it worked, but my cia games wouldn't launch and my homebrew and SNES BlargVc injects had no banners.
    So I tried deleting everything corrupted on system settings and downloaded the cias of the homebrew I use to install with H&S injected FBI, but FBI was not giving me the option to install those CIAs and when trying to update FBI, it just gave me an error saying it was not able to update.

    So I formatted again and bam, black screen, so I formatted AGAIN and I'm having the same problem.

    It could be that this SD card is faulty, but it has shown no signs of problems and works on anywhere else. Popped it in my phone, downloaded an app on it, restarted the phone and the app was still there working, not corrupted.

    I really need help because I really don't plan on using this SD card on my phone, I bought so I could use the 8gb one on the 3DS on my phone, but the universe apparently fucking hates me and wants everything to go bad.

    EDIT: The old SD card still works fine on the 3DS. Everything launches normally... but it's just 8gbs.