RxTools not Loading from Ctrbootmanager

Discussion in '3DS - Homebrew Development and Emulators' started by inhenccee, Jan 14, 2016.

  1. inhenccee
    OP

    inhenccee Member

    Newcomer
    31
    2
    Jan 4, 2016
    United States
    Im using o3ds XL. My SysNAND is 9.2, and my EMUNAND is 10.3

    I've tried to set up a cold boot from scratch multiple times, making sure each program (rx tools, homebrew, menuhax) works properly. But whenever I get CTRBootmanager involved, something ends up breaking. My 3ds will boot to CTRbootmanager, attempt to load RX tools, then when RX tools attemps to load, the screen glitches out as if I were trying to load homebrew, then I'd get a prompt telling me that something went wrong and to reboot my console. Anyone experience the same problem? I've been at this for hours now to no avail.
     
    Last edited by inhenccee, Jan 14, 2016
  2. NekoMichi

    NekoMichi Retro Collector

    Member
    1,304
    928
    Jun 4, 2015
    Minus World
    Does rxTools boot normally through other entry points like NinjHax?
    Do you have the correct firmware.bin in the right folder and slot0x25keyx.bin files at the root of the SD card?
     
  3. Walo

    Walo GBAtemp Regular

    Member
    117
    3
    Aug 4, 2008
    Cote d'Ivoire
    I'm having the same issue and was told it was because it also have menuhax on the emunand so it'll constantly loop trying to boot rxtools.

    I was told that by unlinking the sysnand and emunand you can get rid of menuhax on emunand, but I'm worried it might delete my eshop games as I don't have a NNID, so I haven't taken the plunge yet.
     
  4. inhenccee
    OP

    inhenccee Member

    Newcomer
    31
    2
    Jan 4, 2016
    United States
    My nands are already unlinked, and Im still having the problem

    — Posts automatically merged - Please don't double post! —

    I havent tested rxtools from anything other than from the browser (launch.rxtools.net), and I dont have any slot0x25keyx.bin files in my sd card? Are they necessary?
     
  5. Walo

    Walo GBAtemp Regular

    Member
    117
    3
    Aug 4, 2008
    Cote d'Ivoire
    Try changing your theme on emunand to see if it's because you still have menuhax on it.
     
  6. vb_encryption_vb

    vb_encryption_vb That hardmod guy....

    Member
    1,914
    917
    Nov 21, 2015
    United States
    Acworth, GA
    Did you edit the rop payload?
     
  7. TheGlow

    TheGlow GBAtemp Regular

    Member
    149
    32
    Nov 23, 2013
    United States
    Da Bronx
    Did you set Menuhax to Type2 so auto boots with no button pressed? That is actually still in effect once rxTools loads.
     
  8. rasputin

    rasputin GBAtemp Advanced Fan

    Member
    938
    115
    Mar 7, 2008
    United States
    you have to break menuhax in emunand by changing theme.. if you're still linked it will break in sysnand too
     
  9. inhenccee
    OP

    inhenccee Member

    Newcomer
    31
    2
    Jan 4, 2016
    United States
    JUST FIXED-- What I did

    Before all this, I used a backup of rxTools 2.6 I had saved.

    1) Installed menu manager

    2)Dragged CTR boot manager to sd card root

    3) Held L to boot into emunand directly from power up

    I did not do anything with Menu Manager Type 1 Type 2 Config. I left that alone
     
  10. Ripper00420

    Ripper00420 GBAtemp Advanced Fan

    Member
    740
    224
    Nov 5, 2013
    United States
    Can't you noobs stop making threads, and read one for a change. Your clogging the information from this site!!!!
     
  11. Elemi

    Elemi Yo!

    Member
    131
    107
    Feb 29, 2012
    England
    How ironic, nobody gives a fuck about people like you with your ridiculous and elitist opinions, your post is the most useless post in this whole thread.

    EDIT: I came to this thread because I had the same problem and had not found a fix despite frequent searching, which makes this a useful thread no?
     
    Last edited by Elemi, Jan 14, 2016
  12. Ripper00420

    Ripper00420 GBAtemp Advanced Fan

    Member
    740
    224
    Nov 5, 2013
    United States
    ^And this is my point exactly.... Sad huh.