RXtools EMUnand update softbricks my system?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Axlfox, Feb 25, 2016.

  1. Axlfox
    OP

    Axlfox Member

    Newcomer
    43
    4
    Feb 25, 2016
    United States
    Hello everyone. This is my first time posting here because there's something I need urgent help with.

    So recently I managed to set up EMUnand using RXtools (with no flashcart) its unlinked to the sysnand and the firmware is currently on RX 9.2, everything works just fine, the problem is the following.

    Im currently trying to update my firmware, ofc I do it from system config, the update seems to download just fine, it tells me that the update is complete and it prompts me to restart. HOWEVER when I restart my system, emunand greets me with a black screen and a popup that says "an error has occurred, please restart your 3DS system" and before I can do anything else, it kicks me back to menuhax loader. It does this each time I restart, so basically the update renders the emunand useless, so I have to re-install my 9.2 backup in order for it to work again.

    I tried to update again several times and the same thing happened, I also tried to install the new firmware via CIA installer and RX's injector, but none of them worked either. I tried searching for answers everywhere but no one seems to have faced the same problem as me, is there a solution at all?
     
  2. Raylight

    Raylight Paranoid Temper

    Member
    988
    359
    May 10, 2014
    United States
    Who wants to know?
    you using the latest rxTools?
     
  3. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    988
    330
    Apr 28, 2013
    You can still boot rxtools after that? Can you check your sysnand firmware version now?
     
  4. mitroux

    mitroux GBAtemp Regular

    Member
    263
    51
    Sep 12, 2007
    Macau
    are you using a n3ds?
    if yes , you need to grab the latest nighty , and also those new firmwares
    key_0x16.bin (N3DS arm9bin decryption, 9.6+ keyX) and key_0x1B.bin (N3DS 9.6 NCCH keyX) on the root of your SD card.
     
  5. Axlfox
    OP

    Axlfox Member

    Newcomer
    43
    4
    Feb 25, 2016
    United States
    I... actually dont remember, I think Im up to the last "official" version

    Yeah, I was able to access rxtools, but not the rxtool system menu

    Im using an old 3DS XL.
     
  6. Raylight

    Raylight Paranoid Temper

    Member
    988
    359
    May 10, 2014
    United States
    Who wants to know?
    You need rxTools 3.0 Beta 2
     
    Last edited by Raylight, Feb 25, 2016
  7. cid xiv
    This message by cid xiv has been removed from public view by Minox, Feb 25, 2016, Reason: Trolling.
    Feb 25, 2016
  8. Axlfox
    OP

    Axlfox Member

    Newcomer
    43
    4
    Feb 25, 2016
    United States
    Could you please give me more clear instructions? Im not very experienced with this sort of stuff.
     
  9. Dracari

    Dracari GBAtemp Maniac

    Member
    1,487
    407
    Apr 5, 2009
    United States
    with an Old3DS, https://mega.nz/#!1M0AEYiI!dX8iOKL1JFyVRetmrCbNaDSaB8vsVg9GP0sk02TEBDw Delete the rxtools.bin on the root of teh SD if its an ooooold stable, extract rxtools folder from this to the root of the SDCard run from this in tools " o3ds_cdn_gen.py" copy that firm folder to the rxtools folder on the SDCard you can "Delayed coldboot these builds of RXTools using ctrbootmanager or you can use the rxtools loader for Homebrew Launcher(which hasto be launched from HBL ala Sysnand

    you can use this guide http://gbatemp.net/threads/tutorial-more-or-less-catch-all-tutorial.407080/ to setup ctrbootmanager to load the nightlies versiosn of rxtools. Upside w/ these over the oooold stable builds, you dont nee dto boot into sysnand for DSIware/DSFlashcards/Retail cards anymore.
     
  10. Axlfox
    OP

    Axlfox Member

    Newcomer
    43
    4
    Feb 25, 2016
    United States
    Ok so Im using the latest rxtools (turns out I was using 2.6) and I managed to update to the latest firm without bricks. But now it pops up and error whenever I try to use the Eshop or trying to update my software.
     
  11. Dracari

    Dracari GBAtemp Maniac

    Member
    1,487
    407
    Apr 5, 2009
    United States

    if you unlinked the NANDs using tiny Format (andindeed on EmuNAND 10.6) you nee dto relink your NNID via Settings.
     
  12. Axlfox
    OP

    Axlfox Member

    Newcomer
    43
    4
    Feb 25, 2016
    United States
    You mean in both Sys and Emunand?
     
  13. GKGC34

    GKGC34 GBAtemp Regular

    Member
    124
    12
    Jan 13, 2016
    France
    Hi @Axlfox!

    Do you have TubeHax DNS activated? It may be the cause of the error.
     
  14. Axlfox
    OP

    Axlfox Member

    Newcomer
    43
    4
    Feb 25, 2016
    United States
    Hello!

    Nope, I dont use browser exploits.
     
  15. Ericzander

    Ericzander I used hax to get yellow name

    pip Reporter
    1,501
    1,449
    Feb 28, 2014
    United States
    Grand Line
    If you're a visual learner, I made this video a few days ago going over the process.

     
  16. GKGC34

    GKGC34 GBAtemp Regular

    Member
    124
    12
    Jan 13, 2016
    France
  17. Axlfox
    OP

    Axlfox Member

    Newcomer
    43
    4
    Feb 25, 2016
    United States
    GKGC34 likes this.