1. gudenau

    OP gudenau Largely ignored
    Member

    Joined:
    Jul 7, 2010
    Messages:
    3,712
    Country:
    United States
    I have a Raspberry Pi and I would like to see if I can get an x86/x86-64 program running on it. I know it will not work that well, this is more of a "because I can" thing.

    My current idea is to setup QEMU with some sort of chroot directory that runs as x86/x86-64 then run the program with WINE.

    I have tried to do this a couple of times but I was not successful, any suggestions as to what I should do?
     
  2. gudenau

    OP gudenau Largely ignored
    Member

    Joined:
    Jul 7, 2010
    Messages:
    3,712
    Country:
    United States
    Update on this.

    I'm trying to use debootstrap to setup an amd64 environment and I can't get it to work. I've tried with and without --foreign but it errors out with something like "mount proc proc /proc failed", and when running the debootstrap binary under qemu when using --foreign it says that there is an error in the executable.

    Must be doing something wrong here...
     
  3. bobmcjr

    bobmcjr GBAtemp Maniac
    Member

    Joined:
    Apr 26, 2013
    Messages:
    1,045
    Country:
    United States
  4. gudenau

    OP gudenau Largely ignored
    Member

    Joined:
    Jul 7, 2010
    Messages:
    3,712
    Country:
    United States
    Seems that was about what I tried at first but couldn't get working. I would still like to try and get the chroot thung working with qemu.
     
Draft saved Draft deleted