RetroArch - PCSX ReARMed - Memcard Files?

Discussion in 'iPhone, iPod & iPad' started by jonthedit, May 12, 2014.

  1. jonthedit
    OP

    jonthedit GBAtemp Advanced Maniac

    Member
    1,691
    438
    May 30, 2011
    Bangladesh
    [This is posted here on gbatemp because Libretro's forum post button is broken... maybe someone here can help]


    Hello. I have been actively using RetroArch since the iOS release quite a while ago. I

    love the work you guys put into this and can not say thank you enough for all your

    hard work! It is shameful to see people create unofficial clones to make a money off

    your work!

    Before I Begin:
    iPad 2,1 - iOS 7.0.6 - Jailbroken
    RetroArch - Installed from official "themaister" repo - v1.0.0.1
    BTStack - Installed from BigBoss repo - v0.8-3



    On to questions.
    Here is the main question I created this topic for:
    Q1: Memory Card Files: Where are the memory card files and what format are

    they in?
    I am using the PCSX ReARMed core with PSX games. I want to copy/replace the memory

    card that the emulator uses for saves. I am not talking about save states, I found

    those files in the /var/mobile/Documents/.RetroArch folder. My configs save

    great, save states work awesome, and normal saves work great as well. That is why I am

    confused. There is no ".mem", ".mcd", ".mcr", ".gme", ".ddf", ".psx", ".ps", ".psm",

    ".VMP", or ".VM1" files. Unless RetroArch has a special memory card file type that I

    am not aware of, I can not find the memory card file. I even searched in

    /Applications/RetroArch.app. I know RetroArch does indeed use some sort of

    memory card file as when I load up a game without a save state the "actual save" is

    present. (I have tested this on a few games).

    The following are now secondary questions, unrelated to the topic above, not

    crucial but I would like an answer if possible, thanks!


    Q2: WiiMote + Nunchuck: Nunchuck not registering?
    I own two official generation 1 WiiMotes that connect seamlessly with RetroArch. I

    read that people have got the Nunchuck and ClassicController extensions to work with

    RetroArch, however upon modifying the "Input" for "Joystick" Nunchuck does not effect

    the menu. I have tried with different WiiMotes and even 3rd party remotes (some 3rd

    party remotes do not connect with RetroArch, like the non-genuine PS3 controllers).

    What am I doing wrong? I have tried connecting without Nunchuck, then connecting the

    Nunchuck, and vise-versa.

    Q3: NonGenuine PS3 Controller Support: RetroArch does not like the

    controllers!
    I own two non-official PS3 controllers (fake ones someone sold to me on eBay) and they

    work great besides the obvious cheaper components and different bluetooth

    protocols/identification. Because of this, RetroArch fails to connect to either

    controller even after proper pairing via PC. A 3rd party application, BLUTROL, (sorry

    if you do not like me posting about other tweaks, I will remove if necessary), is

    capable of connecting perfectly with the remotes and I have used it over the RetroArch

    bluetooth a few times. It works, but not perfectly because of the obvious "not

    officially integrated into the app".
    I was wondering if there are any plans to allow/workaround to connecting these non-

    genuine controllers.


    Thank you for taking the time to read this,
    I appreciate your support and your dedication to RetroArch! :)