RetroArch and Snes9x Errors.

Discussion in 'Computer Programming, Emulation, and Game Modding' started by mikeyt1998, Jan 5, 2015.

  1. mikeyt1998
    OP

    mikeyt1998 YouTube Glitcher

    Member
    1,401
    64
    Aug 11, 2007
    Dalton-in-furness, north west
    I'm trying to play a couple of SNES games through the use of Emulation. I'm not new to emulation or anything, I mostly use my WiiU which is flawless usually, just fancied trying out some PC to try it out.

    Upon attempting to load both SNES 9x and retroarch, I come to a standstill. First it asked for missing file d3dx9_38.dll and once that was located it asked for d3dx9_43.dll. With them both in place the Emulators BOTH now say the application was unable to start properly (0xc000007b)

    I can't understand what my problem is, the computer is 100% powerful enough. I've tried installing the latest DirectX runtime files too but still nothing. OS is Windows 8, processor intel i5, Nvidia Graphics Crad and 8GB Memory so shouldn't have much problem unless it's the OS itself that won't work right. I tried compatibility mode but still nothing :(

    if anyone can help me out with this I'll be damn grateful! Thanks!


    BIG FAT EDIT. I managed to get it to work. For anyone interested, installing DirectX from the microsoft website directly didn't help me, Kept getting the same errors. However I found an old forum post relating to it and found that a 'redist' install made everything work...

    I don't know exactly what was different about it, but it first downloaded what seemed to be update files, if that's what CAB extensions are? Some kind of Microsoft compression? I dunno.

    Anyways, it also downloaded an application, which rwhen run installed all of the files intot he correct places, but what was different about that to the online installer I'll never know... Thanks anyways to those who viewed!