R4i sdhc ERROR (NEED HELP!) *desesperate*

Discussion in 'R4 DS' started by mike3003, Mar 16, 2011.

Mar 16, 2011
  1. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    Hello,
    here's the problem:

    I recently bought an R4i SDCH compatible with my NDS original(the first of all versions)

    Then, I downloaded the newest kernel for my R4i web page, and I extracted all files to my TF card's root.

    When I select the icon of my r4 at NDS menu appears the following error: "Loading ...Please upgrade the hardware to support latest firmware"


    Aditional information:

    website of my R4i: http://www.r4isdhc.com/

    my R4i and kernel: http://www.r4isdhc.com/download_v2-0i/

    my R4i doesn't work on my NDS original, but it works on NDS LITE

    I tried the latest kernel in 2 micro SD cards (256Mb and 8GB)

    EDIT:
    The icon of my R4i at the menu is Alex Rider: stormbreaker... this isn't the icon of Acekards?? My R4i could be a clone of an Acekard
    here the image:
    http://i850.photobucket.com/albums/ab62/Lp...ld/DSCN5371.jpg
     
  2. injected11

    Member injected11 Crescent Freshâ„¢

    Joined:
    Jul 17, 2009
    Messages:
    1,776
    Country:
    United States
    The error message is telling you to purchase a new cart. The firmware you're trying to use on it is no longer supported. Either go back to your old firmware and look into secondary firmwares that will enable you to play new games (like WOOD or YSmenu), or buy a new cart.
     
  3. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    I think you are not understanding... My r4 is recent and it always had this problem! I never could fixed it. This R4i sdhc doesn't work on my NDS orginal but it works on DS Lite, I have already tried :s
     
  4. injected11

    Member injected11 Crescent Freshâ„¢

    Joined:
    Jul 17, 2009
    Messages:
    1,776
    Country:
    United States
    The "Loading... upgrade hardware" message means you loaded a firmware onto it that is meant for a newer version of your cart. The cart shouldn't work on either system if displaying that message. If it doesn't display that message, and works on one DS and not the other, the problem is likely contact issues. Try the "paper trick" (use the search bar).

    If that message keeps appearing, you're still going to need to downgrade back to your old firmware, or buy a new cart.
     
  5. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    thanks for your help! [​IMG] I will search about that trick and later I will post the results (hope that my r4 works**)

    EDIT: [​IMG] That trick didn't work for me! When you are saying to have an old firmware what kernel do you think I should try??

    Remembering... website: http://www.r4isdhc.com/
    my R4i: http://t3.gstatic.com/images?q=tbn:ANd9GcT...qkE1nbv&t=1

    HELP!!
     
  6. iggloovortex

    Member iggloovortex GBAtemp Advanced Fan

    Joined:
    Nov 20, 2009
    Messages:
    771
    Location:
    Stratford, CT
    Country:
    United States
    are you sure thats your r4i? are you not confusing it for this?
    http://www.r4sdhc.com/r4tsdhc.asp

    if not, then this should be your firmware
    Firmware
     
  7. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France

    Yes I am sure...and I tried that firmware a lot of times! But thanks for trying to help me [​IMG]

    NOTE: I will edit the first post, because I think I forgot to say something important.
     
  8. iggloovortex

    Member iggloovortex GBAtemp Advanced Fan

    Joined:
    Nov 20, 2009
    Messages:
    771
    Location:
    Stratford, CT
    Country:
    United States
    well at this point im just throwing out suggestions, but how about formatting your SD?
     
  9. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    I aldready tried :s Today I will try another SD. I hope it works...
     
  10. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    I tried a new micro SD 2GB but it didn't work again!
     
  11. Dter ic

    Member Dter ic ~

    Joined:
    Feb 19, 2009
    Messages:
    1,757
    Country:
    United Kingdom
    im guessing you should use your ds lite from now on, since the cart your using won't work on the ds phat.

    or purchase a new cart, the cheapest is the r4i gold or the acekard 2i
     
  12. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    The problem is that the NdsLite is not mine :x it is my friend's
     
  13. Stropdasje

    Member Stropdasje GBAtemp Regular

    Joined:
    Aug 25, 2009
    Messages:
    157
    Country:
    Netherlands
    I still think it's a contact problem, because if it works on a DS Lite it is should also run on the DS Phat. I think you have the correct working firmware otherwise the DS Lite would also not work. So if it is not a firmware problem, it is not, then it must be something else. Look in the slot of the DS Phat is the connector is clean and no contacts are bent or damaged?

    If not, then your DS Phat might be defective. Do normal DS games run on the DS Phat?

    Did the R4 stop working when you replaced the firmware of were there problems before; I mean irregular crashes, not booting sometimes and things like that indicating that there may have been a problem before.
     
  14. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    I think the conector is clean and not damage because the NDS runs pokemon black and other DS games normally. This R4 never worked on my NDS phat, it always appears the same error "please upgrade the hardware..."

    I don't see what is the problem of my NDS... I tried this R4 in 3 NDS phat, and it didn't work on two of them, however it worked in one; it worked in a DsLite too :S

    --------------
    Thank's for your patience [​IMG] I hope that someone can solve my problem :S
     
  15. mike3003
    OP

    Newcomer mike3003 Newbie

    Joined:
    Mar 16, 2011
    Messages:
    9
    Country:
    France
    Yeah! I finally fixed the problem! I needed to use a new micro SD adapter!

    Finally!! [​IMG]
     

Share This Page