R4i 3DS RTS System shut-down

Discussion in '3DS - Flashcards & Custom Firmwares' started by Benja81, Feb 14, 2017.

  1. Benja81
    OP

    Benja81 GBAtemp Fan

    Member
    466
    220
    Dec 24, 2015
    United States
    Hello,

    I have a N3DS with A9LH, using an R4i 3DS RTS flashcard. The other day I was playing a game on the flashcard and closed my 3DS, when I opened again it would not come back out of sleep mode. I had to hold the power button until it shut down.

    After powering back on I would only get a black screen when booting 3DS, thought something was wrong with A9LH, and upgraded to latest bin file, tried booting over and over, but found it would not boot until I removed the flashcard. After that time it starts up just fine with or without the flashcard plugged in, but when trying to launch the card now, my 3DS goes to a black screen and then instantly powers down. Everything else with my 3DS seems fine, all 3DS games work, just not the card anymore. Anyone seen this before, is my card dead? I tried with and without an sd card plugged into the flashcard, and have tried a different sd card as well.
     
  2. nechigawara

    nechigawara Citizen of Gamindustri

    Member
    1,168
    389
    Oct 14, 2006
    Thailand
    Planeptune
    Can you try loading legit NDS cart?
     
  3. Jayro

    Jayro MediCat USB and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,955
    2,665
    Jul 23, 2012
    United States
    Octo Canyon
    This is why I'm loving all the Bootstrap.nds updates with TWLoader. I get the convenience of playing NDS roms, without the flash cart fuckery.
     
  4. Benja81
    OP

    Benja81 GBAtemp Fan

    Member
    466
    220
    Dec 24, 2015
    United States
    Good idea, after work I'm going to see if I can find one, I know I have a couple lying around somewhere.

    Does this mean I can configure my 3DS to play DS roms now?
     
    Last edited by Benja81, Feb 14, 2017
    Jayro likes this.
  5. Distrance

    Distrance 矢澤にこ

    Member
    1,144
    426
    Nov 23, 2008
    Finland
    You can use TWLoader to play DS roms from your SD card yes, but it's still under development and game compatability is low. Check it out yourself.
     
    Jayro and Benja81 like this.
  6. Benja81
    OP

    Benja81 GBAtemp Fan

    Member
    466
    220
    Dec 24, 2015
    United States
    Thanks!
     
  7. Benja81
    OP

    Benja81 GBAtemp Fan

    Member
    466
    220
    Dec 24, 2015
    United States
    I forgot that I sold all of my game cards last time I sold one of my 3DS on ebay. However, the interesting thing is that I tried TWLoader and a compatible game, Mario 64, and the same thing happens when it tries to load, the 3DS turns off. I also tried with Princess Peach and Tetris, 2 other compatible games. So it seems my 3DS cannot properly enter DS mode?
     
  8. Distrance

    Distrance 矢澤にこ

    Member
    1,144
    426
    Nov 23, 2008
    Finland
    Maybe the first thing on https://3ds.guide/troubleshooting will help you? Honestly I don't know what it refers to with "broken functionality", but if you can't enter DS mode then I'd call that broken. At the very least I doubt you can break it further from your current condition.

    Whoops forget what you may or may not have seen (edited it away). I'm sleepy and got threads confused. The above still applies though .. you might as well give it a go. I'm going to sleep now so hopefully someone else can pitch in if it doesn't help.
     
    Last edited by Distrance, Feb 15, 2017
    Benja81 likes this.
  9. nechigawara

    nechigawara Citizen of Gamindustri

    Member
    1,168
    389
    Oct 14, 2006
    Thailand
    Planeptune
    Look Like TWL Firm (DS mode) broken. Following the Troubleshooting link provide by @Distrance should fix it.
     
    Distrance likes this.
  10. Benja81
    OP

    Benja81 GBAtemp Fan

    Member
    466
    220
    Dec 24, 2015
    United States
    Thank you for the suggestion. When I try to install the CIAs with FBI, I get an error message, invalid argument. So I tried with BBM and it states that the titles already exist. Do I need to delete them first somehow and then install again?

    Edit: Nevermind, I was trying to install to SD instead of NAND, after using FBI to overwrite and install to NAND, DS mode now works again. Thank you!!
     
    Last edited by Benja81, Feb 15, 2017
    Distrance likes this.
  11. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,177
    674
    May 16, 2011
    United States
    Are you using a real old FBI version? The current version of FBI is a lot better and can figure out where to install CIAs by itself.
     
    Last edited by squall14716, Feb 16, 2017 - Reason: Brain typo.
    Benja81 likes this.
  12. Benja81
    OP

    Benja81 GBAtemp Fan

    Member
    466
    220
    Dec 24, 2015
    United States
    You know, I probably do I think its from almost a year ago. I will update it, thanks!