Question Question about SX OS PRO

Discussion in 'Switch - Backup Loaders & Modchips' started by osui818, Sep 27, 2018.

  1. osui818
    OP

    osui818 Member

    Newcomer
    2
    May 14, 2015
    United States
    I just bought a Nintendo switch, firmware 4.1.0, I have SX OS pro. my question is should i stay at 4.1.0 or update to 6.0.0? and is there anyway i can update from 4.1 to 5.1?
     
  2. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    You can use ChoiDujourNX to update your firmware to 5.1 since some users are noting instability with firmware 6.0 and we cannot figure out why. And there is no reason to be on firmware 6.0 since no games, updates, or DLC currently require it outside of online play.
     
  3. superdukester

    superdukester Member

    Newcomer
    1
    Sep 25, 2018
    Canada
    Where's the update files at? I know what people are going to say..."in the usual places". That doesn't help!
    How about giving the exact name of the update file so google has a chance of returning "in the usual places" sites.
     
  4. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    NX-"Insert firmware number here".zip
     
  5. osui818
    OP

    osui818 Member

    Newcomer
    2
    May 14, 2015
    United States
    If i use ChoiDujourNX to update to 5.1, i will still able to use SX OS ?
     
  6. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    I don't see why not. Although you cannot use ChoiDujourNX with SX OS since they do not support (thanks TX). You must another CFW to use ChoiDujourNX.

    EDIT: I should also mention it installs AutoRCM by default to prevent you from booting non-RCM OFW and burning a fuse when you do so. It doesn't matter if you have AutoRCM already installed as it will overwrite it with its own implementation.
     
    Last edited by Draxzelex, Sep 27, 2018
  7. osui818
    OP

    osui818 Member

    Newcomer
    2
    May 14, 2015
    United States
    i havent use the SX OS pro yet, i want to update to 5.1, then i will use SX OS pro.
     
  8. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Then you must use one of the available free and open-source CFWs to load the homebrew application (forgot to mention that as well) as well as download the firmware files from the Internet to install with ChoiDujourNX.
     
  9. superdukester

    superdukester Member

    Newcomer
    1
    Sep 25, 2018
    Canada
    If I am already
    I'm already on 5.1.0. Will downloading and installing nx-6.0.0 let me play all the games that are asking for an update?
     
  10. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    No games, updates, or DLC truly require firmware 6.0; the only reason they are prompting for an update is because of some metadata but the content will load perfectly fine on a 5.1 console. However if you want to remove the update message then you must update to 6.0 (which I still see no reason to update to).
     
  11. superdukester

    superdukester Member

    Newcomer
    1
    Sep 25, 2018
    Canada
    My Switch is super banned (I think that is the correct term) so when it is asking for the update, I can't update and I can't bypass it by pressing "start software"....so what choice do I have then?
     
  12. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    There are several objective disadvantages towards updating to firmware 6.0 such as loss of DevMenu, custom themes, and if you use SX OS certain games/content do not work for some reason so I still see no reason to update since staying on firmware 5.1 is objectively better for CFW.
     
  13. superdukester

    superdukester Member

    Newcomer
    1
    Sep 25, 2018
    Canada
    Not arguing the points you made but it doesn't solve my issue of not being able to play certain games. Eg. Zelda won't launch

    If I'm screwed for time being and have to wait for TX to release something let me know.
     
  14. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Zelda most definitely does not require firmware 6.0 (it works on firmware 1.0 after all). Either you have an update pending or you did not bypass the firmware requirement of one of your games/update/DLC when you installed it.
     
  15. superdukester

    superdukester Member

    Newcomer
    1
    Sep 25, 2018
    Canada
    Everything was working fine a week before Nintendo released 6.0. I didn't play with the switch until recently and noticed the some games that use to work are now asking for an update which I use to be able to bypass. Zelda asking for an update when it was working before is odd.

    I guess I got nothing to lose and will update as soon as I find the update file which shows up xbins but with no download link. As for choidujour, it runs on SX OS 2.0
     
  16. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Its probably asking for a game update, not a system update; the two messages look similar but are not identical.
     
  17. superdukester

    superdukester Member

    Newcomer
    1
    Sep 25, 2018
    Canada
    Yes they are game updates. So what is the fix?
     
  18. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Download and install the game updates. However those are copyrighted so I cannot help you look for those. However, they are likely to be found in the same places where you download your games.
     
  19. magico29

    magico29 GBAtemp Maniac

    Member
    6
    GBAtemp Patron
    magico29 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Aug 2, 2017
    United States
    use hekate to update to 5.1.0 via choidujour and then you can use TX as you wish.
    TX for running backup games and choidujour for system updates without burning fuses,so do not get confuse about that.
     
  20. Maupiti

    Maupiti GBAtemp Regular

    Member
    3
    Sep 16, 2018
    France
    As the others members said, you will need another CFW to run ChoiDujourNX, and your sd card needs to be formated in fat32, as If your switch is new and never updated, you don’t have Exfat support until you install it (via ChoiDujourNX also)
     
Loading...