Question about SuperCard DSTWO +

Discussion in '3DS - Flashcards & Custom Firmwares' started by Jesus94, Nov 22, 2015.

  1. Jesus94
    OP

    Jesus94 Newbie

    Newcomer
    1
    0
    Jul 9, 2008
    Hey everyone i want to buy SuperCard DSTWO +, but i dont know if the flashcard support 3DS games on firmware upper than 9.2.
    Can resolve my question? Thnks:D