PS2 modchip - wired incorrectly? (photos)

Discussion in 'Sony PlayStation 1 & 2' started by Codename PUMA, Jun 12, 2015.

  1. Codename PUMA
    OP

    Codename PUMA Advanced Member

    Newcomer
    1
    May 7, 2014
    Long story short I made a thread last year that a chipped PS2 I bought doesn't play PS1 games (not even legit ones, unless I turn the modchip off), despite pretty much all attempts at activating PS1 mode (double resets, stuff like that). I got a chipped PS1 to compensate but that's being a bit of a jerk lately and I require a SCART cable with it which means I can only play it on one TV which sucks. So I finally got the courage to rip open the PS2 completely and take photos so I can hopefully get it to play PS1 games once and for all.

    The modchip is a Mars II, and it has "M320-L8" on it. I can't find exact photos of the exact same one, nor am I knowledgeable at all that this should look like other Mars photos. I guess I'm wondering if anyone immediately notices something off:

    Full-photo:
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0012.jpg.html
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0013.jpg.html
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0005.jpg.html

    Zoom in of the chip:
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0014.jpg.html
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0016.jpg.html

    Zoom in of top part:
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0011.jpg.html
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0019.jpg.html (this is rotated)

    Zoom in of the left part:
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0009.jpg.html (w/ the chip itself)
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0006.jpg.html

    Zoom in of right part:
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0008.jpg.html

    Zoom in of the top/right thing:
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0010.jpg.html
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0018.jpg.html
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0007.jpg.html

    The back (the top zoom-in, the left set of wires, goes through the board):
    http://s1237.photobucket.com/user/Yeah93/media/Photo-0020.jpg.html


    I'll take more if need be, I don't really have access to a that good a camera though.

    FWIW it plays NTSC, and back up PS2 games perfectly, and I don't need a SCART cable for it to show up in colour.
     
  2. Codename PUMA
    OP

    Codename PUMA Advanced Member

    Newcomer
    1
    May 7, 2014
    Aaaaaaaaaand broke the damn thing. Can't get the controller port ribbon back in on re-assembly. Brilliant.
     
  3. migles

    migles GBAtemp Guru

    Member
    12
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 19, 2013
    China
    Earth-chan
  4. Codename PUMA
    OP

    Codename PUMA Advanced Member

    Newcomer
    1
    May 7, 2014
    I've tried every kind of reset twice/etc method there could possibly be, really. Thanks, though.

    Not that it matters anymore. :( The memory card/controller port is screwed after I had to flat out tape it to the board. The analog light turns on on controllers but it doesn't recognise button presses or memory cards at all. Gonna have a get a new one, looks like.
     
Loading...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice