Problems with browserhax

Discussion in '3DS - Homebrew Development and Emulators' started by Brav0, Nov 21, 2015.

  1. Brav0
    OP

    Brav0 GBAtemp Regular

    Member
    2
    Jun 26, 2014
    Romania
    So, today I decided to install browserhax, but when I opened the browser it started nagging me with: "To use this browser, please update your system in System Settings" So I immedeatly pressed the home button because I know that updating makes the hack unusable. I dont know what to do. Help!
     
  2. Mrrraou

    Mrrraou GBAtemp Advanced Maniac

    Member
    10
    Oct 17, 2015
    France
    Browserhax is dead on 9.9 and newer.
     
  3. daxtsu

    daxtsu GBAtemp Guru

    Member
    13
    Jun 9, 2007
    Antarctica
    If you're on N3DS you can sort of work around it (search around, there's a topic on it, but your results may vary), but if you're on O3DS, you're out of luck. This assumes you didn't update to 9.9 or higher through a retail game card; if you did, you're even more out of luck, Nintendo's intentionally "bricking" the browser through game carts until you update through the system settings, if your browser is old enough. If that happened to you, even an N3DS won't save you.
     
    Last edited by daxtsu, Nov 21, 2015
  4. Brav0
    OP

    Brav0 GBAtemp Regular

    Member
    2
    Jun 26, 2014
    Romania
    I have 9.9.0-20E Old 3ds. Im screwed, right?
     
  5. Mrrraou

    Mrrraou GBAtemp Advanced Maniac

    Member
    10
    Oct 17, 2015
    France
    Yes, you are.
     
  6. Brav0
    OP

    Brav0 GBAtemp Regular

    Member
    2
    Jun 26, 2014
    Romania
    :( Is there any other way to launch homebrew then without any games?
     
  7. daxtsu

    daxtsu GBAtemp Guru

    Member
    13
    Jun 9, 2007
    Antarctica
    If you had themehax/menuhax beforehand, you could just use that, but otherwise, no.
     
  8. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    9
    Nov 19, 2015
    United States
    False. Browserhax is fixed on 10.1, and if you get the update nag on O3DS, you're screwed since there is no work around like the N3DS.
     
  9. daxtsu

    daxtsu GBAtemp Guru

    Member
    13
    Jun 9, 2007
    Antarctica
    What exactly is "false"? Nothing I said is incorrect. 9.9 or higher includes 10.1, and I said if he's on O3DS, he's out of luck.
     
    Ammako and dark_samus3 like this.
  10. Brav0
    OP

    Brav0 GBAtemp Regular

    Member
    2
    Jun 26, 2014
    Romania
    I heard there is a work around, but i dont know what. Its pretty sad that i cant softmod it cuz of me updating a week ago, when i didnt even think of softmodding ._.
     
  11. dpad_5678

    dpad_5678 GBAtemp's Memelord

    Member
    9
    Nov 19, 2015
    United States
    (10.2 I meant) You said that 9.9 fixes it. It doesn't
     
  12. daxtsu

    daxtsu GBAtemp Guru

    Member
    13
    Jun 9, 2007
    Antarctica
    Source: http://3dbrew.org/wiki/Internet_Browser#Forced_system-update

    Source: http://3dbrew.org/wiki/Internet_Browser#v9.9_dummy_web-browser

    So yes, it does. But at any rate, he's on O3DS, so there's not much he can do with browserhax at this point.
     
    Ammako likes this.
  13. Stecker8

    Stecker8 Plug

    Member
    2
    Oct 9, 2015
    Here
    Two weeks ago i use browserhax in my O3DS and it works. Now when i enter in browser i don't see the nag
     
  14. MsMidnight

    MsMidnight part time fe modder

    Member
    6
    Oct 12, 2015
    kys
    hopefully we get a homerew that can deactivate the string if possible
     
  15. Flora Cherry

    Flora Cherry I'm unhappy

    Member
    2
    Mar 2, 2014
    France
    mine too stop work in new 3ds :( 10.1.0.27e
     
  16. Brav0
    OP

    Brav0 GBAtemp Regular

    Member
    2
    Jun 26, 2014
    Romania
    Hopefully.
     
  17. Mnecraft368

    Mnecraft368 GBAtemp Advanced Maniac

    Member
    5
    Aug 8, 2015
    There is no way around it. Every version of 3DS has it patched, If you have a laptop and SmashBros3DS you can dual boot or live usb linux and get smashhax, oot3dshax or ninjhax. They work on latest firmware, themehax works with 10.1 and ironhax for non-latest ironfall.

    — Posts automatically merged - Please don't double post! —

    New 3ds kinda have a work around, google is your friend. Ask your friend for help on how.
     
  18. Flora Cherry

    Flora Cherry I'm unhappy

    Member
    2
    Mar 2, 2014
    France
    nintendo install one new icon game in my 3ds my browser started crashed all time i launch the browserhax
     
  19. Rayan92

    Rayan92 Advanced Member

    Newcomer
    1
    Nov 1, 2015
    Hi guys any new solutions on how to get homebrew for 2DS v9.9 or do I kill myself in despair...also if no solution should I just update my 2ds to latest software or should I still wait? thanks
     
  20. Mnecraft368

    Mnecraft368 GBAtemp Advanced Maniac

    Member
    5
    Aug 8, 2015
    If you have smash on 1.1.2 or less you could use smashhax, or you can use oot3dhax (that needs powersaves) (smashhax needs linux) and ofc you can use ninjhax (no kidding! uses cubic ninja)
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice