Problem with TP link TL-WN321G USB dongle

Discussion in 'NDS - Console and Game Discussions' started by skpuppy, Sep 9, 2010.

Sep 9, 2010
  1. skpuppy

    Newcomer skpuppy Member

    Sep 8, 2010
    United States
    I am really sorry for starting this thread here, but when I try to open new thread in forum made for it (Nintendo Wi-fi) it says that I don't have permission. [​IMG] I tried option for opening threads elsewhere, it works, only there it doesn't, so I'm not really sure what's the problem. I also read forum rules to see if I'm making some mistake, and couldn't find anything, so please excuse me if I'm breaking some forum rule, that really wasn't my intention. I'm only seeking help (and can likewise help people with similar problems as I managed to solve some of this stuff by myself).

    I've recently bought Tp-link TL-WN321G USB dongle ( ) and I've got problems connecting my DS to Nintendo wifi with it, so I'm kindly asking people from gbatemp to help me with this issue. I'll give detailed rundown of this problem so you can easily understand what's happening. Oh btw, I have DS lite.


    My roommate and me have our computers connected over ethernet lan. Both our machines are running Windows Xp Sp2. His computer has internet connection, which he shares with my computer via Internet connection sharing option in Windows xp. He has two network cards, one is connected to cable modem which gives us internet, the other is connected with switch (my and 3rd computer are also connected to this switch). Switch model is:
    As far as I know, this switch doesn't have any firewall/settings, you just plug cables and that's it.

    This is how our network is set up:

    Computer 1 (roommate's computer with internet access)
    It has Internet connection which has ICS turned on for our local network. That card has it's TCP/IP settings to auto.

    2nd network card on that computer (our lan card) uses following settings:
    Subnet Mask:
    Gateway: blank
    DNS: blank

    Computer 2 (my computer)
    lan card set to :

    Computer 3 (irrelevant for this issue, in another room)
    lan card set to:

    So, basically, Computer 1 shares it's internet connection with Computers 2 and 3. Everything is working smoothly, no problems etc.

    I've used this nice guide to connect dongle to my computer:
    I've followed guide to the letter. I use soft AP option, which turns my ICS (internet connection sharing) on, dongle starts to receive signal after 1-2 mins.

    Wireless connection is set up according to this guide, i.e. tcp/ip protocol is:
    gateway: (pointing to my LAN card which is giving internet via ICS)

    DS is configured same as in guide (manually configured ofc in Nintendo wifi settings):

    My problem is that every time I try to connect my Nintendo DS to Nintendo wifi, I get error 52100 while trying to test connection. This problem is only happening with my computer; no matter what settings I use for wireless connection (i.e. changing gateway ip adress, or dns, or ip of wireless connection) it just won't work.
    I'm not using WEP, connection is open. Tried it with Shared and 64 bit WEP, still same error. DS can find access point, but can't connect to Nintendo Wifi.
    As for dongle's settings, it's all set up according to guide - SSID match on both settings and DS; TX rate is 2 mbit etc.

    Wifi works, as my friend tested it with his phone. It's just my DS getting every time that 52100 error.

    Here's list of all the things I tried:

    - Changing wireless connection gateway and dns to following: computer 1 internet connection; computer 1 lan card (; leaving it blank. In all 3 cases dongle manages to get signal.
    - changing WEP from open to shared with 64bit key, still 52100
    - Changing channels, tried 1,6 and 11, all three work and DS can find access point, but cant connect to internet (52100 error)
    - Connecting my computer directly to Computer 1, ignoring the switch (thought it might be switch problem but nope); same error
    - turning firewall and antivirus completely off

    TLDR: When I try to connect my DS to wireless connection on my computer (computer 2) it gives me 52100 error

    Next thing I tried was to connect USB dongle to Computer 1.

    I set everything like in guide.
    Wireless settings:
    gateway: ip of internet connection card (not our lan which is
    dns: ip of internet connection card

    DS settings are same as in previous case.

    With this settings, it works! It only works with these settings - if I put our lan's ip for gateway, it never gets signal. DS tests wifi w/o problems, I also played Mario Kart and it works flawlessly. But the problem is, I can only turn ICS for one connection, either wireless or our lan, can't turn it for both at once (stupid Windows XP). I tried bridging Wireless connection and LAN in windows XP, it makes bridge but my wireless connection never gains signal that way. I tried to turn on compatibility mode for wireless dongle with command " netsh bridge set adapter 1 forcecompatmode=enable " and it lists it as enabled, but still no luck, wireless connection never gains signal while in bridge.

    This way I know that dongle works, and that DS works, but I can't have internet on computers 2 and 3 if I have wireless connection and it's really irritating to switch every moment ICS from wireless to our lan whenever someone needs internet on computers 2 and 3. So that isn't really solution to my problems.

    Sorry for lenghty read, here's also TLDR version:

    On my computer, Nintendo DS gives 52100 error (connected to access point, but cant connect to nintendo wifi) every time
    On my roommates' computer, wifi works, but then I can't have internet over lan for other computers in network, only for newly made wireless connection

    Hope someone has any tips for this problem, I've been banging my head with this problem for two days straight and can't find solution. Thanks in advance, anything will be greatly appriciated!

    Kind regards, sk

Share This Page