Problem with SD2Vita

Discussion in 'PS Vita - Hacking & Homebrew' started by skydancer93, Aug 7, 2017.

  1. skydancer93
    OP

    skydancer93 GBAtemp Regular

    Member
    274
    39
    Mar 16, 2015
    United States
    I have an SD2Vita running Henkaku Enso on a PS Vita phat unit for the past few days with no issues.

    All of the sudden, today, I was playing it with no issues and put it in sleep mode. Woke it up just now to play it and closed out the game I was playing. Then, I started another game only for the bubble to freeze and then after a couple minutes of the light going crazy at the game card slot, it tells me the file is corrupt. I power down the unit and it was frozen at the menu and now it seems like it will not detect the SD card at ALL. When I turn the Vita on, the light goes nuts for a few minutes only for the menu to pop up and all my installed items to be gone. Same with turning it off

    Brand New microSD card and SD2Vita adapter. I hope it's not dead already. I even tried taking it out and resetting it twice. That didn't fix anything. How can I fix this and is this going to be a common thing?
     
  2. DonJav

    DonJav Member

    Newcomer
    33
    5
    Sep 23, 2016
    Does the vita work as normal without the adaptor in? Also it could be that the sd card is corrupt or fake, use H2testw to test it and try a different sd card in the adaptor.
     
    Last edited by DonJav, Aug 7, 2017
  3. skydancer93
    OP

    skydancer93 GBAtemp Regular

    Member
    274
    39
    Mar 16, 2015
    United States
    That I didn't try. The SD is legit as it was bought from Amazon themselves and not a third party seller.

    It's weird but it seems to be working now. ALL I did was take it out, pop the micro SD in my laptop, take it out, and put it back in and so far, everything is back and working. I didn't do anything to the microSD when it was in the laptop but view it's contents.
     
    DonJav likes this.
  4. subcon959

    subcon959 teh retro

    Member
    769
    469
    Dec 24, 2008
    Almost certainly it will be a common thing since it's a home-made device in a portable console that is hardly ever going to be stationary. The contacts are not going to align perfectly and may well shift position with normal use. That's why it started working again after re-inserting.
     
  5. skydancer93
    OP

    skydancer93 GBAtemp Regular

    Member
    274
    39
    Mar 16, 2015
    United States
    I don't think that was it as I took out and reinserted the unit twice and it still didn't work until I put the microSD into the computer and took it out.
     
  6. mccrackey

    mccrackey Newbie

    Newcomer
    3
    0
    Sep 13, 2009
    United States
    This Reddit thread saved mine:

    Now I can at least access MolecularShell, but the ux0: partition still isn't showing, so I don't think it's fixing the root cause. We might have gotten bad cards. I've got another one coming, so I'll let you know if it works.
     
    Last edited by Tom Bombadildo, Sep 26, 2017
  7. SSEpochX

    SSEpochX Newbie

    Newcomer
    8
    0
    Jun 17, 2017
    United States
    I have a similar issue. Happens at random, usually when bring my vita out of sleep and then try to start up a new game a corrupt memory error occurs. I found that by opening the flap on the cartridge slot takes pressure off the SD card slot and allows it to read again. I don't have to restart the system or anything, it just starts reading correctly.

    Kind of pain, its like the sd2vita card needs to slightly shorter.
     
  8. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,551
    666
    Oct 10, 2009
    United States
    I know that if the sd2vita card isn't making a secure connection the vita will freeze on the enso logo. it has to be shimmied in as far as it can go, then u can close the dust jacket.
     
  9. SSEpochX

    SSEpochX Newbie

    Newcomer
    8
    0
    Jun 17, 2017
    United States
    its in as far is it will go, still happens occasionally.
     
  10. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,551
    666
    Oct 10, 2009
    United States
    it might be the plugin. there r some things that need updating, and at first I thought it was vita shell related, but I think it's the plugin actually. one of the problems is mounting the internal memory card or transferring via usb in vita shell. I've not encountered a corrupted memory card error, but I also haven't played much of my vita either. that error could be the plugin itself rather than the card. u can cancel out the plugin by holding L at boot btw.
     
  11. skydancer93
    OP

    skydancer93 GBAtemp Regular

    Member
    274
    39
    Mar 16, 2015
    United States
    I noticed, that why I tell everyone who wants one now to invest in a pair of pointed tweezers.
     
  12. Agent Moose

    Agent Moose GBAtemp Fan

    Member
    324
    80
    Dec 6, 2014
    United States
    This kind of relates to this topic: I just got my SD2Vita working, minus the fact that games are currupted. if I load the official memory card, they run.

    I tried re-copying over the games from the memory card to the sd2vita and it still wouldn't load the game. I think it might be an issue with the official bubble? I can reinstall the games, but then I will loose all my save data, and I don't want that to happen. Anyone know of a way to fix this?