Problem with R4 patch.....help!

Discussion in '3DS - Flashcards & Custom Firmwares' started by meshuggah27, Jul 15, 2015.

  1. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    Hey all,

    =EDIT= It is a Revision 9 card.
    =EDIT= It is actually a revision 6 card (I found one pictured as Rev6 with an ACTEL chip, the Rev9 did not have the ACTEL chip)
    =EDIT= I seem to have made things worse. I tried flashing R4iGold_3DS43_Patch (4.3.0) onto it, and it installed just fine. Now the cart will only work in my DSLite, not my DSi, and the game icon is Rafa Nadal Tennis now. -_-. Also, it will not let me run the R4iGold_NDSi145_Patch now. Comes up Card Check Fail just like the 6.0/6.2 update.

    Having an issue with an R4i 3DS card purchased at r4ids.cn. I cannot for the life of me get the upgrade patch to work. Ive tried on my DSi, and my DSLite with no luck. Every time i go to start the patch, next to Card Check it just says: FAIL. The only thing ive noticed is that my card DOES NOT have the 'RTS' letters on it. That spot is vacant. Everything else is EXACTLY the same. Inside the cart, there is a big square ACTEL chip, and does not have the 'R9 connector' everyone is telling me to cut. But you arent supposed to cut the trace until the 6.2 update, not 6.0.

    http://www.se7ensins.com/forums/thr...nsole-v6-2-0-12-dsi-v1-45-and-ds-lite.983793/

    I was following this guide on how to do it, and got up to the part with the patch and now i am stuck.

    Also just tried loading the .NDS upgrade file from another flash card on my DSLite and then swapped in my R4 card (been hunting around the site for a solution), but still get the Card Check Fail error. I attempted to flash the 6.0 patch and it gave me the same card fail error. The latest patch i am able to install normally is the v1.45 NDSi patch (R4iGold_NDSi145_Patch).

    Any help or suggestions you all can throw my way? Anything would be much appreciated. Thank you!

    If someone could also delete my other thread, that would be much appreciated. Wasnt aware there was a 3DS section aswell.
     

    Attached Files:

    Last edited by meshuggah27, Jul 15, 2015
  2. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    I also forgot to mention im trying to use this on a 2DS console.
     
  3. cocoPika

    cocoPika GBAtemp Regular

    Member
    205
    19
    Dec 2, 2014
    Canada
    why no rts on the card, is that real r4i gold 3ds card?
    When did you get it?
    Have you tried to format your sd card and download the newest kernel again?
     
  4. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    I purchased it about two years ago. As far as i can tell, there is no difference outside of the real time save function.
     
  5. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    What is your console firmware ?
     
  6. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    8.1.0-19U
     
  7. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Then you can setup rxtools and downgrade your whitelist/twl_firm.
     
  8. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    Is there a guide for that somewhere? Would that allow my card to work in my 2DS after?
     
  9. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
  10. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    Im sorry but i cant find any documentation on how to inject the FBI into my sysnand.
     
  11. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Did you see the readme inside the fbi_injection folder?
     
  12. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    I tried what was in the readme, but i cant find an 'Other Options -> Install FBI over Health&Safety App.' only 'Advanced Options' that gives me an option to 'Install FBI'. when i do that i get
    "Opening SecureInfo_A...Error.
    Trying with SecureInfo_B...Error.
    Process Failed!
    Press A to exit.
     
  13. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    Got it booted into FBI, when i try to install the FBI.cia i get
    Install Failed!
    Could not install app.
    Raw Error: 0XC8A0802B
    Module: AM (0X20)
    Level: Status (0Xi9)
    Summary: Invalid State (0X5)
    Description: Database does not exist (0X2B)

    I booted into the emunand, then used the health and safety exploit to load FBI, and thats where i got that error trying to install the FBI.cia
     
  14. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
  15. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    Alright, got the FBI logo on my homescreen. Boot into it, and now when i try installing the 2 cias you mentioned, in either order, i get DESCRIPTION_INVALID_COMBINATION

    =EDIT= FBI logo has dissapeared from my homescreen. On bootup you can see the icon appear for a second, but then dissapears.

    =EDIT= i got the xorpads and injected FBI into my nand and recompliled it, now im sitting here with an 800mb NAND file and no idea how to restore it. THAT i couldnt find any documentation on. I tried through the Gateway method (boot from the browser) but it says my console isnt supported when i go to restore NAND.
     
    Last edited by meshuggah27, Jul 16, 2015
  16. VerseHell

    VerseHell GBAtemp Psycho!

    Member
    3,067
    1,067
    Jun 29, 2014
    France
    Launch rxmode in sysnand and your H&S should still be here, and if you're using FBI, then the destination must be nand. And you also have an option in rxtools to restore your original mset.
     
  17. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    When i launch RXmode in sysnand and boot H&S, FBI loads fine. but when i try to install those CIA's for the whitelist and the firm, they error out with DESCRIPTION_INVALID_COMBINATION
     
  18. meshuggah27
    OP

    meshuggah27 Member

    Newcomer
    16
    0
    Jul 6, 2015
    United States
    Florida
    I can install game CIA's fine, but they wont boot. When i choose them from the title screen they make it to 'Loading' or whatever and then itll reset back into the system menu.