Problem with HIDTest

Discussion in 'Wii U - Hacking & Backup Loaders' started by FreezingIceKirby, Jul 15, 2014.

  1. FreezingIceKirby
    OP

    FreezingIceKirby Advanced Member

    Newcomer
    58
    8
    Jul 15, 2014
    United States
    Trying to switch over to Nintendont, but I don't have a PS3, PS4, or any other sort of controller like that... so, I thought I'd try HIDTest to make my own controller.ini with the few USB controllers I have, as suggested by other topics.

    ...One problem though. For some reason, HIDTest will not work for me. Every time I start it up, this is all I see.


    ==========================
    HIDtest
    Built : Apr 20 2014 00:24:40
    Version : 0.6
    Firmware : 55.22.31

    Failed to open config
    HIDVersion : 40001
    Getting list of HID compatible devices...




    ==========================

    (If I have a controller.ini inside the SD card at the right area, that "Failed to open config" won't show up... but "Getting list of HID compatible devices..." is still the last thing that shows up.)

    (Also, I tried both versions 4 and 6, and both hang at the same spot.)

    According to what I've read on here, there should be numbers and all sorts of things on the screen... but mine hangs for some reason, and I have to hold the power button in for five seconds in order to get out of it. Not only that, it also seems to mess up the Homebrew channel, and I'll have to delete the Homebrew save file in order to get back into it.

    (Also, this happens regardless if I have any sort of USB controller plugged in or not.)

    I tried doing a bit of research on this first before creating an account asking for help, but apparently nobody's encountered or mentioned having this problem (except for one other person, but their inquiry about it went ignored). I could've sworn I followed the instructions carefully... am I doing something wrong here for this thing to freeze up like this? I have the most recent homebrew channel (1.1.12, or whatever it is), and I tried it on both a Wii and a Wii U... but received the same results.

    Any help will be appreciated... and apologies if the solution is somehow staring at me straight in the face and I'm just not seeing it. :unsure:


    (And in case it's important, I tried using a USB Hammerhead FX controller and a Gamecube-to-USB... plugged in or not, HIDtest still freezes.)
     
  2. lettuce

    lettuce GBAtemp Advanced Fan

    Member
    667
    9
    Jul 27, 2006
    I have this issue too, did you very get it working?
     
  3. FreezingIceKirby
    OP

    FreezingIceKirby Advanced Member

    Newcomer
    58
    8
    Jul 15, 2014
    United States
    I did after a while. Turns out, the program is kinda built badly, and if you don't have a HID-compatible controller plugged in, it just hangs without any option of getting out of it and you're forced to hold in the power button for five seconds (or on the Wii U, you have to unplug it).

    Basically, activate HIDTest, let it boot up, then plug in your controller. If it advances and shows you the appropriate numbers and stuff, then your controller will work. If it still hangs at "Getting List of HID Compatible Devices...", then that means your controller won't work and there's nothing you can do (except hold the power button in/unplug the console).

    (Also, sometimes the controller works and doesn't work, depending on which USB port you're using. Not sure why that is though...)

    Hope this helps.
     
  4. lettuce

    lettuce GBAtemp Advanced Fan

    Member
    667
    9
    Jul 27, 2006
    Well this is odd, as my GioTeck GC2 Wireless pad, has worked with Nintendont in the past. But at the moment im having trouble getting it to sync. I thought i would give HIDTest a go to create its own config but it just seems to lock HIDTest all the time.

    What controller.ini file is supposed to be used with HIDTest?