RELEASE pPlay: switch video player

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by cpasjuste, Dec 14, 2018.

  1. anhsamac

    anhsamac Newbie

    Newcomer
    2
    Jan 3, 2019
    Australia
    Any chance for playing video HEVC (High Effciency Video Coding) or video 10bit ? Next release maybe?
     
  2. cpasjuste
    OP

    cpasjuste GBAtemp Advanced Fan

    Member
    12
    Aug 27, 2015
    France
    It works, already. 1080p will be too slow thought, but some 720p will work fine.
     
    anhsamac and lordelan like this.
  3. slovenhjelm

    slovenhjelm Newbie

    Newcomer
    2
    Jun 5, 2018
    Sweden
    hey guys, i have an issue.

    for some reason PPlay freezes when i try to open a folder with certain movies in it. i havent been able to pinpoint exactly what type of file causes this as the offenders have been of varying different size and file type. i really cant figure this out.

    i am on 5.1, using the latest atmosphere build and am running pplay 2.0.
     
  4. Light9384

    Light9384 Member

    Newcomer
    1
    Mar 19, 2018
    United States
    hey, I have a question. Can it run videos of the external hard drive ? Or only from the sd card ?
     
  5. SvenDeadlySin

    SvenDeadlySin Member

    Newcomer
    2
    Apr 27, 2019
    United States
    Oklahoma
    Any chance it’ll be updated to work with 8.0.0? It currently lags the videos. Any format I’ve tried, with ram access.
     
  6. han xin

    han xin Newbie

    Newcomer
    4
    Dec 13, 2015
    can you add smb support


    Sent from my iPhone using Tapatalk
     
  7. cyrilz87

    cyrilz87 Newbie

    Newcomer
    2
    Apr 28, 2019
    Singapore
    I'm able to setup own ftp server from internet browser but unable to do it here. I'm also followed and edited the way according to readme.md
    • NETWORK = "ftp://user:Password@ip:Port/
    Now just jammed at Network section What possibly go wrong here?
     
    Last edited by cyrilz87, Apr 29, 2019
  8. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Not yet.
     
  9. Csmrcc

    Csmrcc GBAtemp Fan

    Member
    4
    Sep 13, 2018
    Spain
    fw 8.0.0 AMS 0.8.9 pplay 2.0
    and i have no lags on video, maybe it depends on the video format etc?
     
  10. ole

    ole Advanced Member

    Newcomer
    2
    Apr 12, 2015
    Norway
    Any recommendation on the which format to use ? If someone have an Handbrake preset would be great.
     
  11. Csmrcc

    Csmrcc GBAtemp Fan

    Member
    4
    Sep 13, 2018
    Spain
    for me all kinds of format works, i didnt have any problem yet
     
  12. Andrezin0692

    Andrezin0692 Member

    Newcomer
    3
    Jun 13, 2014
    Brazil
    Ilha Solteira
    Ive been having ftp issues, i use coreftp on my wondows pc and it works great to transfer files edit and delete, using sysftp or just nxshell. But when using pplay it just shows the (..) at the top, and cant browse any files, when i click network it makes two sounds as if it was connecting then instantly disconnecting... Any light on this? Do i have to set the ftp server differently then just file xfering? Running kosmos with 7.0.1 atmos 8.9, accessing pplay with full ram and with the ftp config edited
     
  13. ole

    ole Advanced Member

    Newcomer
    2
    Apr 12, 2015
    Norway
    No difference in battery usage?

    mk4 vs mkv..
     
    Last edited by ole, May 1, 2019
  14. cyrilz87

    cyrilz87 Newbie

    Newcomer
    2
    Apr 28, 2019
    Singapore
    Will pplay’s network access Nintendo server?
     
  15. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    lol no
     
    Naked_Snake likes this.
  16. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    pPlay won't contact nintendo's servers, but to be clear, you need to use something like 90dns if you're connecting to wifi and don't want your Switch talking to Nintendo and getting you banned.
     
  17. ole

    ole Advanced Member

    Newcomer
    2
    Apr 12, 2015
    Norway
    Hmm, I’m running reinix on 7 firmware.

    Got cpu boost enabled and running pplay so it have full ram access ( through using an nsp homebrew launcher )

    My files are converted using handbrake 720p android preset to mp4 file.

    My issues is that every 33 minutes the video begins to stutter heavily and I have to exit and restart pplay.

    Anyone having the same issues? Could I assist im debugging it?
     
  18. Sethtimus Prime

    Sethtimus Prime GBAtemp Regular

    Member
    2
    Nov 16, 2012
    United States
    Can you start where you left off and go for another 33 minutes before it does it again?
     
  19. ole

    ole Advanced Member

    Newcomer
    2
    Apr 12, 2015
    Norway
    Yes
     
  20. SvenDeadlySin

    SvenDeadlySin Member

    Newcomer
    2
    Apr 27, 2019
    United States
    Oklahoma
    Will HVEC 1080P be possible ever?

    — Posts automatically merged - Please don't double post! —
     
  21. nifoc2099

    nifoc2099 Member

    Newcomer
    2
    Dec 13, 2018
    Singapore
    Not yet. I have to re-encode all my hvec 1080p vids in order for them to work on Pplay. Tone Down some features especially Video frame rate & bitrates
     
Loading...