Please help with HBL on 5.0.0

Discussion in 'Wii U - Hacking & Backup Loaders' started by dbkdbk2, Apr 24, 2016.

  1. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    Hi,

    I'm having trouble starting up HBL on my WiiU (5.0.0 U).

    I have tried using the following link: http://wj44.ml/osdriver/payload500.html.

    It takes me to a black screen and asks me to press "A" or "B" (original exploit or modified, respectively). Regardless of which button I press, it opens up Internet Browser again and takes me to: http://wiiubru.com/payload500.html. All I see then is a frame that says "Not Found
    The requested URL /frame.html was not found on this server.".
    (Whoops, that was because of my cache I think.)

    I think I read somewhere that wiiubru will no longer host the files for versions below 5.5.0. I tried hosting the files myself (http://wiiuserv.5gbfree.com/), but I just get the "Not Found" frame again.

    Can someone help?
     
    Last edited by dbkdbk2, Apr 24, 2016
    KiiWii likes this.


  2. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,817
    1,339
    Nov 17, 2008
    United Kingdom
    Never mind.....

    Edit: try using the 1.2 rc1 HBL www files in dimoks GitHub.
     
    Last edited by KiiWii, Apr 24, 2016
  3. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    That's the one I've been trying

    Edit:

    I think I might just be missing some fundamental step. Here is what I've done so far:

    Seen that I have 5.0.0 U.
    Blocked nintendo's update servers.
    TubeHAX.
    Used Internet Browser to navigate to http://wj44.ml/osdriver/payload500.html.
    I've tried Pressing A. I've also tried Pressing B.
    Internet Browser restarts and takes me to http://wiiubru.com/payload500.html.
    I get the "Not Found" error (you can navigate to http://wiiubru.com/payload500.html and see the error too).
    Am I missing anything? I have the HBL files in SD:/wiiu/apps/.
     
    Last edited by dbkdbk2, Apr 24, 2016
  4. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,817
    1,339
    Nov 17, 2008
    United Kingdom
    Hmmm I use his for 5.3.2..

    Tryd the one from @pwsincd s web site?
     
  5. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    That's wiiubru.com, right? Doesn't work...
     
  6. andriy921

    andriy921 GBAtemp Regular

    Member
    267
    97
    Dec 1, 2015
    First - you don't need to run kernel exploit. Just run hbl's payload directly.
    Second - it seems like that host is missing frame.html file. Try hosting package locally.

    — Posts automatically merged - Please don't double post! —

    Oh well. It seems like @dimok didn't include that file. That's probably the reason why it was not included on that file. Try to contact side owner to fix that. Locally you can use any frame.html that was already included with any other package.
     
    KiiWii likes this.
  7. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    I can't seem to find any frame.html file in the other HBL uploads on dimoks' github. Could you link me to one please?
     
  8. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,817
    1,339
    Nov 17, 2008
    United Kingdom
    No need for frame.html, just index.html.

    I havent had frame.html ever since self hosting.
     
  9. pwsincd

    pwsincd Garage Flower

    Member
    3,337
    1,732
    Dec 4, 2011
    Manchester UK
    your saying that wj44 's site redirects to mine ????

    the frame your seeing maybe is something from wj44's site .. i dunno i havent hosted or had a frame.html file from any of dimok's releases... just try www.wiiubru.com directly..
    also your cache maybe in need of a clear... wiiubru.com hosting dimoks HBL RC v1.2 should load the HBL channel with one visit..

    i think the frame.html comes from a link within the osdriver payload file .. for an iframe...
     
    Last edited by pwsincd, Apr 24, 2016
    KiiWii likes this.
  10. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,817
    1,339
    Nov 17, 2008
    United Kingdom
  11. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    Sorry, the redirect to your site might have been an issue with my cache.

    — Posts automatically merged - Please don't double post! —

    I've cleared my cache. Going to "wiiubru.com" redirects me to "wiiubru.com/payload500.html". All I see the is

    "Not Found

    The requested URL /frame.html was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

    Going to try using my android to host the files that KiiWii just linked to
     
    KiiWii likes this.
  12. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,817
    1,339
    Nov 17, 2008
    United Kingdom
    Im currently playing Star Fox Zero with that self host set up. 10 min wait to play is agony, but its worth the wait!
     
  13. andriy921

    andriy921 GBAtemp Regular

    Member
    267
    97
    Dec 1, 2015
    frame.html - is a file, required by any payload for firmwares < 5.3.2. It never changes. Just download definitive package, grab that file from kexploit folder and put to your hbl payload.
     
    pwsincd likes this.
  14. pwsincd

    pwsincd Garage Flower

    Member
    3,337
    1,732
    Dec 4, 2011
    Manchester UK
    ok i have added the frame.html from an old osdriver kernel exploit folder , give it another go now.. ill check what this file is for..
     
  15. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    This. Thank you very much.

    Edit:

    It worked once I added frame.html to my own server, so it should probably work on yours too. I'll test once I'm done copying files onto my SD card.
     
    Last edited by dbkdbk2, Apr 24, 2016
  16. andriy921

    andriy921 GBAtemp Regular

    Member
    267
    97
    Dec 1, 2015
    So you're the owner of this hosting?
    frame.html is part of webkit exploit and required by any payload for firmwares < 5.3.2. Dimok just forgot about this because he uses 5.3.2. This file is static, it never changes and libwiiu's framework automatically generates it for you when you convert payload.bin to payload.html. Dimok already knows about the issue and will include that file in next release.
     
  17. pwsincd

    pwsincd Garage Flower

    Member
    3,337
    1,732
    Dec 4, 2011
    Manchester UK
    Yes i am , i did really remove support for <5.5.x firmwares as i could not verify the files myself... however i just added dimoks HBL as it was simple enough to do so..with a modified index to redirect for 5.5.x and PC users.. and avoid situations like this , cheers for the heads up on that file..
     
  18. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    Uh, rather than create a new thread... so I'm trying to use Loadiine GX2 to launch Bayonetta, but I'm not sure if I'm doing things right.

    I ran the exploit using wj44.ml's site. I then used wiiubru.com to launch HBL. Through HBL, I opened up Loadiine GX2. I can see the Bayonetta icon. Once I try to run the game however, I just get a black screen, with one green pixel on the right side of the screen. Does the game just take a long time to load? Or am I doing something wrong?
     
  19. andriy921

    andriy921 GBAtemp Regular

    Member
    267
    97
    Dec 1, 2015
    I know nothing about game compatibility, but please stop running other exploits before hbl.
    HBL already includes kernel exploit, which is more stable and doesn't need browser restart. So please, please go directly to wiiubru.com.
     
  20. dbkdbk2
    OP

    dbkdbk2 Member

    Newcomer
    26
    2
    Apr 24, 2016
    United States
    Oh, I didn't know that.

    So, first thing I do is open up Internet Browser. Then go to wiiubru.com. Then HBL opens up.

    Through HBL I launch Loadiine GX2. Then I double tap the Bayonetta icon.

    But then I just get a black screen (and green pixel).

    Loadiine GX2's launch mode is set to MiiMaker. But I haven't opened MiiMaker myself. Do I need to open MiiMaker?

    I think that Loadiine GX2 automatically tries to launch the game without requiring the user to manually open MiiMaker?