old 3ds 10.5 homebrew not working

Discussion in '3DS - Homebrew Development and Emulators' started by omegazeroINFI, Feb 5, 2016.

  1. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    ---------
    EDIT:
    i need to really clarify this now.

    i really dont think the problem itself is the exploit.

    at one point, i got a bit further in browserhax than i did in my video and it gave me the same red screen as oothax.
    the problem im having is that the menu itself wont come up and the system crashed.

    if i ran oothax on another old 3ds at 10.5, im positive it would work.
    ----------
    ever since 10.3, ive been having issues opening the home brew menu on my capture 3ds.

    browserhax doesnt run properly on it and oothax while it gets to the loading process (back in 10.3, it kept booting back to the 3ds home screen), keeps crashing. is there some sort of backlog limit in system memory or something?

    id like to change my custom themes
     
    Last edited by omegazeroINFI, Feb 6, 2016
  2. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    Browserhax can be made to work on 10.5 -- I had been struggling with the issue myself (I thought I was doomed!), but I came across a post on Yellows8's Github, where Yellows8 and another user (Goodlookinguy) figured out that adding garbage alphanumeric values at the end of the browserhax address can make it work.

    So type something like -- http://yls8.mtheall.com/3dsbrowserhax_auto.php?asdfgbhnjmklijuytresxdcv -- and see what happens. You'll need to remember to add that question mark (the one after the .php), as it's basically a dummy "get query". They're still not entirely sure why that works, but Goodlookinguy suggests something to do with script caching.

    I gave it a try, and can confirm it works.

    Good luck!
     
    Last edited by theodora, Feb 5, 2016
    Arubaro likes this.
  3. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    i get a script terminated error even with that. it seems to stop at the script part before getting any further since it boots me back to the home screen
     
  4. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    Did you try clearing your save data first? When I tried it, I did that, and then -- once past the setup screens -- quickly pressed URL to input the browserhax address.

    You might need to be patient with it. I know it's not as stable as some, but -- keep at it!
     
  5. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    clearing save data? exactly what will that do the digital games i bought? and where would i do that? (also, the earlier method wiped out my 3ds custom theme, so its themeless now :/)
     
  6. N64

    N64 GBAtemp Fan

    Member
    426
    144
    Apr 16, 2014
    United States
    initializing save data of your browser only deletes existing bookmarks and anything in the cache... so it won't affect your games.

    its in browser settings (click the wrench) at the very bottom
     
  7. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    It's just the browser save data you need to clear. Check the browser settings -- there's a button at the bottom for this purpose.

    This will have no effect on your digital games or anything else. It's like clearing your cache on your PC browser.
     
  8. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    the error still persists, only now instead of booting me to the home menu, i get a black screen

    An error has occured.
    Hold down the POWER Button to
    turn off the power, then turn it on
    and try again.
    for help, blah
     
  9. N64

    N64 GBAtemp Fan

    Member
    426
    144
    Apr 16, 2014
    United States
    you likely have themehax installed. remove your sd card, power on your 3DS, put in the sd card, and change your theme. that will stop the error from occurring.
    then you can try browserhax again
     
  10. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    I can only cite from my own experience, I'm afraid. :/ Sorry to hear it's not working for you.

    Reboot, clear your browser save data again, and give it one more go. There has to be someway of getting it to work for you.
     
  11. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    ive never used themehax/menuhax before. on this 3ds, up until the issues ive been having on 10.3, ive only used ocarina of time hax.

    the black screen message i mentioned showed up after the browserhax only now, im feeling like a complete retard after realizing my sd card was never put back in the system.

    browserhax seems to be theoretically working as its now giving me the same issue oothax was giving me. im stuck at a red screen on the lower screen.
    whats stopping the homebrew menu from booting?
     
  12. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    We've all been there at some point -- that one thing that should have been obvious, right? :D

    As far as the red screen goes, I'm not sure. Yellows8 wrote a thing about the color codes, but I think I may have to defer to one of the other members for an explanation.

    Have you updated your payload? It's the only other thing I can think of.
     
  13. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    in terms of browserhax, im new to it for the mostpart, so im not sure.
    in terms of oothax, yes, i had it working on the new one, erased and redownloaded the new one for the old.
    heres a video of what happens.

    https://www.dropbox.com/s/u8zal29pm3lbz3b/path (14).mp4?dl=0
    this file shows just how far i get trying to load the homebrew menu.
     
  14. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    I can only advise on browserhax, I'm afraid. I don't have oothax (my old entry point was Ironhax).

    Are you using Smealum's starter pack? Maybe try redownloading (from his github) and add it to your SD card again?

    I'm sorry to hear you're having difficulty, though. Here's hoping you'll be able to get it working.
     
  15. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
  16. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    There's a button a little further below the history and cookies buttons -- keep scrolling past the network information and the proxy settings, and you'll find another button reading, "clear all save data". Use that instead.

    Basically, you need to clear your cache -- not just history and cookies -- because the cache stores downloaded pages, images, scripts, etc, for easier loading next time around. It also clears bookmarks, and I would imagine, your network settings, and search engine.

    Give it a shot and report back. :)
     
  17. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    same result as before.
     
  18. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    Give me a few minutes. :) I've taken some video using my mobile, and hopefully, I can show you my process when it's uploaded.

    EDIT: https://www.dropbox.com/s/1mk32ws1g9t7fir/20160205_234747.mp4?dl=0

    Okay, so -- the video above might be a touch blurry (sorry >.>; ), but this shows the process I use to reproduce the ability to access homebrew from the browser.

    1) Enter browser, touch the wee spanner, scroll down to "clear all save data", and OK it. It'll exit out to your home menu when finished.

    2) Re-enter browser. Go through the setup screens, and then as soon as you can, hit URL.

    3) Type in the browserhax address -- http://yls8.mtheall.com/3dsbrowserhax_auto.php and add a "?" after ".php" and then a string of random letters and numbers. E.g., http://yls8.mtheall.com/3dsbrowserhax_auto.php?asdrsrdbvsxfhvb

    4) Hit confirm.

    5) Be patient and wait. Hopefully, homebrew should load, as it does in my video.

    Here's hoping that with video and clarification (perhaps I maybe wasn't clear earlier?), this might work. <3
     
    Last edited by theodora, Feb 6, 2016
  19. omegazeroINFI
    OP

    omegazeroINFI Advanced Member

    Newcomer
    69
    7
    Aug 17, 2015
    United States
    i need to really clarify this now.

    i really dont think the problem itself is the exploit.

    at one point, i got a bit further in browserhax than i did in my video and it gave me the same red screen as oothax.
    the problem im having is that the menu itself wont come up and the system crashed.

    if i ran oothax on another old 3ds at 10.5, im positive it would work.
     
    Last edited by omegazeroINFI, Feb 6, 2016
  20. theodora

    theodora Member

    Newcomer
    26
    6
    Feb 5, 2016
    *Nod* According to the thing Yellows8 wrote on the colour coding, the red screen is the start of the "read file and dump to SD card" ropbin chain.
    It sounds like something is getting stuck, but I'm not sure what. Maybe it's your SD card? Or your network connection?

    Other than that, I'm not entirely sure, and I may have to defer to other forum members for an answer on this, if anybody can help, please?
     
    Last edited by theodora, Feb 6, 2016