Nintendont doesn't recognize my USB drive

Discussion in 'Wii U - Hacking & Backup Loaders' started by dooceswild, Mar 3, 2017.

  1. dooceswild
    OP

    dooceswild Advanced Member

    Newcomer
    73
    5
    Feb 19, 2017
    United States
    California
    I have tried numerous formats for naming conventions.

    I currently have a games folder on my hard drive. I have a few sample games on there, of which I've done the following combinations:

    USB:/games/name of game[game id]/game.iso
    USB:/games/name of game[game id]/[gameID].iso
    USB:/games/gameID.iso
    USB:/games/game id/game.iso

    When I launch Nintendont, I can select SD or USB. When I select USB, it says there is no FAT drive or no games folder and then restarts the Wii.

    My drive is USB 2.0 powered with a Y cable, plugged into the top slot in the back. Wii games launch fine from USB Loader GX.

    At this point, the partition is not hidden with uStealth, although after I get this working, I will be hiding it. Any ideas what I need to do differently?
     
  2. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,552
    666
    Oct 10, 2009
    United States
    tried an sd card? which ports is ur drive plugged into?
     
  3. dooceswild
    OP

    dooceswild Advanced Member

    Newcomer
    73
    5
    Feb 19, 2017
    United States
    California
    I haven't loaded a game onto the SD card yet to test. I'll try that next. The USB is plugged into the top port of the WiiU on the back.
     
  4. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,552
    666
    Oct 10, 2009
    United States
    I don't know if it can read a y cable. I have mine plugged in with one cable since it's powered. the reason I say that is nintendont doesn't like two drives plugged in at the same time. it should give u a region error though. do u have a powered drive or a flash drive?
     
  5. dooceswild
    OP

    dooceswild Advanced Member

    Newcomer
    73
    5
    Feb 19, 2017
    United States
    California
    Hmm. I do have an 8GB, but I was hoping to be able to always leave my drive plugged in so I can keep my library of Wii Games. I'll try and self-power it and see if that fixes the issue. It seems odd that Nintendont can't see it but USBLoader GX sees it just fine this way, no?
     
  6. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,552
    666
    Oct 10, 2009
    United States
    I don't know y the error exists. the way I have it setup is gamecube games on my sd card, wii games on a powered drive, and wii u using the two front usb ports and is unpowered. never had a problem with that setup. u don't have to unplug anything. oh, yeah, the wii drive is stealthed too. nintendont doesn't like two usb drives plugged in which might be y it can't see ur drive, but I don't know for sure which is y u should check another drive or sd card.
     
  7. dooceswild
    OP

    dooceswild Advanced Member

    Newcomer
    73
    5
    Feb 19, 2017
    United States
    California
    I tried something different. I updated Nintendont (Apparently I had a very old version somehow), and I powered the USB drive with external power rather than a Y cable. It still said no USB device.
    I then put a game on an 8gb flash drive and it worked fine.

    My 750GB drive is FAT32, formatted using the exact same utility as the 8gb drive. I'm not sure what else could be wrong.
     
  8. godreborn

    godreborn GBAtemp Psycho!

    Member
    3,552
    666
    Oct 10, 2009
    United States
    my guess is that it's the y cable. I don't know if nintendont works with a y cable.
     
  9. dooceswild
    OP

    dooceswild Advanced Member

    Newcomer
    73
    5
    Feb 19, 2017
    United States
    California
    No Y cable on the last try. I powered it independently. It's got a little power plug I can use instead.
     
  10. tbb043

    tbb043 Member

    Member
    1,044
    461
    Jan 30, 2008
    United States
    Y cable vs external power shouldn't make a difference, only one branch of the Y carries data, so only it should be noticed by the system as a drive. The other one is for power only.


    Dumb question... is your drive formatted to FAT? If not, reformat it. You may need to download a 3rd party formatter since for some reason Windows is a bitch about formatting drives to FAT over a certain size.

    Is there a Nintendon't plugin for that loader? if so try using that. I've had good luck with the one for CFG loader (the wii loader I use). The nintendon't loader isn't really needed on it's own if you have a Wii loader to use.
     
  11. pedro702

    pedro702 GBAtemp Guru

    Member
    6,620
    2,121
    Mar 3, 2014
    Portugal
    you sure your hdd is fat32 formated without hidden partitions or something?

    also the correct path to nintendont games is
    usb:games/anyname/game.iso

    try starting nintendont directly instead of being through usbloader gx.
     
  12. dooceswild
    OP

    dooceswild Advanced Member

    Newcomer
    73
    5
    Feb 19, 2017
    United States
    California
    I'm sorry to those that replied, life got in the way. The drive is hidden, so I don't get the nag screen on startup. It is for sure FAT32. I'll check the path and make sure it's correct. Does it have to have the game ID in it, or can it just be /games/Basketball Game/game.iso?
     
  13. pedro702

    pedro702 GBAtemp Guru

    Member
    6,620
    2,121
    Mar 3, 2014
    Portugal
    to be used in nintendont yeah it doesnt need the id, to be seen on usbloadergx it probably needs gameid but also im not sure if nintendont still has a working hidden drive thing with all the changes tbh.

    also make sure you dont have hidden extensions so the game doesnt end up being called game.iso.iso