Hacking Nintendo Switch Jailbreak support

Xpresive

Active Member
OP
Newcomer
Joined
Jan 29, 2018
Messages
33
Trophies
0
Age
32
XP
167
Country
Zimbabwe
Hello everyone!

All the discussion internet are very confusing. I'm buying used Nintendo Switch console, it says that it's year old so I will check out if the console version is Jailbreakable (serial n0), but how about OS updates? Which OS is still Jailbreakable and from which OS jailbreak cannot be done anymore? Thanks for answers!
 

mav2010

Well-Known Member
Member
Joined
May 29, 2018
Messages
100
Trophies
0
Age
41
XP
891
Country
Germany
If it is one of the original Switch consoles that are vulnerable to fusee gelee, it doesn’t matter. It will always be exploitable.

If the console is one of the newer ipatched models, it needs to be on firmware 4.1.0 to be exploitable.

Try to find one of the first kind. They are much easier to hack and will be forever.
 
  • Like
Reactions: EmulateLife

Xpresive

Active Member
OP
Newcomer
Joined
Jan 29, 2018
Messages
33
Trophies
0
Age
32
XP
167
Country
Zimbabwe
If it is one of the original Switch consoles that are vulnerable to fusee gelee, it doesn’t matter. It will always be exploitable.

If the console is one of the newer ipatched models, it needs to be on firmware 4.1.0 to be exploitable.

Try to find one of the first kind. They are much easier to hack and will be forever.

Thanks for fast reply! I will try to find the older model, which is before June 2018? ( Look at https://gbatemp.net/threads/switch-...he-first-post-before-asking-questions.481215/ ? )
"it needs to be on firmware 4.1.0 to be exploitable." So if console if later than June 2018 and not Switch v2, it can still be exploited if it's not 4.1.0 and later? Do people often update their switch?

--------------------- MERGED ---------------------------

Thanks for fast reply! I will try to find the older model, which is before June 2018? ( Look at https://gbatemp.net/threads/switch-...he-first-post-before-asking-questions.481215/ ? )
"it needs to be on firmware 4.1.0 to be exploitable." So if console if later than June 2018 and not Switch v2, it can still be exploited if it's not 4.1.0 and later? Do people often update their switch?
or when i'm buying from person, just type serial to the "https://ismyswitchpatched.com/".
 

mav2010

Well-Known Member
Member
Joined
May 29, 2018
Messages
100
Trophies
0
Age
41
XP
891
Country
Germany
Ideally try to get the serial number and then compare with the common lists whether it is patched or not:
https://nh-server.github.io/switch-guide/user_guide/getting_started/#serial-list

Theoretically ALL Switches are vulnerable to the newer Deja Vu exploit. BUT it is at the moment only published for firmwares up to 4.1.0. And the chance of bricking is much higher with this exploit.

If you want to play online, you have to keep the firmware on latest version and Nintendo is also pretty aggressive at pushing new versions. So for a normal user it is very likely, that the firmware will be up to date.
 

Xpresive

Active Member
OP
Newcomer
Joined
Jan 29, 2018
Messages
33
Trophies
0
Age
32
XP
167
Country
Zimbabwe
Ideally try to get the serial number and then compare with the common lists whether it is patched or not:
https://nh-server.github.io/switch-guide/user_guide/getting_started/#serial-list

Theoretically ALL Switches are vulnerable to the newer Deja Vu exploit. BUT it is at the moment only published for firmwares up to 4.1.0. And the chance of bricking is much higher with this exploit.

If you want to play online, you have to keep the firmware on latest version and Nintendo is also pretty aggressive at pushing new versions. So for a normal user it is very likely, that the firmware will be up to date.
Awesome! So if a serial code matches that it's old one and that whetever that switch OS is updated to, it will always be hackable? Maybe I will be lucky
 

EmulateLife

Well-Known Member
Member
Joined
May 30, 2016
Messages
3,981
Trophies
0
Age
41
XP
1,870
Country
United States
Yes I'd say it would be more difficult to find a Switch on 4.1 firmware or before than finding an unpatched (pre-June 2018) Switch.
 

Xpresive

Active Member
OP
Newcomer
Joined
Jan 29, 2018
Messages
33
Trophies
0
Age
32
XP
167
Country
Zimbabwe
Yes I'd say it would be more difficult to find a Switch on 4.1 firmware or before than finding an unpatched (pre-June 2018) Switch.
What's other jailbreak options for June 2018 - 2019 Jan models? Or they all same till new Switch?
 

EmulateLife

Well-Known Member
Member
Joined
May 30, 2016
Messages
3,981
Trophies
0
Age
41
XP
1,870
Country
United States
Dude we've already explained this to you. If there were any other exploits we would have already told you.

Unpatched Switch - can be hacked, any firmware
Patched Switch - can be hacked if on 4.1 or lower

That's it, there is no other hacks right now.
 

Xpresive

Active Member
OP
Newcomer
Joined
Jan 29, 2018
Messages
33
Trophies
0
Age
32
XP
167
Country
Zimbabwe
Dude we've already explained this to you. If there were any other exploits we would have already told you.

Unpatched Switch - can be hacked, any firmware
Patched Switch - can be hacked if on 4.1 or lower

That's it, there is no other hacks right now.
"Deja-vu currently only has implementations available from firmwares 1.0.0 - 3.0.0 and 4.0.1 - 4.1.0, however the exploit theoretically works up to firmware 7.0.1 (the exploit was patched in firmware 8.0.0) and support for these higher firmwares should be added in the future. The current deja-vu implementations are Nereba for firmware 1.0.0, and Caffeine for firmwares 2.0.0-3.0.0 and 4.0.1 - 4.1.0."
 

Ericthegreat

Not New Member
Member
Joined
Nov 8, 2008
Messages
3,436
Trophies
2
Location
Vana'diel
XP
3,898
Country
United States
Hello everyone!

All the discussion internet are very confusing. I'm buying used Nintendo Switch console, it says that it's year old so I will check out if the console version is Jailbreakable (serial n0), but how about OS updates? Which OS is still Jailbreakable and from which OS jailbreak cannot be done anymore? Thanks for answers!
Supposedly a new hack will come out for newer switches, but I would not believe it is real until you see it, it will most likely cost money.
 

EmulateLife

Well-Known Member
Member
Joined
May 30, 2016
Messages
3,981
Trophies
0
Age
41
XP
1,870
Country
United States
SMH, that means it could implement 7.0.1 one day, but can't implement 8.0+ at all because of changes Nintendo made. What I said still stands.

You wanted to know what hacks are available right now and we told you. Who knows when it will implement 7.0.1 it's been months and it's still 4.1 or lower right now.
 
Last edited by EmulateLife,

labib

New Member
Newbie
Joined
Apr 4, 2020
Messages
1
Trophies
0
Age
19
XP
24
Country
Bangladesh
I am also buying a new nintendo switch,but most of them that are v2 of the switch. So, is the new nintendo switch hackable or not?
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
  • K3N1 @ K3N1:
    Samsung UI is probably a ram hog as it is
  • RedColoredStars @ RedColoredStars:
    Yeah. Could be a number of things. My old ass phone has a custom rom on it too so a lot of the bloat is gone, and its not using the moto UI
  • M4x1mumReZ @ M4x1mumReZ:
    @K3N1, I'm using an XCover 5
  • FAST6191 @ FAST6191:
    re youtube on phones. Newpipe is the way
    +1
  • FAST6191 @ FAST6191:
    3x playback speed and no adverts plus whole load of other things.
  • K3N1 @ K3N1:
    Until it gets a lawsuit notice
  • FAST6191 @ FAST6191:
    Not sure what path they would use for this one
  • FAST6191 @ FAST6191:
    On a different note entirely I randomly ended up on a hardware mods website. Lot of stuff for the GBA and DS it seems that I had missed entirely.
  • FAST6191 @ FAST6191:
    as well as the option to pay $2 for a surface mount standard fuse
  • Oleboy555 @ Oleboy555:
    i use re vanced
  • K3N1 @ K3N1:
    VPN YouTube premium $15 a year with a Turkey connection lol
  • M4x1mumReZ @ M4x1mumReZ:
    D, E, F, G...
  • cearp @ cearp:
    @FAST6191 - totally agree. not sure the reasons people use vanced/revanced over newpipe.
    I guess it's because of people still wanting to use their yt account (with vanced)?
    +1
  • cearp @ cearp:
    when I use newpipe, I am not signed in, no ads, have exportable watch lists etc... really good.
  • luotesi @ luotesi:
    Does anyone have a golden cheat for D2R v1.0.2.0?Like Money、Exp。
  • M4x1mumReZ @ M4x1mumReZ:
    Look elsewhere or make your own
  • Psionic Roshambo @ Psionic Roshambo:
    With hookers and booze!!!
  • x65943 @ x65943:
    damn that robot just knew to put the whole bottle of ketchup on the hamburger somehow
  • Sonic Angel Knight @ Sonic Angel Knight:
    Or put mustard on hamburger :ninja:
  • x65943 @ x65943:
    we are living in the future
  • K3N1 @ K3N1:
    Yeah cheese is a thing now
    K3N1 @ K3N1: Yeah cheese is a thing now